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Mesa Introduction

Mesa is a traditional spreadsheet program that runs on MAC OS X computers. Mesa 
looks and works similarly to Lotus 1-2-3 and Microsoft Excel. If you have used either of 
these programs, then Mesa should be very easy to learn. 

Please note that while Mesa works very much like 1-2-3 and Excel, Mesa does do things 
in slightly different ways or menu options will be located in different places. For example, 
Mesa uses a MAC OS X convention called Inspectors to achieve many results. Just 
because Mesa does not work the exact same way as 1-2-3 or Excel does not mean that 
Mesa cannot produce the same result. If you have questions, please contact us or look 
in the Help.

Mesa contains many features to make building worksheets and presenting data intuitive 
and efficient. Mesa has many other features to help you work more naturally. Please take 
some time to read through the Help so that you can discover more about Mesa. 

If you have questions, please contact P&L Software technical support team either via 
e-mail (mesa@plsys.co.uk) or by phone at 

(44) 1494 432422 

1.  Getting Started
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More about Mesa 

What is a spreadsheet?

A spreadsheet is a program that allows the user to enter data into matrix of cells. Each 
cell can be individually addressed based on its row and column number. In Mesa, rows 
are numbered from 1 to 16384 and columns are labeled from A to XFD. Each cell has a 
value and formatting information. The cell’s value is based on either its contents (e.g., a 
number like 5, or a string like Hello) or on a formula that is evaluated to result in the cell’s 
value. A value can be a number (e.g., 1, 4.7, 5280), a string (e.g., Hello, June Stock Prices, 
Eastern Region), or an error (e.g., !ERR, !/0). 

A formula can refer to the value in a cell during calculation. This is why spreadsheets are 
so powerful. Because the value in one cell can depend on the value in another cell, when 
the first cell is changed, the second cell updates itself properly. For example, if a cell 
contained the formula =A1+1, when the value in cell A1 is changed, the cell containing 
the formula automatically updates itself.

Cells also contain formatting information. This includes the text format of the display 
(e.g., General number, Scientific notation, Currency format), the color of the text, the 
background color of the cell, and more. Information can be presented in a more visually 
pleasing or informative manner by changing the cell formatting. Mesa allows some of 
the cell’s formatting to be changed by the cell’s formula so that a cell can automatically 
change its color if it contains certain values. This feature allows worksheets to alert the 
user to important cells that contain critical values.

Once the cells have been populated with values, and the spreadsheet has been formatted, 
it can be printed out, e-mailed to others, or saved. In addition, Mesa allows you to graph 
the values in cells to produce presentation-quality graphs and include those graphs in 
reports or copy the graphs or groups of cells and paste them into other MAC OS X 
applications. Mesa can also import data from Excel and some other common delimited  
text files.



Mesa User’s Guide         Release 3.0         3

CHAPTER 1         Getting Started 

Once the data has been entered into Mesa from various different sources, the formulas 
have been entered so that the raw data can be summarized, the formatting has been 
applied, and the charts and graphs have been created, you can print the worksheet in order 
to produce a presentation quality report. 

To find out more about Mesa’s capabilities we suggest you to take a quick tutorial tour.

Mesa for people who have used other spread-
sheets 

Mesa doesn’t actually look much like Excel or 1-2-3 (we think it looks better!), but it 
gives you lots of the same functionality. You get multiple worksheets in a workbook, all 
the usual editing options, over 100 functions, a great Report Designer, charts and much 
more. There are certainly some things in Excel and 1-2-3 that you don’t get (yet) in Mesa 
3D - pie charts and pivot tables being on testers wish lists at the moment. But we will be 
enhancing Mesa and making upgrades available on a regular basis. If you want to know 
if a feature is planned just mail us at mesa@plsys.com and we’ll get right back to you. It 
may even be in Mesa already, you just haven’t found it yet! 

The best way to get to know Mesa is to use the knowledge you already have of 
how spreadsheets behave, and to spend a little time browsing around menus and just 
experimenting. 

If you have time, work through the Tutorial, which takes you through building a work-
book. If you don’t have time or inclination for this, at least open up the Tutorial Examples 
folder (which came on the Mesa.dmg you downloaded) and open up the workbooks to see 
what a full Mesa workbook looks like. 

Here are a few things to try out after you’ve got used to the basics, just to save you the 
time of reading through all the Help files. 
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1. Inspectors. 

Mesa uses Inspectors to let you view and change the Properties of the element you’re on 
(which could be a cell, a chart, a report, etc.). This is where you change fonts, colors, 
sizes, formats, and more. The Inspector icon on the Toolbar is therefore very important for 
you. When you use Mesa for the first time, fill in a few cells with text and numbers, and 
then click the Inspector to see what you can do to those cells. 

2. Smart Copy 

Of course you can use Mesa’s copy and paste to copy a formula around the worksheet. 
But if you need to change the ‘original’ formula, then you have to go through the nuisance 
of remembering where you’d previously copied it to and copying the new formula over 
again. So Mesa gives you more than that with its smart NEXT () and SAME () functions 

Use Mesa’s Smart Fill Copy instead. To try it out, try the following. Enter some numbers 
in cells A1 through to G1; then go to cell A2, and enter a formula like ‘=a1+10%’. Then 
select A2 through to G2 and instead of the usual ‘Copy+Paste’ use the menu option: 
Range->Fill->Smart. Look at the formula in B2, C2 etc. Then change the formula in A2 to 
‘=a1-10%’ - all the ‘dependent’ cells immediately use the new formula too. On the same 
theme, go to cell A3 and type in ‘Jan’. Select A3 through to G3 and use Range->Fill-
>Smart again. Smartly, Mesa fills in the month names for you. Now change A3 to say 
‘January’ - all the others change to the full text month-names too. Now change A3 to say 
‘Monday’. Now ‘2001’. Now ‘Q1’…. 

3. Formula Builder

The Smart ‘NEXT ()’ and PREV () functions are unique to Mesa. But Mesa has a full 
set of Excel and 1-2-3 financial, math, and string, date etc functions. To find out more 
about them, click the Formulas icon in the Toolbar. You can see a list of all the functions 
we use, read a description of how to deploy them, and even build a formula to be copied 
into the worksheet at the same time. 
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4. Colors 

Lots of things look better when they’re colored - for example the content of cells, the 
background of cells, and all the different parts of charts. You can color these from the 
appropriate Inspector of course (just look for the colorwell on the Sheet Inspector, Cell 
Inspector or Chart Inspector and double-click it to bring up the Color Palette. But you can 
also drag colors directly off the Palette onto the part of your workbook you want to color. 
Set up the Palette with your favorite colors in the bottom boxes. 

* Drag a color onto a cell to change the text/number color 
* Select a group of cells and drag a color onto any one of those cells to change the  
 text/number color for the entire group · Hold down the Alt key and drag a   
 color onto a cell to change the background color for that cell 
* Select a group of cells and Alt-drag a color onto any one of those cells to change  
 the background color for the entire group. 
* Create a chart with the Chart Icon. Drag colors directly onto the data ranges, the 
 titles, the borders and so on. 

5. Printing 

There are three ways to get a printout of your spreadsheet data 

* Simply choose ‘Print’ from the Workbook menu. Follow the dialog boxes to  
 choose printer, orientation, scaling etc. Mesa will print all the data in your   
 worksheet from A1 to the bottom leftmost data item. 
* Select the area you want to print, and then choose ‘Print’ from the Workbook  
 menu. Follow the dialog boxes to choose printer, orientation, scaling etc. Mesa  
 will print the area you selected. 

Set up a Report. This method is useful when you want more control over the layout 
and/or want to print the same area of the workbook on a frequent basis (e.g. to print 
out a weekly report). 

Choose the Report icon from the toolbar and select a New report. 
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* Drag ‘tags’ like filename, path, date, time etc. to the position on the virtual page 
 that you want. 
* Drag the margins on the virtual page to the width you require 
* Choose as many Data Ranges as you want to print - they can be from different  
 worksheets in the workbook if you want - and set them to Smart Width to make  
 sure wide ranges are scaled automatically to fit the page layout 
* Use the Page Setup button to choose orientation etc. 
* Give the report a name 
* Print it out from the Report list. 

You can reprint this report (with the latest data of course) simply by selecting it from the 
Report list. Even better, you can drag the icon for that report onto your worksheet (just 
select it from the bottom left of the Report List), place it somewhere convenient on the 
sheet, and run the report just by clicking it’s icon.

6. Customizing the Toolbar 

The Toolbar along the top of every workbook comes with a ‘default’ set of tools. You 
can customize the toolset and use just the ones you want. Take the Window->Customize 
toolbar option, choose an option for the toolset you want to select from, and simply drag 
the icons into your toolbar. You can put in spaces and separator lines to group the icons 
in a way that meaningful for you. We love Smart Fill, so we usually put that onto our 
Toolbar, along with Copy, Paste and Clear… 
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What’s new in Mesa3
Users of Mesa 2 should read through this to get an idea of the new features available 
in Mesa 3. 

Summary

New User Interface Mesa 3.0 has been enhanced to make the User Interface compliant 
with Mac OS X standards and therefore more intuitive and easier to use. All icons have 
been completely redesigned. 

New features Mesa 3.0 includes:

* Customizable Toolbar
* Graphics in Reports
* SplitScreen formula bar
* Automatic Range updating in Reports, Queries, Extracts and Labels
* New Inspector panel
* Improved Formula Builder

Dates will now copy out of Mesa as strings, not numbers (settable in Preferences)   

Compatible with Mesa 2 

Mesa 3.0 is fully backwards compatible with Mesa 2. All your Mesa 2 worksheets 
(including reports, graphs, queries etc.) will load and work identically. All the features of 
Mesa 2 are still there in Mesa 3.0. However, if you are used to Mesa 2 you should invest a 
little time in exploring Mesa 3.0 to locate the menu options that you need. 
   
Revised User Interface

The worksheet, menus and Inspectors have been completely overhauled to make them 
Mac OS X compliant. 
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New Inspector panels

All icons have been completely redesigned to present a crisper and more pleasing effect

MAC OS X-Style help has been added

As you read through the new features below, you will see screenshots of the new-look 
Mesa. Here’s a full screen shot to give you an idea.

New-look Workbook

The Workbook window now includes an Icon Bar containing short-cut routes to the most 
frequently used panels. As in Mesa 2, the Save and Print icons can be replaced with any 
other icon you want using the customizable toolbar.
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The Toolbar

The new Toolbar lets you keep short-cut icons for anything you’d find useful. Bring 
up the Toolbar with Window->Customize toolbar or by selecting the Customize icon on 
the worksheet.

 The Toolbar is fully customizable so that you can set up the shortcuts that you need.You 
can choose among Icon only, Text only or choose both options.
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The Inspectors 

There are Mesa Inspectors for the following: 

Inspector You create and change
Sheet  Dimensions, general behavior
Borders Lines around cells
Cell Formats Display Formats
Cell Styles Font, Color etc.
Extracts Queries within the Mesa worksheet
Scenarios Scenario tables
Layers  Positioning of Graphic objects on the worksheet
Labels  Names for areas on the worksheets
Charts  Change charts created via the Chart Selector Tool

All Mesa Inspectors are grouped together in the Inspector Panel. Bring this up with Tools-
>Inspector or by selecting the Inspector icon on the Workbook.
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Select the inspector you want by selecting the appropriate Icon from the Toolbar on the 
top. QuickHelp works on all icons in your Inspector panel. The Inspector options for 
Charts will not be available unless you have either just created a new chart or have 
selected an existing chart on the worksheet.  
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Reports  

Mesa 3.0 uses a Report Designer Tool similar to the one in Mesa 2 to let you set up and 
save Reports. A Report is a a set of items to which you give:

* Sheet name
* the range(s) to print
* holding
* paper size/orientation
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* Header and Footer options (page numbering, dates, graphics etc.)
* general display options

You can create as many reports as you like, giving a different name to each one.

Putting a Graphic item on a report for Printing

New in Mesa 3.0 is the ability to place a graphic image file on your printout.
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Just find the image you want in the folder and drag it into the worksheet or report.

SplitScreen Formula Entry

You can make the Formula Entry area larger by dragging the ‘dimple’ at the top of the 
worksheet.

If you drag the Formula Entry area to zero size, then you can edit the cell contents 
directly in the cell.

Automatic Range Updating 

Ranges in Reports, Extracts, and Labels will fill automatically with the cell coordinates of 
the area currently selected on the worksheet.

To edit a defined range, select the range coordinates in the Report, Extract etc., and then 
click back in to the worksheet and reselect the area you require. This will automatically 
update the range.

Charts
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Mesa 3.0 has a new Chart Selection Panel and a redesigned Chart Inspector.

One major improvement is that once you have created a new Chart, the chart selection 
panel disappears from the screen and is replaced by the Chart Inspector, from which 
you can select different chart types. This removes the problem in Mesa 2 whereby users 
created several charts on top of one another on the worksheet!
Key usage

So many users asked us to change the behavior of ESC to be like Excel and 1-2-3 (ie, 
abandoning the entry) that we’ve done it! If you prefer ESC to behave like it did in Mesa 
2, use Preferences Keys and uncheck the ‘Escape Abandons’ box.

Dates as Strings

On the Preferences File menu you can now choose to have dates copy out of Mesa as 
strings rather than as numbers. This applies to Copy/Cut and Paste operations, and to the 
Export Delimited Text option.
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Getting Help

Use Help to raise the standard Help panel. 

You can navigate help by topics or by browsing the index, pages will also have some 
additional links to similar pages with similar topic.

Use the Mouse

Move the cursor by sliding the mouse over a smooth, flat surface. 

Position the cursor on an object such as a command, button, slider, or icon. 

Use a mouse button to click, drag, or double-click. 

Slide the mouse on a smooth surface to point the cursor at something on the screen. Then 
use a mouse button to perform an action on what you’re pointing at.

To click Without moving the mouse, press and release a mouse button.

To press Without moving the mouse, press a mouse button and hold it down. Pressing 
usually has the same effect as repeated clicking.

To drag Press and hold down a mouse button. Then move the cursor by sliding the mouse. 
Finally, release the mouse button. 

CHAPTER 1         Getting Started 
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To double-click Click twice in quick succession. This often extends the action caused 
by a single click.

If you run out of room while sliding the mouse, you can lift the mouse and put it back 
down somewhere else without moving the cursor. No matter how far you move the 
mouse, the cursor stays on the screen.

Buttons, Slides and Textelds

                                                                           Horizontal
         Sliding
         Bar

  Vertical
  Sliding
  Bar

        Text Field
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Buttons are labeled with text or graphics to show what they do. A dimmed button, shown 
in gray rather than black, is currently unavailable.(See image above)

You can move to the next text field in a window by pressing the Tab key. Hold down the 
Shift key and press Tab to move to the previous next field.

If a text field next to a slider shows a value for the current setting, you can type in the field 
and press Return to change the setting.

Work with Windows

To select a window to work in, click in it. 
To move it, drag it by its title bar. 

        To put it aside temporarily, click its miniaturize button. 

        To close it completely, click its close button. 

        To make it larger or smaller, drag its resize bar.
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         Miniaturized 
         Applications are
         placed in the  
         dock

The key window is the one where you’re currently working, other windows will have 
its title bar grayed out.

Clicking in a window brings it forward, in front of other windows, and makes it the 
key window. 

Double-click a mini-window to display the window full size.
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Scroll to See Me

To scroll one line, click a scroll button. 

To scroll continuously, press a scroll button or drag the scroll knob. 

To scroll quickly to an approximate location, click in the scroll bar. 

To scroll a windowful, hold down the Alternate key and click a scroll button. 

               scroller
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When a window contains more than can be displayed at once, you scroll to see what 
isn’t currently visible.

The scroll knob’s size and position indicate how much of the total contents you’re 
viewing and where you are.

The Alternate key is the key to the right of the space bar that, on most keyboards, is 
labeled “Alt.”
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2.  Mesa Basics

This chapter is about what to expect when you first launch Mesa, and how to set the 
application preferences; how to open, close, and save Mesa documents, how to use the 
Toolbar and how to quit the application.

Launching Mesa

To start Mesa, find the Mesa icon and double click on it.

Mesa icon 

The icon may be on your Dock, or within the File Viewer or on your desktop. Look for 
the file named Mesa3.app. 

If you are unfamiliar with the MacOS X operating environment, check the MacOS X 
online help. 

After Mesa starts, a new blank workbook opens automatically
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* This can also be done by typing Apple-n  
* You can open an existing model by finding it in the Workspace, selecting its icon 
 and double-clicking. 

Open Existing WorkBook

Choose the Open option from the Workbook menu to open an existing Mesa book or use 
Apple-O               command

CHAPTER 2         The Basics 



24           Release 3.0        Mesa User’s Guide

CHAPTER 2         The Basics 

The names of all files with an extension of Mesa, xls (Excel files), wks or wk1 (Lotus 123 
files) will be displayed in the browser.

* You can also open an existing book by finding it in the Workspace, selecting its 
 icon and double-clicking. 

Start New Work Book

Choose the New Sheet option from the Workbook menu to start a new Mesa sheet or 
use Apple+             command
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Save Workbook

There are several ways to save your work.

* Use Workbook->Save from the Mesa menu or Apple S           command or click on

 

* Click the Close button at the top left of the worksheet  
* Use Workbook->Save As from the Mesa menu or Apple              command 

If it is the first time you have saved a sheet, or if you have selected Workbook-> Save As, 
the Save panel appears. Use the browser to select a location and name for the file. 

Using Menus

Just like MAC OS X, Mesa has a hierarchical menu structure consisting of a main menu 
with subordinate menus, some of which have sub-menus of their own.
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A menu item that displays -> opens a sub-menu. 

If a menu item is grayed out then it is not available at the current moment. However, if 
you perform an action which makes that menu item possible, then the item will ungray 
and be usable again.

If a letter or punctuation mark appears at the far right of the menu item, that command can 
be executed either by clicking with the mouse on the menu item, or by holding down the 
Apple key while typing the indicated character.

EG Apple-S is the Shortcut Key for Workbook-Save

 * Menus can be dragged to any point on the screen and released to ‘stick’  
  at that point. 
 * Menu commands can be dragged as Icons into the Toolbar by using  
  Window->Customize Toolbar.
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Using Inspectors

The Inspector panel (accessed with Tools->Inspector or by clicking the Inspector icon 
on the Workbook Toolbar) provides a series of panels allowing you to manipulate items 
on the Mesa worksheet.

Inspectors are provided for:

* Sheet (formats and Templates)
* Cell Format
* Cell Style
* Data extraction
* Borders
* Display formats
* Events
* Scenarios
* Layers
* Labels
* Charts

Each Inspector provides an easy way to examine and change information about the item 
you’re inspecting.
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The Toolbar

The Toolbar is a panel in which you can stick icons representing menu actions, colors, 
fonts and more.

Use it to speed up your access to the commands you use most often.

The Toolbar is the key to your quick and easy use of Mesa.

The Toolbar is fully customizable so that you can set up the shortcuts that you need. 

Use Window->Customize toolbar to bring up the Toolbar window.

When you use Mesa for the first time, the Toolbar will have a standard set of icons on it.

You can remove or add icons just by dragging them. To add an icon to the Toolbar place 
the mouse over the Menu item you want to add, click and drag it on the toolbar. Apart 
from standard icons itself, there are Separator, Space and Flexible Space icons available 

for you to manage spacing between the icons on the toolbar.

Customize toolbar opens up three options.

* Common tools

* Recent menu selections

* All menu commands (this option can be further expanded)
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Common tools enables you to add some additional standard icons such as colors, fonts 
etc. 

Recent menu selections allows you the most recent commands you perform to be added 
as icons to your toolbar
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However in case you require some other icons, Mesa 3 allows you to select just about 
any icon you desire. By selecting All menu commands, and then further expanding its 
sub-menus you can add some more icons.

E.g. highlighting Paste special and clicking Continue button brings up all the paste special 
icons. 
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In case of no more space for all your desired icons, the icons not fitting in the toolbar can 
be seen by clicking double arrow on the right top window corner. 
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To hide the icons, click on the “Lozenge” button, that is clear button on the right hand top 
corner of the window (see the arrow)

For some extra help, have mouse hover for about 2 seconds over any icon to see a short 
description of what that icon does.

Quitting Messa

To finish a Mesa session, take the Quit option from the main menu. If you have any 
unsaved worksheets open, Mesa will prompt you asking whether you want to save 
them or not (individually) before quitting.
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The Workbook

The Workbook main window consists of three main areas.

The Spreadsheet: a set of cells laid out in rows and columns 

3.  Working with Workbooks
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The Formula Bar: where you type or view the text, numbers or formulas in the cells.

The Toolbar: a set of icons which act as shortcuts to frequently-used areas of Mesa.

As in other MAC OS X applications, there are Window buttons which can be selected to 
Miniaturize, Maximize or Close the window.

The Workbook window can be enlarged or shrunk by positioning the mouse in any corner 
of the window and dragging.

Moving Around the Sheet

You can move around the worksheet in many ways:

The cursor keys will move you one cell in the appropriate direction

Clicking in a cell with the mouse will move you to that cell

The Page-Up/Page Down indicators in the Window Frame will move you one screen 
up or down

The Scroll bars will move you gently in the direction you choose with the mouse

* ESC will either Abandon what you’re typing or enter a Move to A1, depending 
 on your Preferences setting
* The Tab key will move you one screenful to the right: Shift-Tab will move you 
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one screen to the left
* There are lots of other Shortcut key combinations to move you around (see below)
* Cell->Goto... will take you straight to any cell you specify
* Edit->Find is a handy way to jump to part of your worksheet by Cell Content.

Rows and Coloumns

All cells in the worksheet are accessed by specifying the intersecting row and column of 
the cell. For example, the cell in the upper left corner of the worksheet is cell A1. 

Columns

Rows

Rows

 The number in the Row Frame designates the row number. 

 The letter in the Column Frame designates the column letter.

 * Click on the Row Number in the Frame to select an 
  entire row

 * Click on the Column letter in the Frame to select an 
  entire  column
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Entering Data

Cells contain and display one of four things: 

* Text strings, such as Profits
* Values, such as 12
* Dates, such as 21-02-1996 
* Formulas, such as =A4+A5 

To enter data into an editable cell:

1. Move to the cell 
2. In the Formula Bar, enter a number, date or text string. 
3. Move away from the cell to enter the value 

* Values and dates can be formatted in any number of differing formats. For 
example, the number 12 can be displayed as “$12.00,” “£12,” “12” or “1.2e+01.”
* Once data is in a cell, it and its format can be copied and pasted into other cells.

Entering Text

Anything you type into the Formula Bar which contains a non-numerical character is 
considered by Mesa to be text.
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Field where you type in 
Formula

The exceptions to the above rule are items starting with the Formula Indicators =, +, -, and @

Text strings are automatically left-aligned in a cell. You can change the alignment by using the Cell Format Inspector.

Text strings have a value of zero if they are included (usually by mistake) in the range of a calculation
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Entering Numbers

Anything you type into the Formula Bar which contains nothing but numerical characters 
is considered by Mesa to be a number. 

Numbers are automatically right-aligned in a cell. You can change the alignment by using 
the Cell Format Inspector.
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Entering Dates

Dates have to be entered using a specific format, using the slash key ‘/’ as a separator 
e.g. 12/25/2001

In all cases, the date will display automatically by default in the format DD-Mon-YY

If you want to use European-style dates (DD/MM/YYYY) use the Mesa3 preferences 
panel to set this.

So the entry:

12/25/2001

will show as

25-Dec-2001

You can use the Mesa3->Preferences->Cell Display Preferences to control what the 
default date display is.

You can also format dates to look different from the default(for example, showing just the 
Month and Year) by using the Cell Format Inspector.

Mesa can do calculations with date cells. 

TIP: Use the function =now() to enter the current date.
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Copying Data

Copying is a two-stage operation. 

Select the range to be copied. Click Edit->Copy. Select the cell into which you want to 
put the data, and click Edit->Paste.

If you copy a formula, the cell references change relative to the new cell position of 
the formula.

If you copy text, numbers or dates, the copy is identical to the original entry.

Use Alt-Click as a Shortcut key to copy a cell or range of cells. Select the range to copy, 
and then Alt-Click on the top left cell of the position you want to paste to..

Range->Fill or Range->SmartFill is often a quicker way to copy data.

Data selected by a copy operation can be pasted into other MAC OS X applications.

Moving Data

Moving Data is a two-stage operation. 

Select the range to be copied. Click Edit->Cut. Select the cell into which you want to put 
the data, and click Edit->Paste.

If you copy a formula, the cell references change relative to the new cell position of 
the formula.

If you cut text, numbers or dates, the copy is identical to the original entry.
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Moving Data is a two-stage operation. 

Select the range to be copied. Click Edit->Cut. Select the cell into which you want to put 
the data, and click Edit->Paste.

If you copy a formula, the cell references change relative to the new cell position of 
the formula.

If you cut text, numbers or dates, the copy is identical to the original entry.

* You don’t have to paste after a cut. It can be used as another way of deleting 
 data from the worksheet. 
* Data selected by a cut operation can be pasted into other MAC OS X applications.

Pasting Data

Use the Paste command to place the contents of the MAC OS X pasteboard wherever 
you want on any worksheet. 

If the Pasteboard contains a TIFF or EPS image, Mesa will overlay that graphic image 
on your sheet.

You can Paste the current contents of the pasteboard over and over again. 

Data from other MAC OS X applications can be pasted into a Mesa worksheet. 

Editing Data

You edit data by selecting the cell you want to change, and clicking in the Formula Entry 
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area at the top of the worksheet.

You can use all the standard MAC OS X text selection operations to cut, copy, delete 
etc. your data.

When you finish editing, either press Enter or click away from the cell to save your 
changes

Use ESC to abandon any changes you’ve made.

Remember that you can drag the Formula Area larger or smaller. If you remove the 
formula area completely, you’ll be able to edit the cell contents ‘in-cell’.

Paste Special

Paste Special allows you to take data from the Pasteboard and paste it in - with a twist!

Paste Special is most commonly used to paste just data (i.e. no formatting information) or 
conversely just formatting information (i.e. no data) from another cell on the worksheet.
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Paste Values lets you paste the values from the cell range that was cut or copied into the 
pasteboard to another range without affecting its format or content. Note that the values 
in the pasted range will be frozen and formulas will be converted to their calculated 
values.

Paste Format lets you paste the format of the cell range that was cut or copied into the 
pasteboard to a specified location on a worksheet without pasting any included values.

Move lets you paste the contents of the cell range that was cut or copied into the 
pasteboard to a specified location on a worksheet. If the original range was copied to 
the pasteboard, this command clears the original range as it moves the data to the new 
one. Any references within the range to cells outside of the range still point to the same 

place.

You cannot Move ranges from one worksheet to another. To move a range from one 
worksheet to another, select the range in the first worksheet, Edit -> Cut it, and Edit -> 
Paste it into the second worksheet.

The Move operation is different from a Cut and Paste operation. If you Cut and Paste 
a range of cells, formulas that referred to the old location of the range continue to refer 
that location. If you Copy and Paste Special ->Move the cells, formulas elsewhere in your 
worksheet are updated to reflect the new location of the range.

Transpose places a copy of the cells on the clipboard at the current location on the 
worksheet, but transposes the rows and columns of the range. The cell in the second row 
and first column in the original range is placed in the first row and second column, etc.

Add adds the value in each cell on the pasteboard to the values in each cell of the 

selected range.

Subtract subtracts the value in each cell on the pasteboard from the values in each cell 
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of the selected range.

Multiply multiplies the values in the selected range by the value of each cell on the 
pasteboard.

Divide divides values in each cell of the selected range by the value on the pasteboard.

Undo

Use Edit->Undo to reverse the effect of the last action(s) you carried out.

You can undo your previous actions one at the time until you have reverted the Workbook 
to the state you require.

The undo command on the menu changes to show the action that will be undone.

Use Redo to move forward and “undo” your “undos”.

Redo

Use Edit->Redo to reverse the effect of Edit->Undo

You can Redo all the commands that you have “undone”.

Clearing data

“Clearing” is used in Mesa to mean removal of the data and formatting information in 
a selection.



Mesa User’s Guide         Release 3.0         45

CHAPTER 3         Working With Workbooks 

This is not the same as “Deleting” a selection. For example, if you Delete a row, the 
entire row is cut out of the worksheet. If you Clear a row, the data in the cells is removed 
but the row is still there.

Use Edit->Clear to clear a selection.

You can use Edit->Clear to remove a graph from the worksheet.

You can use the Backspace key to clear the contents of a cell.

Clearing Special

Clear Special allows you to clear only certain aspects of the selected cells.

You can clear:

just the formats (e.g. font, color, borders)

just the data (leaving the formatting intact)
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Numbers only (leaving all text intact)

Strings only (leaving all numbers intact)

Deleting Data

“Deleting” is used in Mesa to mean complete removal of the selected item from the 
worksheet.

This is not the same as “Clearing” or “Blanking” a selection. For example, if you Delete a 
row, the entire row is cut out of the worksheet. If you Clear the same row, the data in the 
cells is removed but the row is still there.

Use Edit->Delete to delete a selection.

Cols To delete columns, highlight the columns you wish to delete, and click the Delete 
command. Columns to the right of the deleted columns will be shifted to the left 
appropriately.

Rows To delete rows, highlight the rows you wish to delete, and click the Delete 
command. The Rows below the deleted rows will be shifted up appropriately.

Cells If you highlight one or more cells on your worksheet and click Delete, the data in 
the affected row(s) will shift to the left by the number of cells you highlighted.
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Finding a Data Item

Use Edit->Find to perform quick and easy searches of your worksheet in order to move 
to a particular cell.

Fill in the panel with the information you want to find. 

Next finds the next occurrence of the data moving Down the sheet.

Previous finds the next occurrence of the data moving Up the sheet.

There is no Replace option available within the Find panel.

Fill With Data

You can use Range->Fill instead of a Copy + Paste sequence if you want to copy the 
contents of a cell to adjacent cells.

Why? Fill is quicker because it uses only one command. The output from a Fill command 
is identical to that from a Copy + Paste sequence.

Select the cell containing the data you want to copy, and Drag to also select all the 

cells you want to copy the data into. Then use the appropriate Range->Fill command 
to paste the data in.

Fill and SmartFill do different things. Read about both of them before deciding which 
is most appropriate for you.
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Smart Fill

Use Fill->Smart to fill ranges with sequences of data. 

Select the cell containing the data you want to start the sequence with, and Drag to 
also select all the cells you want to copy the data into. Then use the appropriate Range-
>SmartFill command to paste the data in.

If the starter cell contains text, Mesa checks to see whether it recognizes the text. If so, 
the sequential cells are filled in using the NEXT() function. If not, Mesa tags a 1 on the 
end of the text and increases the number by 1 in subsequent cells.

If the starter cell contains a number, Mesa increases the number by 1 in subsequent cells 
using the NEXT() function.

If the starter cell contains a formula, Mesa mimics the normal Copy+Paste operation 
using the SAME() function.

In all cases, if the contents of the starter cell is changed, the adjacent cells will 
automatically take on new values based on the new starter cell. This is especially 
useful if a formula has to be changed.

Apple-Return is a useful Shortcut key for SmartFill

Time Sequences. Mesa knows about 

Days of the week

Months of the year

Quarters

Quarters and Years
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Numbers

Dates

For example, if you enter ‘May’ into A1 and SmartFill across to H1, the cells fill with 
‘May’ through to ‘November’.

Formulas

Calculations or ‘formulas’ are used to perform the main function of any spreadsheet - 
working with numbers.  Formulas can be short and simple or long and as complex as you 
require. They can contain: numbers cell addresses of Functions, to show Mesa that you’re 
putting a Formula into a cell, put the Equals sign = first. 

Here are some example formulas:  

=A1+A2 

=B3+25 

=SUM(J2.K50)
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Use the Formula Builder to help set up complex formulas or find out more about Mesa 
Functions.
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Converting Data

The Range->Convert sub-menu has the following commands:

Formulas to Values freezes the current values in the cell range that you selected. If you 
recalculate the worksheet, the frozen values will not change.

Strings to Numbers converts the string values in a given range to their number value. If a 
string cannot be converted, the cell is set to 0.

Numbers to Strings converts numeric entries in a range to their string value.

The Format->Text->Case sub-menu has the following commands:

To Upper Case converts string data in the cell or cell range that you selected to all 
capital letters.

To Lower Case converts string data in the selected cell or cell range to all lower case 
letters.

To Proper Case capitalizes the first letter of each word of string data in the selected 
cell or cell range

Multiple Worksheets

A Mesa workbook can contain up to 256 separate worksheets within it. Each worksheet 
has a name, shown on the TAB at the top of the workbook. The first worksheet is called 
“Sheet 1”, the next “Sheet 2’ and so on. 
You never have to use more than one worksheet, if you don’t want to. But it can make 
your life easier if you organize your work into separate sheets.
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The Head Office of a multinational might use a separate worksheet to hold the sales 
figures for each country they deal with, and have a ‘front’ worksheet to total up all the 
figures. 
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To change the name of a worksheet to something more meaningful, just double-click on 
the TAB name and type in the new name you want. You can use formulas to refer to cells 
in other worksheets. You can either use the mouse to ‘click and select’ the sheet and cells 
you want, or simply type the full cell reference yourself. 

To refer to a cell on a different worksheet, put the sheet name and a ‘!’ 
(bang) before the cell reference. For example: =”Japan”!A23*25% 
=”Japan”!A23+”France”!A23+”USA”!A23 If you change the name of a worksheet, all 
formulas referring to that sheet will automatically update and use the new name. 

Functions

 Functions And @Functions

 In order to provide compatibility with other spreadsheets, Mesa provides functions 
 both with and without a leading @ character. The two sets of functions are very  
 similar, but not always identical, when they are not the same, the @ version of the 
 function will be given a separate entry. 

 Functions without the @ character are compatible with Microsoft Excel functions; 
 function with the leading @ character are compatible with Lotus 1-2-3 functions.

 Entering a Formula Into a Cell

 Mesa recognizes an expression entered into a cell as a formula by the first 
 character of the expression. Formulas must begin with @, =, +, or -. The functions 
 in a formula are assumed to be the non @ character version of the functions unless 
 the @ character is included with each function, even if the formula began with 
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 an @ character. This means that in formulas that contain a mixture of @ and 
 non-@ functions, only the functions preceded by an @ character are @ functions.

 In Mesa, you can enter a formula into a cell by typing it directly into the formula 
 bar the same way you would enter numbers or strings, or you can build a formula 
 with the Formula Builder. 

 The Formula Builder is an inspector that contains a scrollable list of all of Mesa’s 
 functions, divided up into different categories. Clicking on a function will give 
 you a brief description of the function. The Formula Builder can be used to paste 
 the different functions together. 

 Use Tools->Formula Builder or click the Formula Builder icon on the Workbook  
 Toolbar to start the Formula Builder

 The highlighted function will appear in the formula bar. Edit any arguments  
 the function has by deleting the variable names from the function as it appears in  
 the formula bar, and replace them with appropriate values. By pasting in operators 
 and other functions, you can create large, complex formulas easily.

 Function Arguments

 Many of Mesa’s functions can take a variety of different arguments. In almost  
 all cases, Mesa’s functions can take the specified type of argument, an   
 expression that returns the specified type of argument, or the address of a cell  
 containing the specified type of argument. The following is a brief explanation of  
 what can be used as arguments in Mesa’s functions.

 

 Numbers

 Many of Mesa’s functions take numbers as arguments. The numbers can be  
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 entered directly into the formula, or they can be given as the cell address of a cell  
 containing to number. A blank cell has a value of zero.

 Occasionally a function needs a specific type of number. Here is a list of some of  
 the specific types of numbers that functions may take.

 Integer: a number with no fractional portion.

 1, 42, -28, 589

 positive number: any number with a value of zero or greater.

 0, 28, 39.541, 0.028

 Strings

 When strings are needed as arguments to functions, they can either be typed  
 directly into the formula, in which case they need to be place in quotation marks,  
 or the address of the cell containing the string may be given, in which case the  
 contents of the cell does not have to be in quotation marks. For example,   
 the following expressions both return START.

 =UPPER(“start”) 

 A

 1 start

 =UPPER(A1)

 Dates

 Mesa has a number of date related functions that take dates as their arguments. 
 In most cases these functions take a date serial number as their argument. (Specific 
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 exceptions are given in the function descriptions, see “Date Functions”.) 

 A date serial number is a number used by Mesa to represent dates so that they 
 may be formatted in a number of different ways. The number corresponds to the 
 number of days since January 1, 1970. Dates after the year 2000 can be specified 
 by placing a 1 before the year. The easiest way to obtain a date serial number 
 is to enter the desired date into a cell as you would normally, and give the address 
 of the cell containing the date.

 Cell Addresses

 A cell address in Mesa consists of the letter corresponding to the column of the  
 cell, and the number of the row of the cell. For instance, cell A1 is the cell in the 
 upper left hand corner of the worksheet. It is the cell in row one and column A.

 Some Mesa functions take a cell address as their argument. In most Mesa 
 functions, when you enter the address of a cell as an argument, the function  
 uses the contents of that cell as the argument. In a few functions, however, the    
 function is looking for information about the cell itself. This is the case  for  
 functions that ask specifically for a cell address as an argument.

 An example of a function that takes a cell address as its argument is the function 
 ISEMPTY, which checks to see if the cell at a given address is empty. 

 =ISEMPTY(U2)

 Ranges

 Ranges can also be used as arguments in Mesa’s functions. In some cases, the  
 function can take a list of numbers as arguments, and a range that contains  
 an appropriate list may be entered as an argument. In other cases, a function  
 may need to know the size an location of a database, and therefore needs a range 
 as an argument.
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 Ranges can be specified in one of two ways. The simplest way is to specify it by 
 giving the address of the cells in the upper left corner and lower right
    corner of the range separated by a colon.    
 For example A1:F10 is the range that occupies rows 1 through 10 of columns  
 A through F. You can also use the name of a ranged that was named using the  
 Label Inspector (See “Label Inspector”). If you had used the Label Inspector to 
 create a range named Rates, you could enter Rates as a range argument.

 =ROWS(A1:F10) -> 10

 =ROWS(Rates)

 Constants

 Mesa has a number of function constants that can be used as arguments in Mesa’s  
 functions. For a complete explanation of Mesa’s constants, see “Constants”.

 Expressions

 The arguments to functions can contain calls to other functions as well as formulas 
 containing constants and operators. As long as the formulas returns an appropriate 
 value,  it may be used as an argument for another function. In this way you can  
 create complex formulas using Mesa’s functions.

 Constants

 Color Constants

 Color constants are used by MAC OS X to specify how the amount of red, blue, 
 and green present in a given color. Color constants can be used in Mesa’s 
 functions to manipulate the color of cells and ranges. Here is a list of the available 
 color constants.

 BLACKCOLOR, @BLACKCOLOR
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 BLUECOLOR, @BLUECOLOR

 CYANCOLOR, @CYANCOLOR

 DKGRAYCOLOR, @DKGRAYCOLOR

 GREENCOLOR, @GREENCOLOR

 LTGRAYCOLOR, @LTGRAYCOLOR

 MAGENTACOLOR, @MAGENTACOLOR

 REDCOLOR, @REDCOLOR

 WHITECOLOR, @WHITECOLOR

 YELLOWCOLOR, @YELLOWCOLOR

 Format Constants

 Mesa uses the following format constants in its formatting functions. These f 
 ormats correspond to the different cell style formats in the Cell Style Inspector. 
 (See “Cell Style Inspector”.)

 GENERALFORMAT, @GENERALFORMAT: This constant is used to specify 
 the general format.

 =FORMAT(238.093, GENERALFORMAT) -> 238.093

 FIXEDFORMAT, @FIXEDFORMAT: This constant is used to specify the  
 fixed decimal format.

 =FORMAT(42.692, FIXEDFORMAT) -> 42.69
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SCIENTIFICFORMAT, @SCIENTIFICFORMAT: This constant is used to spec-
ify the  scientific notation format.

=FORMAT(1.69, SCIENTIFICFORMAT) -> 1.89e+01

CURRENCYFORMAT, @CURRENCYFORMAT: This constant is used to spec 
ify the  currency format.

=FORMAT(555.9, CURRENCYFORMAT) -> $555.90

COMMAFORMAT, @COMMAFORMAT: This constant is used to specify the 
comma format.

=FORMAT(238.093, COMMAFORMAT) -> 238.09

CHARTFORMAT, @CHARTFORMAT: This constant is used to specify the chart 
format.

=FORMAT(7, CHARTFORMAT) -> +++++++

PERCENTFORMAT, @PERCENTFORMAT: This constant is used to specify the 
percent format.

=FORMAT(0.09389, PERCENTFORMAT, 2) -> 9.39%

DMYFORMAT, @DMYFORMAT: This constant is used to specify the date day- 
month- year format.

=FORMAT(9876.54321, DMYFORMAT) -> 15-Jan-
 DAYMONFORMAT, @DAYMONFORMAT: This constant is used to 
specify date day-month format.

=FORMAT(9876.54321, DAYMONTHFORMAT) 
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 -> 15-Jan

 MONYEARFORMAT, @MONYEARFORMAT: This constant is used to specify 
 date month-year format.
 
 =FORMAT(9876.54321, MONYEARFORMAT) 

 -> Jan-97

 HMSFORMAT, @HMSFORMAT: This constant is used to specify date hours-
 minutes-seconds format.

 =FORMAT(9876.54321, HMSFORMAT) 

 -> 1:02:13 PM

 HOURMINFORMAT, @HOURMINFORMAT: This constant is used to specify 
 date hours-minutes format.
 
 =FORMAT(9876.54321, HOURMINFORMAT) 

 -> 1:02 PM

 DINTL1FORMAT, @DINTL1FORMAT: This constant is used to specify the  
 numeric date month-day-year format.

 =FORMAT(9876.54321, DINTL1FORMAT) 

 -> 01/15/97

 DINTL2FORMAT, @DINTL2FORMAT: This constant is used to specify the  
 numeric date month-day format.

 =FORMAT(9876.54321, DINT2FORMAT) -> 01/15
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 TINTL1FORMAT, @TINTL1FORMAT: This constant is used to specify twenty  
 four hour time format with seconds.

 =FORMAT(9876.54321, TINTL1FORMAT)

 -> 13:02:13

 TINTL2FORMAT, @TINTL2FORMAT: This constant is used to specify twenty  
 four hour time format without seconds.

 =FORMAT(9876.54321, TINTL2FORMAT) -> 13:02

 Math Constants

 Mesa uses the following mathematical constants in its functions.

 PI, @PI: The area of a circle of radius one, approximately 3.14159.

 RANDOM, RAND, @RAND: This function returns a random number between  
 zero and one, including zero and excluding one.

 Date Constants

 Mesa uses the following date constants in its date functions to specify current 
 date or time.
 NOW, @NOW: Returns the current date serial number.

 TODAY, @TODAY: Returns the current date serial number without the current 
 time, so that the serial number only contains the day month and year information.

 Special Constants

 CURRENTNUMBER or @CURRENTNUMBER: The current numeric value of  
 a cell. Can be used for time series functions. To reset a cell containing this   
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 constant, use Edit ® Clear Special ® Reset.

 To remember the largest number entered into cell A1, use

 =if(a1 > currentnumber,a1,currentnumber).

 To count the number of times the worksheet was recalculated, use

 currentnumber + 1
 
 CURRENTVALUE or @CURRENTVALUE: The current value of the cell (before 
 the recalc). This is useful for comparing old cell values with other values, such as 
        taking the larger of the current value or the value of another cell.To reset a 
 cell containing this constant, use Edit ® Clear Special ® Reset.
 
 ERR or @ERR: Returns an error. All cells that refer to a cell with an error will 
 evaluate to errors as well.

 ERRORCONST: Returns an error. All cells that refer to a cell with an error will 
 evaluate to errors as well.

 FALSE(), FALSE or @FALSE: Returns a logical false value.

 FILENAME or @FILENAME: Returns the filename of the current worksheet.

 HOSTNAME, or @HOSTNAME: Returns the name of the machine that Mesa 
 is running on.

 NA or @NA: Returns a special error, NA. All cells that refer to a cell with an  
 error will evaluate to errors as well. @NA is useful to designate cells that have a  
 value that is not available or defined.

 NACONST: Returns a special error, NA. All cells that refer to a cell with an error  
 will evaluate to errors as well. NACONST is useful to designate cells that have a  
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 value that is not available or defined.

 PATHNAME or @PATHNAME: Returns the path of the current worksheet.

 THISCOLUMN: Returns the column number of the cell containing this constant.

 THISROW: Returns the row number of the cell containing this constant.

 TRUE(), TRUE or @TRUE: Returns a logical true value.

 USERNAME, or @USERNAME: Returns the user’s login name.

 Database Functions

 For more information about criteria ranges, see “Criteria Ranges”  .

 DAVE, or DAVERAGE

 Takes the average of numeric records that match criteria.

 DAVE(database, offset, crit)

 database the range address of the database

 offset the offset of the column to be averaged

 crit the criteria range

 This function takes a range and averages all the numbers in the column at the 
 offset value from the first column of the range that meet the criteria defined in 
 another column.

 This is a sample database:
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A B C

1 NAME GRADE GPA GRADE

2 Joe B 3.2 B

3 Sue A 4.7

4 Robert C 2.7

5 Steve A 4.5

6 Ann B 4.2

The database range is A1:C6. The criteria range is D1:D2.

To calculate the average GPA of everyone who earned a B use this formula:

=DAVE(A1:C6,2,D1:D2) -> 3.7

@DAVE or @DAVG

Takes the average of numeric records that match criteria. Strings have a value 
of zero.

@DAVE(database, offset, crit)

database the range address of the database
offset the offset of the column to be averaged

crit the criteria range

This function takes a range and averages all the numbers in the column at the 
offset value from the first column of the range that meet the criteria defined in 



Mesa User’s Guide         Release 3.0         65

CHAPTER 3         Working With Workbooks 

another column. This function is basically the same as DAVE() or DAVERAGE() 
except that those function ignore string values.

This is a sample database:

A B C

1 NAME GRADE GPA GRADE

2 Joe B 3.2 B

3 Sue A 4.7

4 Robert C 2.7

5 Steve A 4.5

6 Ann B 4.2

The database range is A1:C6. The criteria range is D1:D2.

To calculate the average GPA of everyone who earned a B use this formula:

@DAVE(A1:C6,2,D1:D2) -> 3.7

DCOUNT or @DCOUNT

Counts all the numeric items matching criteria in the column offset from the upper 
left corner of the database range.

DCOUNT(database, offset, crit)

database the range address of the database
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offset the offset of the relevant column

crit the criteria range

This function takes a range and counts all the numbers in the column at the 
offset value from the first column of the range that meet the criteria defined in 
another column.

This is a sample database:

A B C D

1 NAME GRADE GPA GRADE

2 Joe B 3.2 B

3 Sue A 4.7

4 Robert C 2.7

5 Steve A 4.5

6 Ann B 4.2

The database range is A1:C6. The criteria range is D1:D2.

To count the number of students who earned B’s use this formula:

=DCOUNT(A1:C6,1,D1:D2) -> 2

DMAX

Returns the maximum numeric value of the records in database that match criteria.
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DMAX(database, offset, crit)

database the range address of the database

offset the offset of the relevant column

crit the criteria range

This function takes a range and finds the maximum number of the numbers in the 
column at the offset value from the first column of the range that meet the criteria 
defined in another column.

This is a sample database:

A B C D

1 NAME SALES REGION REGION

2 Joe 3000 East East

3 Sue 4500 North

4 Robert 2800 East

5 Steve 3700 South

6 Ann 2400 West

The database range is A1:C6. The criteria range is D1:D2.

To find the largest sales figure in the Eastern region use this formula:

=DMAX(A1:C6,1,D1:D2) = 3000
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@DMAX

Returns the maximum value of the records in database that match criteria. Strings 
have a value of zero.

@DMAX(database, offset, crit)

database the range address of the database

offset the offset of the relevant column

crit the criteria range

This function takes a range and finds the highest number of the numbers in the 
column at the offset value from the first column of the range that meet the criteria 
defined in another column. Strings are assumed to have a value of zero. This 
function is basically the same as DMAX except that those function ignore string 
values

This is a sample database:

A B C D

1 NAME SALES REGION REGION

2 Joe 3000 East East

3 Sue 4500 North
4 Robert 2800 East

5 Steve 3700 South

6 Ann 2400 West
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The database range is A1:C6. The criteria range is D1:D2.

To find the largest sales figure in the Eastern region use this formula:

@DMAX(A1:C6,1,D1:D2) -> 3000

DMAX() and @DMAX differ in that DMAX ignores string values and @DMAX 
treats strings as having a value of zero.

DMIN

Returns the smallest numeric item in the records that match the criteria.

DMIN(database, offset, crit)

database the range address of the database

offset the offset of the relevant column

crit the criteria range

This function takes a range and finds the minimum number of the numbers in the 
column at the offset value from the first column of the range that meet the criteria 
defined in another column.

This is a sample database:

A B C D
1 NAME SALES REGION REGION

2 Joe 3000 East East

3 Sue 4500 North
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4 Robert 2800 East

5 Steve 3700 South

6 Ann 2400 West

The database range is A1:C6. The criteria range is D1:D2.

To find the smallest sales figure in the Eastern region use this formula:

=DMIN(A1:C6,1,D1:D2) = 2800

@DMIN

Returns the smallest numeric item in the records that match the criteria. String 
values will count as zeros.

@DMIN(database, offset, crit)

database the range address of the database

offset the offset of the relevant column

crit the criteria range

This function takes a range and finds the minimum number of the numbers in 
the column at the offset value from the first column of the range that meet the 
criteria defined in another column. Strings are assumed to have a value of zero. 
This function is basically the same as DMIN except that those function ignore 
string values

This is a sample database:

A B C D
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1 NAME SALES REGION REGION

2 Joe 3000 East East

3 Sue 4500 North

4 Robert 2800 East

5 Steve 3700 South

6 Ann 2400 West

The database range is A1:C6. The criteria range is D1:D2.

To find the smallest sales figure in the Eastern region use this formula:

@DMIN(A1:C6,1,D1:D2) -> 2800

DMIN() and @DMIN() differ in that DMIN() ignores strings, while @DMIN() 
treats strings as having a value of zero.

DPROD

Returns the product of all the items matching the criteria in the column offset from 
the upper left corner of the range. Strings are ignored.

DPROD(database, offset, crit)
database the range address of the database

offset the offset of the relevant column

crit the criteria range
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This function takes a range and multiplies all the numbers in the column at the 
offset value from the first column of the range that meet the criteria defined in 
another column.

This is a sample database:

A B C D 

1 GATE PATH % PASSING PATH

2 1 North 0.96 East

3 2 South 0.95 

4 3 West 0.97 

5 4 East 0.95

6 5 East 0.93

7 6 North 0.88

8 7 West 0.92

9 8 East 0.99

10 9 South 0.94

The database range is A1:C10. The criteria range is D1:D2.

To find the product of the percentages for the East path use this formula:

=DPROD(A1:C10, 2, D1:D2) -> 0.874665
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@DPROD

Returns the product of all the items matching the criteria in the column offset from 
the upper left corner of the range. Strings are treated as zero values.

@DPROD(database, offset, crit)

database the range address of the database

offset the offset of the relevant column

crit the criteria range

This function takes a range and multiplies all the numbers in the column at the 
offset value from the first column of the range that meet the criteria defined in 
another column. Strings are treated as having a value of zero. This function is 
basically the same as DPROD except that those function ignore string values

This is a sample database:

A B C D 

1 GATE PATH % PASSING PATH

2 1 North 0.96 East

3 2 South 0.95 

4 3 West 0.97 

5 4 East 0.95

6 5 East 0.93
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7 6 North 0.88

8 7 West 0.92

9 8 East 0.99

10 9 South 0.94

The database range is A1:C10. The criteria range is D1:D2.

To find the product of the percentages for the East path use this formula:

@DPROD(A1:C10, 2, D1:D2) -> 0.874665

DPROD() and @DPROD differ in that DPROD() ignores string values, but 
@DPROD() treats strings as having a value of zero.

DSTDDEV or DSTDEV

Returns the standard deviation of the numeric records that match the criteria.

DSTDEV(database, offset, crit)

database the range address of the database

offset the offset of the relevant column

crit the criteria range

This function takes a range and finds the standard deviation of the numbers in the 
column at the offset value from the first column of the range that meet the criteria 
defined in another column.

This is a sample database:
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A B C D

1 STATE REGION AVG RF REGION

2 AL South 3.7 West

3 CA West 2.1

4 NJ East 5.2

5 FL South 4.9

6 LA South 6.8

7 TX West 5.0

8 MA North 7.6

9 AZ West 2.2

10 NV West 2.4

The database range is A1:C10. The criteria range is D1:D2.

To find the standard deviation of rainfall in the Western region use this formula:

=DSTDEV(A1:C10,2,D1:D2) -> 1.2029
@DSTD

Returns the standard deviation of the records that match the criteria. Strings have 
a value of zero.

@DSTD(database, offset, crit)



76           Release 3.0        Mesa User’s Guide

CHAPTER 3         Working With Workbooks 

database the range address of the database

offset the offset of the relevant column

crit the criteria range

This function takes a range and finds the standard deviation of the numbers in 
the column at the offset value from the first column of the range that meet the 
criteria defined in another column. Strings are assumed to have a value of zero. 
This function is basically the same as DSTDEV except that those function ignore 
string values

This is a sample database:

A B C D

1 NAME SALES REGION REGION

2 Joe 3000 East East

3 Sue 4500 North

4 Robert 2800 East

5 Steve 3700 South

6 Ann 2400 West
The database range is A1:C10. The criteria range is D1:D2.

To find the standard deviation of rainfall in the Western region use this formula:

@DSTD(A1:C10,2,D1:D2) -> 1.2029
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DSUM or @DSUM

Sums all the items matching criteria in the column offset from the upper left 
corner of the database range.

DSUM(database, offset, crit)

database the range address of the database

offset the offset of the relevant column

crit the criteria range

This function takes a range and sums all the numbers in the column at the offset 
value from the first column of the range that meet the criteria defined in another 
column.

This is a sample database:

A B C D

1 STATE REGION AVG RF REGION

2 AL South 3.7 South

3 CA West 2.1

4 NJ East 5.2
5 FL South 4.9

6 LA South 6.8

7 TX West 5.0
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8 MA North 7.6

9 AZ West 2.2

10 NV West 2.4

The database range is A1:C10. The criteria range is D1:D2.

To find the total amount of rainfall for the Southern region use this formula:

=DSUM(A1:C10,2,D1:D2) -> 15.4

DVAR

Returns the variance of the numeric records that match the criteria. Strings are 
ignored.

DVAR(database, offset, crit)
database the range address of the database

offset the offset of the relevant column

crit the criteria range

This function takes a range and finds the variance of the numbers in the column 
at the offset value from the first column of the range that meet the criteria defined 
in another column.

This is a sample database:

A B C D

1 STATE REGION AVG RF REGION
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2 AL South 3.7 West

3 CA West 2.1 South

4 NJ East 5.2

5 FL South 4.9

6 LA South 6.8

7 TX West 5.0

8 MA North 7.6

9 AZ West 2.2

10 NV West 2.4

The database range is A1:C10. The criteria range is D1:D2.

To find the variance of rainfall in the Southern and Western regions use this 
formula:

=DVAR(A1:C10,2,D1:D3) -> 2.7192

@DVAR

Returns the variance of the records that match the criteria. Strings have a value 
of zero.

@DVAR(database, offset, crit)

database the range address of the database
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offset the offset of the relevant column

crit the criteria range

This function takes a range and finds the variance of the numbers in the column 
at the offset value from the first column of the range that meet the criteria defined 
in another column. Strings are treated as having a value of zero. This function is 
basically the same as DVAR except that those function ignore string values

This is a sample database:

A B C D

1 STATE REGION AVG RF REGION

2 AL South 3.7 West

3 CA West 2.1 South

4 NJ East 5.2

5 FL South 4.9

6 LA South 6.8

7 TX West 5.0

8 MA North 7.6
9 AZ West 2.2

10 NV West 2.4

The database range is A1:C10. The criteria range is D1:D3.
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To find the variance of rainfall in the Southern and Western regions use this 
formula:

@DVAR(A1:C10,2,D1:D3) -> 2.7192

DVAR() and @DVAR() are different in that DVAR() ignores string values, while 
@DVAR treats strings as having a value of zero.

Date Functions

CONVDATE or @CONVDATE

Converts a number in the format YYMMDD to a date serial number. 

CONVDATE(date)

date a date given in YYMMDD format

Mesa stores dates in terms of date serial numbers that can be used in various date 
functions, and then translated back into the desired format. Dates after the year 
2000 can be specified by placing a 1 before the year.

=CONVDATE(930210) -> 8441 : This is the date-number of 10-Feb-93

=CONVDATE(1100410) -> 14709 : This returns the date number of 10-Apr-2010.

DATE or @DATE

Returns a date serial number for the year, month and day. 

DATE(yr, mon, day)
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yr the year since 1900

mon the month

day the day of the month

A date serial number is a number used by Mesa to represent dates so that they 
may be formatted in a number of different ways. The number corresponds to the 
number of days since January 1, 1970. Dates after the year 2000 can be specified 
by placing a 1 before the year.

=DATE(92,8,24) -> 8271 : This is the date number for 24-Aug-92.

=DATE(79,10,31) -> 3590 : This is the date-number for 31-Oct-79.

DATEVALUE, DAYS or @DATEVALUE

Datevalue converts a date string to a date serial number. If the value is a number 
it just returns the number.

DATEVALUE(dtstr), DATEVALUE(num)

dtstr a string corresponding to a date

num any number

This function converts dates entered as strings into the date serial number used by 
Mesa’s date functions. This function will not effect numeric input.
=DATEVALUE(“02/04/92”) = 8069

A3: ‘Jul-94

=DATEVALUE(A3) = 8947 : This is the date number for 1-Jul-94
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DAY or @DAY

Returns the day of the month for a date serial number.

DAY(date)

date a date serial number

DAY returns the day of the month for a date serial number date. The date can also 
be a reference to a cell containing a date.

@day(9131) -> 4

A3: 18-Jul-92

=DAY(A3) -> 18

=DAY(NOW) : This formula will return the current day of the month.

HOUR or @HOUR

Returns the hour for a date serial number.

HOUR(date)

date a date serial number

HOUR returns the hour for a date serial number date. The date can also be a 
reference to a cell containing a date. If a time is specified in a cell, but no date is 
specified, the integer portion of the date serial number is assumed to be zero.

=HOUR(TIMEVALUE(“23:00:00”)) -> 23

=HOUR(NOW) : This formula will return the current hour of day.
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MINUTE or @MINUTE

Returns the minute for a date serial number.

MINUTE(date)

date a date serial number

MINUTE returns the minutes from a date serial number date. The date can also be 
a reference to a cell containing a date. If a time is specified in a cell, but no date is 
specified, the integer portion of the date serial number is assumed to be zero.

=MINUTE(TIMEVALUE(“11:35:20”)) -> 35

=MINUTE(NOW) : This formula will return the current number of minutes past 
the hour.

MONTH or @MONTH

Returns the month for a date serial number.

MONTH(date)

date a date serial number

MONTH returns the month of the year for a date serial number date. The date can 
also be a reference to a cell containing a date.
=MONTH(DATEVALUE(“12/24/92”)) -> 12

=CHOOSE(MONTH(NOW)-
1,”Jan”,”Feb”,”Mar”,”Apr”,”May”,”Jun”,”Jul”,”Aug”,”Sep”,”Oct”,”Nov”,”Dec”) 
: This formula will display the current month.
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NETWORKDAYS or @NETWORKDAYS

Returns the number of working days between the given dates.

NETWORKDAYS(date1, date2[,holidays])

date1 the starting date serial number

date2 the ending date serial number

holidays the serial numbers of any intermediate holidays

This function allows you to determine the number of working days between the 
two dates date1 and date2. You can optionally list any holidays that fall between 
the two dates, which will not be counted as working days.

=NETWORKDAYS(NOW,NOW+10) : This returns the number of working days 
between now and 10 days from now.

NEXTMONTH or @NEXTMONTH

Returns a date serial number one calendar month after date. 

NEXTMONTH(date)

date a date serial number

This function returns the date serial number of the date one month from the given 
date. If the day of the month is greater than 28, then it is set to 28.

A3: 27-Jul-92

=NEXTMONTH(A3) -> 8274 : This is the date-number for 
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27-Aug-92.

=NEXTMONTH(11381) -> 11409 : This is the date-number for 28-Mar-2001.

NEXTYEAR or @NEXTYEAR

Returns the next year of the date. 

NEXTYEAR(date)

date a date serial number

This function returns the date serial number of the date one year from the given 
date. If the date is 2/29 of a leap year, the date returned is 2/28 of the following 
year.

=NEXTYEAR(NOW) : This formula returns a date-number one year from the 
current date.

=NEXTYEAR(DATE(93,6,20)) -> 8936 : This is the date-number for 20-Jun-94.

SECOND or @SECOND

Returns the seconds of a date serial number.

SECOND(date)

date a date serial number
SECOND returns the seconds from a date serial number date. The date can also be 
a reference to a cell containing a date. If a time is specified in a cell, but no date is 
specified, the integer portion of the date serial number is assumed to be zero.

=SECOND(TIMEVALUE(“10:31:19”)) -> 19
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=SECOND(0.26903) -> 24 : This formula returns the seconds for the date-value 
for 06:27:24 AM.

TIME or @TIME

Returns a date serial number for a given time.

TIME(hr, min, sec)

hr the hour, from 0 to 23

min the minutes

sec the seconds

This function takes the time, for a given 24 hour time into the corresponding date 
serial number used by Mesa’s date functions. 

=TIME(11,30,00) -> 0.479167 : This is the date-number for 11:30 AM.

=NOW+TIME(8,0,0) : This formula returns a date-number for the time 8 hours 
from now.

TIMEVALUE or @TIMEVALUE

Converts a string to a date serial number.

TIMEVALUE(time-str)
time-str a string corresponding to a time

This function converts time entered as string into the date serial number used by 
Mesa’s date functions. 

A1: ‘10
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A2: ‘58

A3: ‘29

=TIMEVALUE(A1&”:”&A2&”:”&A3) = 0.45728 : This formula takes the string 
contents of cells A1, A2 & A3 and concatenates them into the string “10:58:29”, 
then converts that string to a time value.

A3: 12:34 am

=TIMEVALUE(A3) -> 0.023611 : This is the date-number for 12:34 am.

WEEKDAY or @WEEKDAY

Returns the day of the week for a date serial number, 0 - Sunday through 6 - 
Saturday.

WEEKDAY(date)

date a date serial number

This function is useful in determining what day of the week a given date serial 
number is. 

=WEEKDAY(NOW-5) : This returns the day of the week 5 days prior to today.

A7: “6/20/82”
=WEEKDAY(DATEVALUE(A7)) -> 0 : Returns the day of the week for 
20-Jun-82.

WORKDAY or @WORKDAY

Returns the date serial number a given number of working days from the date 
serial number. Working days are all days other than Saturday, Sunday, and the 
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optional holidays listed.

WORKDAY(date, days [,holidays])

date a date serial number

days any number of days

holidays the serial number of any intermediate holidays

This function takes a date serial number and determines the date serial number 
of the day a given number of working days from then. If there are any holidays 
listed, they will not be counted as working days by this function. You may list 
any combination of dates, cell addresses containing dates, and ranges containing 
dates as arguments for holidays.

=WORKDAY(NOW,10) : This returns the date serial number 10 working days 
from now.

YEAR or @YEAR

Returns the year for a date serial number.

YEAR(date)

date a date serial number

YEAR returns the year for a date serial number. The date can also be a reference 
to a cell containing a date.

=YEAR(NOW-1000) : This returns the year of the date 1,000 days prior to the 
current date.

A7: ‘6/20/82
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=YEAR(DATEVALUE(A7)) -> 82 : This formula extract the year from the date-
string “6/20/82”.

Financial Functions

CALCRATE or @CALCRATE

Calculates the interest rate on an investment, given its present value, the amount 
of each payment, and the number of payment periods.

CALCRATE(pv, pmt, per)

pv the present value of the investment

pmt the amount of each payment

per the number of payment periods

Given an investment with a present value of pv, payments of pmt, and per 
payment periods, the CALCRATE function returns the interest rate such that pv= 
@PV(pmt,rate,term). See “@PV” .

Find the monthly interest rate of a 36 month car loan on $17,000 with a monthly 
payment of $500:

=CALCRATE(17000,500,36) = 0.31% per month or 3.75% per year.

@CTERM

Computes the number of periods required for an investment to grow to the 
specified Future Value with a given interest rate.

@CTERM(rate, fv, pv)
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rate the interest rate

fv the desired Future Value of the investment

pv the Present Value of the investment

Given an investment with a Present Value of pv, the @CTERM function returns 
the number of periods required for it to grow to a Future Value of fv at an interest 
rate of rate.

How long will it take for a $20,000 investment to grow to $40,000 at an annual 
rate of 5%?

@CTERM(0.05,20000,40000) -> 14.2 years

How many months will it take for a $4,000 investment to grow to $8,000, being 
compounded monthly at a rate of 8%?

@CTERM(8%/12,4000,8000) -> 104 months (about 8 1/2 years)

DDBor @DDB

Computes the Double Declining Balance depreciation for an asset.
DDB(cost, salvage, life, per)

cost the original cost of the asset

salvage the salvage value of the asset

life the expected life of the asset

per the number or periods for the depreciation calculation
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Given an asset that has a cost of cost, a salvage value of salvage, and a life 
of life periods, the DDB function will return the depreciated value of the asset 
after per periods. 

A company buys a delivery van for $12,000. It has a useful life of 5 years and will 
be worth $2,000 at the end of that time. How much depreciation can the company 
write off in years 1,2 and 3?

year 1: =DDB(12000,2000,5,1) -> $4,800

year 2: =DDB(12000,2000,5,2) -> $2,880

year 3: =DDB(12000,2000,5,3) -> $1,728

FVor @FV

Computes the Future Value of a series of payments, given a specified interest 
rate. An optional present value and starting time for the first payment may be 
specified.

FV(rate, per, pmt[, pv[, type]])

rate the interest rate
per the number of payments

pmt the size of each payment

pv the Present Value

type the starting time of the first payment

Returns the Future Value of a stream of payments over per periods at rate interest 
rate. If present value pv is not specified, it is assumed to be 0. Type designates 
when the payments start.
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If $2,000 were deposited every year into an account earning 9% annual interest, 
how much would the account be worth in 20 years?

=FV(9%,20,-2000) -> $102,320.24

If a $50,000 were deposited instead and accrued 9% interest from the start of the 
year, what would the account be worth in 20 years?

=FV(9%,20,,-50000,1) -> $ 280,220.54

IRR

Calculates the Internal Rate of Return of an investment.

IRR(guess, num1, num2, ...), IRR(guess, range1, ...)

guess any number

num any number

range any worksheet range
IRR() calculates the internal rate of return for a series of cash flow values. Each 
value represents either a payout (a negative value) or a payment received (positive 
value). The internal rate of return is the interest rate used to discount future cash 
flows such that the net present value of all the cash flows is zero. You may list any 
combination of numbers, cell addresses, and ranges as arguments.

A rug-cleaning business is being offered for sale for $180,000. The owner says the 
business should net $25,000, $35,000, $39,000, $40,000 and $55,000 in years 1-5. 
What is this project’s internal rate of return?

A
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1 -180000

2 25000

3 35000

4 39000

5 40000

6 55000

The initial expense is entered as a negative number in cell A1. The range of cash 
inflows are given in cells A2:A6. To calculate this project’s IRR value:

=IRR(B1,A1:A6) -> 2.3%

@IRR

Computes the Internal Rate of Return of an investment. String entries are consid-
ered zero values.
@IRR(guess, num1, num2, ...), @IRR(guess, range1, ...)

guess any number

num any number

range any range

@IRR() calculates the internal rate of return for a series of cash flow values. Each 
value represents either a payout (a negative value) or a payment received (positive 
value). The internal rate of return is the interest rate used to discount future cash 
flows such that the net present value of all the cash flows is zero. You may list any 
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combination of numbers, cell addresses, and ranges as arguments.

A rug-cleaning business is being offered for sale for $180,000. The owner says the 
business should net $25,000, $35,000, $39,000, $40,000 and $55,000 in years 1-5. 
What is this project’s internal rate of return?

A

1 -180000

2 25000

3 35000

4 39000

5 40000

6 55000

The initial expense is entered as a negative number in cell A1. The range of cash 
inflows are given in cells A2:A6. To calculate this project’s IRR value:

@IRR(B1,A1:A6) -> 2.3%

NPV

Computes the Net Present Value of an investment with a given stream of cash 
flows at a given interest rate. String values are ignored.

NPV(rate, pmt1[, pmt2[, ...]])

rate the interest rate
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pmt a number or range - the payment amounts

Given an interest rate of rate and payments pmt1, pmt2, etc., the NPV function 
returns the Net Present Value of the stream of payments. Each payment can be 
a value or a range. If it is a range, each of the numbers in the range is included 
in the calculation. You may list any combination of numbers, cell addresses, and 
ranges as arguments for pmt.

An apartment building is being offered for sale for $400,000. Expected rental 
incomes for years 1-5 are $79,000, $85,000, $85,000, $103,000 and $120,000 and 
the interest rate is expected to stay close to 7%. Is this a worthwhile investment?

A

1 -400000

2 79000

3 85000

4 85000

5 103000

6 120000

To figure out the net present value of the cash in-flows:

=NPV(7%,A2:A6) -> $381,596

To figure out the value of the project:

Project Value = Initial Cost + NPV
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+A1+NPV(7%,A2:A6) -> -$18,404

No, this project is not worthwhile.

@NPV

Computes the Net Present Value of an investment with a given stream of income 
at a given interest rate. String values are treated as zeros.

NPV(rate, pmt1[, pmt2[, ...]])

rate the interest rate

pmt a number or a range - the payment amounts 

Given an interest rate of rate and payments pmt1, pmt2, etc., the NPV function 
returns the Net Present Value of the stream of payments. Each payment can be 
a value or a range. If it is a range, each of the numbers in the range is included 
in the calculation. You may list any combination of numbers, cell addresses, and 
ranges as arguments for pmt.

An apartment building is being offered for sale for $400,000. Expected rental 
incomes for years 1-5 are $79,000, $85,000, $85,000, $103,000 and $120,000 and 
the interest rate is expected to stay close to 7%. Is this a worthwhile investment?

A

1 -400000

2 79000

3 85000
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4 85000

5 103000

6 120000

To figure out the net present value of the cash in-flows:

@NPV(7%,A2:A6) -> $381,595

To figure out the value of the project:

Project Value = Initial Cost + NPV

+A1+@NPV(7%,A2:A6) -> -18,404

No, this project is not worthwhile. 

PMT

Calculates the size of payments required to pay off a loan.

PMT(rate, per, loan[, fv[, type]])

loan the amount borrowed

rate the interest rate

per the number of payment periods

fv the [optional] Future Value of the loan

type the [optional starting time of the first payment



Mesa User’s Guide         Release 3.0         99

CHAPTER 3         Working With Workbooks 

Given a loan of loan, an interest rate of rate, and per payment periods, the @PMT 
function returns the size of the payments. If the Future Value fv is not specified, 
it is assumed to be 0. If type is not specified, payments are assumed to start 
immediately.

What would be the monthly payment on an $40,000 home improvement loan, to 
be repaid in 5 years at a fixed rate of 9%?

=PMT(9%/12,5*12,-40000) -> $830.33 per month.

@PMT

Calculates the size of payments required to pay off a loan.

@PMT(prin, rate, per)

loan the amount borrowed

rate the interest rate

per the number of payment periods

Given a loan of loan, an interest rate of rate, and per payment periods, the @PMT 
function returns the size of the payments required.

What would be the monthly payment on an $40,000 home improvement loan, to 
be repaid in 5 years at a fixed rate of 9%?

@PMT(40000,9%/12,5*12) -> $830.33 per month.

PV

Computes the Present Value of an investment.
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PV(rate, per, pmt[, fv[, type]])

rate the interest rate

per the number of payment periods

pmt the amount of each payment

fv the [optional] Future Value of the investment

type the [optional] starting time of the payments

Given an interest rate of rate, per payment periods, and a periodic payment of pmt, 
the PV function returns the Present Value of the investment. If a future value fv 
is not given, it is assumed to be 0. If type is not zero, payments are assumed to 
start in the next period.

What is the present value of the retirement annuity which promises to pay $30,000 
every year for the next 20 years, given an interest rate of 12%?

=PV(12%,20,-30000) -> $224,083.31

What is the present value of the investment which promises to pay $225,000 at the 
end of 20 years, given an interest rate of 12%?

=PV(12%,20,-225000) -> $23,325.02

@PV

Computes the Present Value of an investment.

@PV(pmt, rate, per)

pmt the amount of each payment
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rate the interest rate

per the number of payment periods

Given per payments of size pmt and an interest rate of rate, the @PV function 
returns the Present Value of the investment.

What is the present value of the retirement annuity which promises to pay $30,000 
every year for the next 20 years, given an interest rate of 12%?

@PV(30000,12%,20) -> $224,083.31

@RATE

Returns the interest rate for an investment, given the Future Value, Present Value, 
and number of payment periods.

@RATE(fv, pv, per)

fv the desired Future Value of the investment

pv the Present Value of the investment

per the number of payment periods

Given a Present Value of pv, the @RATE function returns the required interest rate 
necessary to achieve the desired Future Value of fv in per payment periods.

How much interest would a bank account need to earn for an investment of 
$67,000 to grow to $100,000 in 5 years or less?

@RATE(100000,67000,5) -> 8.34% or more.

SLNor @SLN
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Returns the Straight-Line depreciation of an asset.

SLN(cost, slvg, life)

cost the original cost of the asset

slvg the salvage value of the asset

life the expected lifetime of the asset

Given an asset with an original cost of cost, a salvage value of slvg, and a lifetime 
of life, the SLN function returns the Straight-Line depreciation for the asset.

A company buys a delivery van for $12,000. It has a useful life of 5 years and 
will be worth $2,000 at the end of that time. How much depreciation can the 
company write off each year?
=SLN(12000,2000,5) -> $2,000

SYD or @SYD

Calculates the Sum of the Years Digits depreciation for an asset.

SYD(cost, slvg, life, per)

cost the original cost of the asset

slvg the salvage value of the asset

life the expected lifetime of the asset

per the number of periods for the depreciation calculation

Given an asset with an original cost of cost, a salvage value of slvg, and a lifetime 
of life periods, the SYD function returns the Sum of the Years Digits depreciation 



Mesa User’s Guide         Release 3.0         103

CHAPTER 3         Working With Workbooks 

for per periods.

A company buys a delivery van for $12,000. It has a useful life of 5 years and will 
be worth $2,000 at the end of that time. How much depreciation can the company 
write off in years 1,2 and 4?

year 1: =SYD(12000,2000,5,1) -> $3,333

year 2: =SYD(12000,2000,5,2) -> $2,667

year 4: =SYD(12000,2000,5,4) -> $1,333

@TERM

Computes the number of payments required to reach a desired Future Value with a 
given payment size and interest rate.

@TERM(pmt,rate,fv)

pmt the size of each payment

rate the interest rate

fv the desired Future Value

Given payments of size pmt and an interest rate of rate, the @TERM function 
returns the number of payments required to reach the desired Future Value fv.

How many $700 monthly payments would be needed to accumulate $250,000 in a 
bank account earning 4% interest?

@TERM(700,4%/12,250000) -> 235.6 monthly payments (taking almost 20 
years).
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Math Functions

ABS or @ABS

Computes the absolute value of the given number.

ABS(num)

num any number 

The absolute value of a number is the value of the number ignoring positive 
or negative indicators. The absolute value of a positive number is given as the 
number. The absolute value of a negative number would be that number multiplied 
by negative one (-1); in other words the same number, except positive.

=ABS(-45.3) -> 45.3
@ABS(-45.3) -> 45.3

=ABS(COS(PI)) -> 1

=ABS(34) -> 34

=ABS(“Absolutely!”) -> 0

ACOS or @ACOS

Returns the arccosine of the given number.

ACOS(num)

num any number between -1 and 1

The arccosine of the number num is the angle whose cosine is num. The ACOS 
function gives the value of the angle in radians; the value of the angle can be 
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obtained in degrees by using this function in conjunction with the RADTODEG 
function. See “RADTODEG or @RADTODEG”.

=ACOS(0.7071) -> 0.7854 (radians) : This is equal to an angle of 45 degrees.

@RADTODEG(@ACOS(0.7071)) -> 45 : This gives the same answer as above, 
but in degrees.

ASIN or @ASIN

Returns the arcsine of the given number.

ASIN(num)

num any number between -1 and 1

The arcsine of the number num is the angle whose sine is num. The ASIN function 
gives the value of the angle in radians; the value of the angle can be obtained in 
degrees by using this function in conjunction with the RADTODEG function. See 
“RADTODEG or @RADTODEG”.

=ASIN(0.3090) -> 0.3141 (radians) : This is equal to an angle of 18 degrees.

@RADTODEG(@ASIN(0.3090)) -> 18 : This gives the same answer as above, 
but in degrees.

ATAN or @ATAN

Returns the arctangent of the given number. 

ATAN(num)

num any number
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The arctangent of the number num is the angle whose tangent is num. The ATAN 
function gives the value of the angle in radians; the value of the angle can be 
obtained in degrees by using this function in conjunction with the RADTODEG 
function. See “RADTODEG or @RADTODEG”.

=ATAN(5.6713) -> 1.3963 (radians) : This is equal to an angle of 80 degrees.

ATAN2

Returns the arctangent of the ratio of the given X and Y coordinates.

ATAN2(x, y)

x any number

y any number
The ATAN2 function finds the angle between the X axis and the point with the 
given coordinates x and y. This gives the angle of a line from the origin (0,0) to 
the point (x,y). The ATAN2 function gives the value of the angle in radians; the 
value of the angle can be obtained in degrees by using this function in conjunction 
with the RADTODEG function. See “RADTODEG or @RADTODEG”.

=ATAN2(1,3) -> 0.3218 (radians) : This is equal to an angle of 18.4 degrees.

@ATAN2

Returns the arctangent of the ratio of the given Y and X coordinates.

@ATAN2(y, x)

y any number

x any number
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@ATAN2 finds the angle between the X axis and the point with the given 
coordinates x and y. This gives the angle of a line from the origin (0,0) to the point 
(x,y). The @ATAN2 function gives the value of the angle in radians; the value of 
the angle can be obtained in degrees by using this function in conjunction with the 
RADTODEG function. See “RADTODEG or @RADTODEG”.

@ATAN2(3,1) -> 0.3217 (radians): This is equivalent to an angle of 18.4 degrees.

ATAN2 and @ATAN2 are different functions. ATAN2 requires the x parameter to 
be first, whereas @ATAN@ requires the y parameter to be first.

AVE or AVERAGE

Computes the average, or mean, of a list of numeric values. Strings are ignored.

AVE(num, ...), AVE(range), AVE(range1, range2, range3,...)
num any number

range any worksheet range

Divides the sum of the given numbers by the count of numeric entries. The items 
in the list are separated by commas, and they may be numbers or cell/range 
references containing numbers. You may list any combination of numbers, cell 
addresses, and ranges as arguments. String entries are ignored and have no effect 
on the result. 

=AVERAGE(4,5,25,3) -> 9.25

Given the following data:

A1: 184

A2: 592
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A3: 97

=AVE(A1:A3) -> 291

@AVE or @AVG
 
Computes the average, or mean, of a list of numeric values. Strings are treated 
as zero values.

@AVE(num,...), @AVE(range), @AVE(range1, range2, range3,...)

num any number

range any worksheet range

Divides the sum of the given numbers by the count of numeric entries. The items 
in the list are separated by commas, and they may be numbers or cell/range 
references containing numbers. You may list any combination of numbers, cell 
addresses, and ranges as arguments. String entries are treated as zero and are 
computed into the result.

@AVE(4,5,25,3) = 9.25

Given the following data:

A1: 184

A2: 592

A3: 97

@AVE(A1:A3) = 291

AVE and AVERAGE are different from @AVE and @AVG in that AVE and 
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AVERAGE ignore string values, while @AVE and @AVG treat string values as 
having a zero value.

COS or @COS

Returns the cosine of the given number.

COS(num)

num any number

The cosine of the angle num is the X coordinate of the point where a line at 
that angle from the X axis intersects a circle of radius one (1) centered on the 
origin (0,0). The COS function takes the value of the angle in radians; the value 
of the angle can be converted from degrees to radians within this function by 
using it in conjunction with the DEGTORAD function. See “DEGTORAD or 
@DEGTORAD”.

=COS(PI) -> -1

@COS(LN(3)) -> 0.4548

COUNT

Counts the number of numeric entries. Cells or items containing blanks or strings 
are not counted.

COUNT(num , ...), COUNT(range), 

COUNT(range1, range2, ...)

num any number

range any worksheet range
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The COUNT function finds the number of numeric entries in the list of arguments, 
and ignores string values. The items in the list are separated by commas, and they 
may be numbers or cell/range references containing numbers. You may list any 
combination of numbers, cell addresses, and ranges as arguments.

A B

1 Duck 10

2 Soup 20

3 1.86 20

4 $300 10

5 ‘====== 30

6 50

7 40 70

=COUNT(A1:A7) -> 3 : There are only three items in column A because cells A1, 
A2, and A5 are strings and A6 is blank.

=COUNT(A1:A7,B1:B7) -> 10 : This counts the 3 items in column A and the 
7 items in column B.

=COUNT(“Good”,”Bad”,”Indifferent”,0) -> 1

@COUNT

Counts the number of numbers and strings given.
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@COUNT(num, ...), @COUNT(range), 

@COUNT(range1, range2, ...)

num any number

range any worksheet range

The @COUNT function finds the number of numeric or string entries in the list of 
arguments. Cells or items containing strings are counted. Cells or items containing 
blanks are not counted. You may list any combination of numbers, cell addresses, 
and ranges as arguments.

A B

1 Duck 10
2 Soup 20

3 1.86 20

4 $300 10

5 ‘====== 30

6 50

7 40 70

@COUNT(A1:A7) = 6: There are only six items in column A because cell A6 
is blank.

@COUNT(A1:A7,B1:B7) = 13: This counts the 6 items in column A and the 7 
items in column B.
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@COUNT(“Good”,”Bad”,”Indifferent”) = 3

COUNT and @COUNT are different in that COUNT only counts numeric values. 
@COUNT also counts string values.

DEGTORAD or @DEGTORAD

Converts the given number from degrees to radians. 

DEGTORAD(num) 

num any number

Angles can be expressed in units of degrees or radians. There are 360 degrees, 
or 2p radians in a circle. All of Mesa’s trigonometric functions express angles in 
radians. This function will allow you to convert angles given in degrees to radians 
for use in Mesa’s trigonometric functions. Radians can be converted to degrees 
using the RADTODEG function. See “RADTODEG or @RADTODEG” .

=DEGTORAD(180) -> 3.14159

DIV or @DIV

Divides the given number by the given divisor and returns an integer.

DIV(num, div)

num any number

div any non-zero number

This function divided the given number by the given divisor and returns the 
integer portion of the answer. The remainder can be obtained using the MOD 
function. See “MOD or @MOD” .
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=DIV(12,5) -> 2

EXP or @EXP

Raises e the power of the given number.

EXP(num)

num any real number

EXP raises e to the given power. The number e is defined to be the number such 
that the derivative of enum is enum. The number e is approximately 2.71828. The 
natural logarithm of enum is num. see “LN or @LN”.

=EXP(4) -> 54.5982
@EXP(12%*5) * 30000 -> $54,664 : This formula calculates the present value of 
$30,000 invested at 12% continually compounded interest for a term of 5 years.

FRACor @FRAC

Returns the fractional component of the given number.

FRAC(num)

num any number

FRAC returns the non-integer portion of the given number, num. This function 
complements the INT function, see “INT or @INT”.

=FRAC(NOW) : This formula returns only the time component of the current 
date.

@FRAC(3.14159) -> 0.14159
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INT or @INT

Returns the integer portion of the given number.

INT(num)

num any number

INT returns the integer portion of the given number, num. This does not round 
the number off, it simply ignores all digits to the right of the decimal point. This 
function complements the FRAC function, see “FRAC or @FRAC”.

=INT(RAND*10) : This formula returns a random number between 0 and 9.

A3: 68293
@INT(LOG(A3))+1 -> 5 : This formula tells how many digits are the number 
in cell A3.

LN or @LN

Returns the natural logarithm of the given number.

LN(num)

num any positive number

The natural logarithm of a number is the power to which e needs to be raised to 
result in the given number; in other words, the logarithm to base e. The number e 
is defined to be the number such that the derivative of enum is enum. The number 
e is approximately 2.71828. If the natural logarithm of num is raised to the power 
e, the result is num. see “EXP or @EXP”.

=LN(27) -> 3.2958
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B8: 1024

=LN(B8)/LN(2) -> 10 : This formula returns the base 2 log of cell B8.

LOG, LOG10 or @LOG

Returns the base ten (10) logarithm of given number.

LOG(num)

num any positive number

The base ten (10) logarithm of a number is the power to which ten needs to be 
raised in order to result in the given number.

=LOG10(45) -> 1.6532

+10^(LOG(292)) -> 292 : This formula takes the base 10 log of 292, then raises 10 
to that power, resulting in the number it began with.

MAX

Returns the largest number in the given range or list.

MAX(num,...), MAX(range), MAX(range1, range2,...)

num any number

range any worksheet range

MAX returns the largest number in a given list or range, ignoring strings and 
non-numeric input. The items in the list are separated by commas, and they 
may be numbers or cell/range references containing numbers. You may list any 
combination of numbers, cell addresses, and ranges as arguments.
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=MAX(4.5,3.2,2.5,2.5,6.2) -> 6.2

=MAX(4,4,4) -> 4

A B C

1 300 400

2 0 400

3 200 100

4 300 5000

5 700

6 600

7 300

8 500

=MAX(A1:A8,C1:C8) -> 5000

@MAX

Returns the largest number in the given range or list with strings considered to 
be zero.

@MAX(num,...), @MAX(range), @MAX(range1, range2,...)

num any number

range any worksheet range
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@MAX returns the largest number in a given list or range. The items in the 
list are separated by commas, and they may be numbers or cell/range references 
containing numbers. You may list any combination of numbers, cell addresses, and 
ranges as arguments. Strings are treated as having a value of zero. 

@MAX(4.5,3.2,2.5,2.5,6.2) = 6.2

@MAX(4,4,4) = 4

A B C

1 300 400

2 0 400

3 200 100

4 300 5000

5 700

6 600

7 300

8 500

@MAX(A1:A8,C1:C8) -> 5000

MAX() and @MAX() differ in that MAX() ignores string values, while @MAX 
treats string values as zero. 
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MIN

Results in the smallest number in the given range or list.

MIN(num,...), MIN(range), MIN(range1, range2,...)

num any number

range any worksheet range

MIN returns the smallest number in a given list or range, ignoring strings and 
non-numeric input. The items in the list are separated by commas, and they 
may be numbers or cell/range references containing numbers. You may list any 
combination of numbers, cell addresses, and ranges as arguments.

A1: 300, A2: 400, A3: Hello!

=MIN(A1:A3) -> 300 : This formula returns 300, and the string entry in cell 
A3 is ignored.

A1: 0.0002, A2: 0, A3: -339492

+MIN(A1:A3) -> -339492

@MIN

Returns the smallest number in the given range or list, with string values consid-
ered to be zero.

@MIN(num,...), @MIN(range), @MIN(range1, range2,...)

num any number

range any worksheet range



Mesa User’s Guide         Release 3.0         119

CHAPTER 3         Working With Workbooks 

@MIN returns the smallest number in a given list or range. The items in the 
list are separated by commas, and they may be numbers or cell/range references 
containing numbers. You may list any combination of numbers, cell addresses, and 
ranges as arguments. Strings are treated as having a value of zero. 

A1: 300

A2: 400

A3: Hello!

@MIN(A1:A3)-> 0 : This formula returns zero because the string “Hello!” evalu-
ates to zero.

A1: 0.0002

A2: 0

A3: -339492

@MIN(A1:A3) -> -339492

MIN() and @MIN() differ in that MIN() ignores string vales while @MIN() treats 
strings as having a value of zero. 

MOD or @MOD

Returns the remainder of the given number divided by the given divisor. 

MOD(num, div)

num any number

div any non-zero number
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MOD compliments the DIV function (see “DIV or @DIV”) by returning the 
portion of the given number that does can not be divided evenly by the given 
divisor.

=MOD(12,5) -> 2

@NOW-@MOD(@NOW,7)+5 : This function returns the date-number for 
Monday of the current week.

PROD

Multiplies all the numbers in the given list.

PROD(num, ...), PROD(range), PROD(range1, range2, ...)

num any number

range any worksheet range

PROD takes the product of all the numbers in the given list. The items in the 
list are separated by commas, and they may be numbers or cell/range references 
containing numbers. You may list any combination of numbers, cell addresses, and 
ranges as arguments. Strings within the list are ignored.

=PROD(3, 5, 10, 2) -> 300

A1: 3

A2: 5

B1: 10

=PROD(A1:A2, B1, 2) -> 300
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@PROD

Multiplies all the numbers in the given list. Strings are treated as having a value 
of zero.

PROD(num, ...), PROD(range), PROD(range1, range2, ...)

num any number

range any worksheet range

PROD takes the product of all the numbers in the given list. The items in the 
list are separated by commas, and they may be numbers or cell/range references 
containing numbers. You may list any combination of numbers, cell addresses, and 
ranges as arguments. Strings within the list are treated as having a value of zero, 
so if a string appears in the list, PROD will return zero.

@PROD(3, 5, 10, 2) -> 300

A1: 3

A2: 5

B1: 10

@PROD(A1:A2, B1, 2) -> 300

PROD and @PROD differ in that PROD ignores strings, while @PROD treats 
strings as having a value of zero.

RADTODEG or @RADTODEG

Converts the given number from radians to degrees. 
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RADTODEG(num)

num any number

Angles can be expressed in units of degrees or radian. There are 360 degrees, 
or 2p radians in a circle. All of Mesa’s trigonometric functions express angles in 
radians. This function will allow you to convert angles given in radians by Mesa’s 
trigonometric functions to degrees. Degrees can be converted to radians using 
DEGTORAD. See “DEGTORAD or @DEGTORAD”.

=RADTODEG(PI) -> 180

ROOT or @ROOT

Returns the given root of the given number.

ROOT(num, n)

num any positive number

n any number

This function can be used to find the n th root of a number, num. The n th root 
of a number num is the number that, multiplied by itself n times, returns the 
number num.

=ROOT(81,4) -> 3

ROUND or @ROUND

Rounds a number to a given number of decimal places. 

ROUND(num, prec)
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num any number

prec any integer

This function rounds the number num to prec decimal places. If prec is zero, the 
number is rounded to the nearest integer. If prec is greater that zero, it will round 
off prec places beyond the decimal point. If prec is less than zero, it rounds to 
the left of the decimal place.

=ROUND(350.2852,2) -> 350.29

@ROUND(25492,-3) -> 25000
SGN, SIGN, @SIGN, or @SGN

Determines whether a number is positive or negative.

SGN(num)

num any number

This function returns 0 if num is zero, -1 if num is less than 0, and 1 if num is 
greater than 0. This functions is useful in conjunction with other functions where it 
is necessary to determine whether a number is positive, negative, or zero. 

B7: +RAND

=SIGN(B7-0.5) : This formula returns -1, 0, or 1 randomly.

=SGN(-405) -> -1

SIN or @SIN

Computes the sine of the given number. 
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SIN(num)

num any number

The sine of an angle is the Y coordinate of the point where a line at that angle 
from the X axis intersects a circle of radius one (1) centered on the origin. The 
SIN function takes the value of the angle in radians; the value of the angle can be 
converted from degrees to radians within this function by using it in conjunction 
with the DEGTORAD function. See “DEGTORAD or @DEGTORAD”.

=SIN(60*PI/180) = 0.8660 : This formula gives the sine of 60 degrees.

A mountain road goes up at an incline of 25 degrees. If the road is straight and is 
20 miles long, what vertical distance will a car travel to climb it? The formula is 
+20 * SIN(25*(pi/180)) -> 8.45 miles

SQRT or @SQRT

Calculates the square root of a number.

SQRT(num)

num any positive number

This function finds the positive number which, when multiplied by itself, yields 
the number num. To find roots other than the square root, see “ROOT or 
@ROOT”.

=SQRT(34) -> 5.8310

@SQRT(@LOG(200)) -> 1.5169

=SQRT(VAR(200,500,100)) -> 170 : This formula computes the standard devia-
tion of the values given in the variance function.
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STDDEV or STDEV

Returns the standard deviation of the ranges or list. Blank cells and strings are 
not counted.

STDDEV(num,...), STDDEV(range), 

STDDEV(range1, range2,...)

num any number

range any worksheet range.

This function finds the standard deviation of the given range or list of numbers. 
The items in the list are separated by commas, and they may be numbers or cell or 
range references containing numbers. You may list any combination of numbers, 
cell addresses, and ranges as arguments. The standard deviation is a measure of 
the statistical distribution of a set of numbers.

A B

1 NAME SCORE

2 Anna 65.8

3 Bill 95.4

4 Donna 30.2

5 Mark 54.9

6 Maria 35.1

7 Susan 75.9
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8 John 83.2

9 Rob 33.1

10 Ethan 81.8

=STDEV(B2:B10) -> 23.1

@STD

Returns the standard deviation of the ranges or list. Strings are counted as 0, and 
blank cells are not counted.

@STD(num,...), @STD(range), @STD(range1, range2,...)

num any number

range any worksheet range

This function finds the standard deviation of the given range or list of numbers. 
The items in the list are separated by commas, and they may be numbers or cell or 
range references containing numbers. You may list any combination of numbers, 
cell addresses, and ranges as arguments. Strings within the list are treated as 
having a value of zero. The standard deviation is a measure of the statistical 
distribution of a set of numbers. 

A B

1 NAME SCORE

2 Anna 65.8
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3 Bill 95.4

4 Donna 30.2

5 Mark 54.9

6 Maria 35.1

7 Susan 75.9

8 John 83.2

9 Rob 33.1

10 Ethan 81.8

@STD(B2:B10) -> 23.1

STDDEV() and STDEV() differ from @STD() in that STDDEV() and STDEV() 
ignore string values while @STD() treats string values as zero.

SUM or @SUM

Adds all the numbers in a list. 

SUM(num,...), SUM(range), SUM(range1, range2,...)

num any number

range any worksheet range

This function finds the sum of all the numbers in the given list or range. The items 
in the list are separated by commas, and they may be numbers or cell or range 
references containing numbers. You can specify as many numbers or ranges as 
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you want. You may list any combination of numbers, cell addresses, and ranges 
as arguments.

=SUM(300,400,2300,100) -> 3100

A1: Blue

A2: 300

A4: 900
B1: 1200

=SUM(A1:A4,B1) -> 2400

TAN or @TAN

Returns the tangent of the given number. 

TAN(num)

num any number

The tangent of an angle is ratio of the Y coordinate to the X coordinate of the 
point where a line at that angle from the X axis intersects a circle of radius one 
(1) centered on the origin. The TAN function takes the value of the angle in 
radians; the value of the angle can be converted from degrees to radians within 
this function by using it in conjunction with the DEGTORAD function. See 
“DEGTORAD or @DEGTORAD”.

=TAN(1.24) -> 2.9119

VAR

Calculates the statistical variance of a list of numbers. Strings and blank cells 
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are not counted.

VAR(num,...), VAR(range), VAR(range1, range2,...)

num any number

range any worksheet range

This function finds the statistical variance of a range of list of numbers. The 
items in the list are separated by commas, and they may be numbers or cell/range 
references containing numbers. You may list any combination of numbers, cell 
addresses, and ranges as arguments. Variance is a measure of how much a set of 
numbers vary from each other. Strings and blank cells in the list are ignored.

A B

1 NAME SCORE

2 Anna 65.8

3 Bill 95.4

4 Donna 30.2

5 Mark 54.9

6 Marie 35.1

7 Susan 75.9

8 John 83.2

9 Rob 33.1
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10 Ethan 81.8

=VAR(B2:B10) -> 531.6010

@VAR

Calculates the statistical variance of a list of numbers. Strings are counted as 0, 
and blank cells are not counted.

@VAR(num,...), @VAR(range), @VAR(range1, range2,...)
num any number

range any worksheet range

This function finds the statistical variance of a range of list of numbers. The 
items in the list are separated by commas, and they may be numbers or cell/range 
references containing numbers. You may list any combination of numbers, cell 
addresses, and ranges as arguments. Variance is a measure of how much a set 
of numbers vary from each other. This function is essentially the same as VAR, 
except that it treats strings as having a value of zero.

A B

1 NAME SCORE

2 Anna 65.8

3 Bill 95.4

4 Donna 30.2

5 Mark 54.9

6 Marie 35.1
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7 Susan 75.9

8 John 83.2

9 Rob 33.1

10 Ethan 81.8

@VAR(B2:B10) = 531.6010
VAR and @VAR are different in that VAR ignores strings while @VAR treats 
string values as zero.

Operators

! or::

Links worksheets

sheet!adr

sheet the name of the worksheet to be linked

adr the address of a cell or range in sheet

These operators create a link to another worksheet, specified by the filename of 
the worksheet, and the address of a cell or range in that worksheet. A worksheet 
link will return the value of the cell or range. Linked worksheets need to be in 
the same directory.

=”Exports”::B52 -> Returns the contents of cell B52 in the worksheet named 
Exports.

=U2!I9 -> Returns the contents of cell I9 in the worksheet whose name is in cell 
U2 of this worksheet 
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=sum(“Exports”!A1:B20) -> Returns the sum of the numbers in the range A1:B20 
in the worksheet named Exports

=sum(U2::prices) -> Returns the sum of the numbers in the range labeled prices in 
the worksheet whose name is in cell U2 of this worksheet.

&

string concatenation

string1&string2

This operator concatenates the two strings on either side of it, forming one string.

=”this”&”that” -> thisthat

A B

1 this that

=A1&B1 -> thisthat

= or ==

equal

exp1=exp2

Expressions containing this operator are true if the value of the first expression is 
equal to the value of the second expression.

!= or <>

not equal to
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exp1!=exp2

This operator tests to see if one expression is not equal to another.

if(1!=0, “OK”) -> OK 
<

less than

num1<num2

Expressions containing this operator are true if the value of the first number is 
smaller than the value of the second number.

>

greater than

num1>num2

Expressions containing this operator are true if the value of the first number is 
larger than the value of the second number.

<= or =<

less than or equal to

num1<=num2

Expressions containing this operator are true if the value of the first number is 
either less than or equal to the value of the second number.

>= or =>
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greater than or equal to

num1>=num2

Expressions containing this operator are true if the value of the first number is 
either greater than or equal to the value of the second number.

+

addition operator

num1+num2

This operator returns the sum of the given numbers.

=4+5 -> 9

-

subtraction operator

num1-num2

This operator subtracts the second number from the first number.

=10-2 -> 8

*

multiplication operator

num1*num2

This operators returns the product of the given numbers.
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=3*5 -> 15

/

division operator

num1/num2

This operator divides the first number by the second number.

=20/5 -> 4

^

exponentiation operator

num1^num2

This operator raises the first number to the power given by the second number. 
In other words it multiplies the first number by itself a number of times specified 
by the second number.

#AND#, &&, <AND>, or AND

logical AND

exp1#AND#exp2

This operator serves as a logical AND. When used to link two expressions, the 
entire expression is true only if both separate expressions are true.

#OR#, <OR>, OR, or ||

logical OR
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exp1#OR#exp2

This operator serves as a logical OR. When used to link two expressions, the 
entire expression is true if either of the two expressions is true.

<XOR>, XOR, or ^^

exclusive OR

exp1<XOR>exp2

Expressions containing this operator are true if either, but not both, or the given 
expressions are true.

Special Functions

#NOT#

Logical NOT.

#NOT#arg

arg a number or true/false value

This is the logical NOT function, but it is not used the same way as the logical 
AND and OR. For example,#NOT# 1 will equal 0, while#NOT# 0 will equal 1.

A3 = +(“Blue”=”Red”) , which returns 0 #NOT#A3 = 1 : The formula in cell A3 
asks “is the string ‘Blue’ = the string ‘Red’? The answer is 0 (false). The #NOT# 
function inverts this returning the answer 1 (true)

#NOT#1 = 0 (false)
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@@

Evaluates a string as a cell address.
@@(string)

string any string that can be interpreted as a cell address

This function evaluates the stringstring as a cell address and returns that address. 
This can be useful for creating a cell address with string concatenation.

A3: Cheers

B3: A3

@@(B3) -> Cheers

A1: 10

A2: 20

A3: 30

B1: A1:A3

@SUM(@@(B1)) -> 60

ADDRESS or @ADDRESS

Returns a cell address for a given row and column number.

ADDRESS(row,col)

row the number of the row
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col the number of the column

The ADDRESS() function returns the address for therow andcol specified. Row 
and column numbering starts at zero, i.e. ADDRESS(0,0) is cell A1. This function 
can be useful in MScript scripts.

B1: 15

=ADDRESS(0,1) -> 15

BEEPIF or @BEEPIF

Beeps if the specified condition is true.

BEEPIF(cond)

cond a conditional expression

The BEEPIF function beeps and returns 1 if the conditioncond is true, and returns 
0 if the condition if false. This can be useful for alerting the user of certain 
conditions within the worksheet.

C7: 100

=BEEPIF(C7<200) : This formula will beep one time.

=BEEPIF(rand>0.5) : This formula will generate a random number between 0 and 
1. If the number is > 0.5, the it beeps and returns 1. Otherwise it returns 0.

CELL or @CELL

Returns information about the attributes of a given cell.

CELL(atrb,cell)
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atrb the cell attribute

cell the cell address

The CELL() function returns attribute information about a the cell at the address-
cell. The type of information requested is specified by the argumentatrb, chosen 
from the list below.

U7: PI

=CELL(“address”,U7) -> $U$7

=CELL(“row”,U7) -> 7

=CELL(“col”,U7) -> 21

=CELL(“contents”,U7) -> 3.141593

ADDRESS - returns the address of the cell

ROW - returns the row of the cell

COL - returns the column of the cell

CONTENTS - returns the value of the cell

FORMAT - returns the format of the cell. Formats are:

G - General

Fn - Fixed Decimal n places Sn - Scientific Format n decimal places

Cn - Currency format n decimal places
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,n - Comma format n decimal places

+ - Chart Format

Pn - Percent Format n decimal places

T - Text Format

H - Hidden Format

D1 - Day Month Year Format

D2 - Day Month Format

D3 - Month Year Format

D6 - Hours Minutes Seconds Format

D7 - Hours Minutes Format

D4 - International Date Format 1

D5 - International Date Format 2

D8 - International Time Format 1

D9 - International Time Format 2

PREFIX - The string prefix in Lotus Format

PROTECT - Returns 0 if the cell is Unprotected, 1 otherwise

TYPE - b - blank cell, v - number value, l - string value



Mesa User’s Guide         Release 3.0         141

CHAPTER 3         Working With Workbooks 

WIDTH - Returns the width of the column in characters

RANGE - Converts a single address to a range

CELLPOINTER or @CELLPOINTER

Returns information about the attributes of the currently active cell.

CELLPOINTER(atrb)

atrb the cell attribute

The CELLPOINTER function returns attribute information about a the currently 
active cell. The type of information requested is specified by the argumentatrb. 
See “CELL or @CELL” for information about attributes. The currently active cell 
is the cell on the worksheet whose contents is currently being displayed in the 
formula bar. Mesa worksheets always have one currently active cell. If a range 
has been selected, the currently active cell is the cell in the upper left corner of 
the range.

CHOOSE or @CHOOSE

Chooses a numbered item from a list.

CHOOSE(num, item1[, item2[, ...])

num the number of the chosen item

item the members of the list

Chooses thenum item from the list of itemsitem1,item2, etc. This function counts 
the listed items starting at zero. You may list any combination of numbers, cell 
addresses, and ranges as arguments foritem.
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=CHOOSE(2,”first”,”second”,”third”,”fourth”) -> third

=CHOOSE(MOD(INT(NOW),7),”Thu”,”Fri”,”Sat”,Sun”,”Mon”,”Tue”,”Wed”) : 
This function returns the current day using NOW to provide the current date.

COLS or @COLS

Returns the number of columns in a range.

COLS(range)

range any range

The COLS function returns the number of columns contained in the rangerange.

=COLS(A1:H20) -> 8

If RANGE1 is the name assigned to the range B1:CC200, =COLS(RANGE1) 
-> 80

DIDCHANGE or @DIDCHANGE

Determines if the sheet has changed since it was last saved.

DIDCHANGE

DIDCHANGE returns a 1 if the sheet has changed since the last time it was saved, 
and a 0 if nothing has changed. Since the act of adding this function changes the 
sheet, it will only show as true when the sheet has been recalculated right after it 
has been saved. This can be useful in MScript scripts.

FORMAT or @FORMAT

Formats the number in the predefined format
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FORMAT(num,fmt-const[,prec])
num any number

fmt-const any format constant

prec any integer [optional]

This function returns the given numbernum in the format specified by the format 
constantfmt-const. A list of the format constants can be found in “Format Con-
stants”. You may optionally specify the precisionprec, the number of decimal 
places in the number. 

=FORMAT(18.9, SCIENTIFICFORMAT) -> 1.89e+01

GETINPUT or @GETINPUT

Returns the user-typed input string.

GETINPUT(cell)

cell any cell

The GETINPUT function returns the string typed into the cellcell by the user, 
rather than its value. This can be useful for MScript scripts.

A1 : =INT(3.2)

=A1 is 3

=GETINPUT(A1) is the string =INT(3.2)

HISTOGRAM or @HISTOGRAM

Creates a histogram for a given range.
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HISTOGRAM(range, divs, anchor[, min, max])

range any range

divs the number of divisions in the histogram

anchor the starting cell of the histogram

min the [optional] minimum

max the [optional] maximum

The HISTOGRAM function groups the values inrange intodivs divisions and 
counts the number of items in each division. The formula should appear indivs 
cells, starting atanchor. It returns the number of items in the division that is offset 
from the anchor point.Min andmax are optional parameters that set the minimum 
and maximum values of the histogram range, so that the distribution will only be 
calculated for values betweenmin andmax.

A B

1 Name GPA

2 Joe 2.6

3 Sue 3.7

4 Robert 3.2

5 Steve 3.0

6 Ann 3.8

7 John 3.5
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8 Mary 2.9

9 Chris 3.5

To divide the students into 5 divisions by GPA and determine how many fall 
into each division:

A10: =HISTOGRAM($B$2:$B$9,5,$A$10) -> 1

B10: =SAME($A$10) -> 2

C10: =SAME($A$10) -> 1

D10: =SAME($A$10) -> 2

E10: =SAME($A$10) -> 2

HLOOKUP or @HLOOKUP

Looks up a code in a horizontal table.

HLOOKUP(code, table, offset)

code the code to be looked up

table a range containing the lookup data

offset the number of rows offset from the top of the table.

Returns the celloffset cells from the top of the first match. If the first row contains 
numbers andcode is less than the first value in the lookup row, !ERR is returned. 
Ifcode is greater than the first value but no exact match is found, HLOOKUP 
returns the value from the last column. If the first row contains only strings and no 
exact match is found, it returns !ERR.
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A B C

1 1 2 3

2 $200 $40 $500

=HLOOKUP(2,A1:C2,1) -> $40

=HLOOKUP(0.5,A1:C2,1) -> !ERR

=HLOOKUP(5,A1:C2,1) -> $500

IF or @IF

Returns a conditional result.

IF(exp,value1[,value2])

exp the conditional expression for evaluation

value1 the first possible result

value2 the [optional] second possible result

The IF function evaluatesexp. If it is a true or non-zero value, the result isvalue1. 
If it is false, zero, or a string, optionalvalue2 or an empty value is the result.

=IF(5>10,”Something is wrong!”,”Everything is normal.”) 

-> Everything is normal.

A1: 3400

A2: 4000
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A3: 5000

=IF(SUM(A1:A3)>=12400,”Full Capacity”) -> Full Capacity

IFELSE

Returns a conditional result.

IFELSE(exp, value1, value2)

exp the conditional expression for evaluation

value1 the first possible result

value2 the second possible result

The IFELSE() function evaluatesexp. If it is a true or non-zero value, the result 
isvalue1. If it is false, zero, or a string,value2 is the result.

=IFELSE(5>10,”Something is wrong!”,”Everything is normal.”) -> Everything is 
normal.

A1: 3400

A2: 4000

A3: 5000

=IFELSE(SUM(A1:A3)>40000,”Full Capacity”,”Okay”) -> Okay

INDEX

Returns a specified cell from a range of cells.
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INDEX(range, row, col)

range any range

row the row offset from the upper left of the range

col the column offset from the upper left of the range

The INDEX function returns the cell that iscol columns androw rows offset from 
the upper left corner of the rangerange.

A B C

1 10 20 30

2 3942 4932 5929

3 4920 5929 9294

=INDEX(A1:C3,2,2) -> 9294

A10: 1

A11: 0

=INDEX(A1:C3,A10,A11) -> 3942

@INDEX

Returns a given cell from a range of cells.

INDEX(range,col,row)

range any range
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col the column offset from the upper left of the range

row the row offset from the upper left of the range

The INDEX() function returns the cell that isrow rows andcol columns offset from 
the upper left corner of the rangerange.

A B C

1 10 20 30

2 3942 4932 5929

3 4920 5929 9294

@INDEX(A1:C3,2,2) = 9294

A10: 0

A11: 1

@INDEX(A1:C3,A10,A11) = 3942

INDEX and @INDEX differ slightly. INDEX() specifies the offset in row then 
column order. @INDEX() specifies the offset in column then row order.

ISEMPTY or @ISEMPTY

Determines if the cell at the given address is empty.

ISEMPTY(adr) 

adr a cell address
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This functions tests whether or not the specified cell is empty. Mesa functions that 
return a True or False result return 1 for True, and 0 for False.

A1 : 5.2

B1 :

=ISEMPTY(A1) is 0

=ISEMPTY(B1) is 1 because cell B1 has no contents.

ISERROR or @ISERR

Determines if the given expression returns an error other than @NA. 

ISERROR(exp)

exp an expression

This function tests whether or not the given expression results in an error. In Mesa 
functions that return a True/False result, 1 corresponds to True, and 0 corresponds 
to False. See “ISNA or @ISNA”.

=ISERR(ERRORCONST) -> 1 (true)

=ISERR(@VALUE(“ABCD”) -> 1 (true) : This formula tried to convert “ABCD” 
to a value using @VALUE(). This returns !ERR, which causes ISERR() to returns 
1.

ISFORMULA or @ISFORMULA

Determines if the cell at the given address contains a formula.

ISFORMULA(adr)
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adr a cell address

This function tests to see if the cell at the given address contains a formula. 
In Mesa functions that return a True/False result, 1 corresponds to True, and 0 
corresponds to False.

A1 : 3.2

B1 : =A1+1

=ISFORMULA(A1) is 0

@ISFORMULA(B1) is 1 because cell B1 contains a formula that adds 1 to the 
contents of cell A1.

ISNA or @ISNA

Determines if the given expression returns an NA error. 

ISNA(exp)

exp an expression

This function tests to see if the given expression returns the NA error. In Mesa 
functions that return a True/False result, 1 corresponds to True, and 0 corresponds 
to False.

=ISNA(@NA) -> 1 (true)

A1: 34

A2: 49

A3: =NA
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=ISNA(SUM(A1:A3)) -> 1 : This formula returns 1 (true) because cell A3 
contains NA, which causes SUM(A1:A3) to evaluate to NA also.

ISNUMBER or @ISNUMBER

Determines if the given expression returns a numeric result.

ISNUMBER(exp)

exp an expression

This function tests to see whether or not the given expression results in a number. 
In Mesa functions that return a True/False result, 1 corresponds to True, and 0 
corresponds to False.

=ISNUMBER(FIXED(300,0)) -> 0 : This formula converts the number “300” to 
a string using FIXED(). It then uses ISNUMBER() to test if that result is a value 
and returns 0 (false).

=ISNUMBER(34) -> 1

A3: +394 - 100

=ISNUMBER(A3) -> 1

ISREF or @ISREF

Determines whether or not the given expression is a cell or range reference. 

ISREF(exp)

exp an expression

This function tests to see whether or not the given expression is a cell or range 
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reference. In Mesa functions that return a True/False result, 1 corresponds to True, 
and 0 corresponds to False.

=ISREF(A1) -> 1 (true)

If RANGE1 has been assigned A1:C10, =ISREF(RANGE1) -> 1

ISSTRING or @ISSTRING

Determines whether or not the given expression results in a string. 

ISSTRING(exp)

exp an expression

This function tests whether or not the given expression will result in a string when 
evaluated. In Mesa functions that return a True/False result, 1 corresponds to True, 
and 0 corresponds to False.

=ISSTRING(VALUE(“340”)) -> 0

=ISSTRING(LEFT(“Goodbye!”,4)) -> 1

=ISSTRING(“Some text”) -> 1

@N

Returns the given expression if it is a number, 0 otherwise.

@N(exp)

exp an expression

If the given expression is a number, @N returns the expression, otherwise @N 
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returns 0. @N is guaranteed to return a number and is used in functions that 
require numbers as parameters.

@N(@STRING(300,0)) -> 0

@N(34) -> 34

NEXT or @NEXT

Returns the next logical value for a given value

NEXT(value[, inc])

value a number, string, or cell reference

inc the [optional] number by which to increment the value

The NEXT function returns the next logical value aftervalue. The value is incre-
mented by 1 unless an optional incrementinc is specified. For example, ifvalue is 
“Mon”, then NEXT(value) returns “Tue”. Values for months, days, and quarters 
are built in. Ifvalue is a number, NEXT adds 1 orinc to the number. For quarterly 
information, it will increment the quarter. When the quarter reaches 4, the next 
quarter is Q1 of the following year. For example, NEXT(“Q4 ‘92”) is “Q1 ‘93”.

=NEXT(“Q4 ‘92”) -> Q1 ‘93

=NEXT(“January”) -> February

=NEXT(“Region 1”) -> Region 2

NOT or @NOT

Logical NOT.
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NOT(num)

num any number

Ifnum is zero or not a number, the NUM() function returns 1; otherwise, it returns 
0.

=NOT(34) -> 0

=NOT(“Text”) -> 1

RANGE or @RANGE

Gives the address for a numerically specified range.

RANGE(ur, lc, lr, rc)

ur number corresponding the upper row of the range

lc number corresponding the left column of the range

lr number corresponding the lower row of the range

rc number corresponding the right column of the range

RANGE returns the address for the range specified by the upper row, left column, 
lower row, right column. RANGE(0,0,1,1) is the range A1:B2. This can be useful 
in MScript scripts.

A1 : 0

B1 : 1

A2 : 5
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B2 : 7

=SUM(RANGE(0,0,1,1)) is 13. This is the sum of the values in the range A1:B2

=SUM(RANGE(A1,A1,B1,B1)) is also 13. Because cell A1 contains 0 and cell 
B1 contains 1, this is the same as the above example.

ROWS or @ROWS

Returns the number of rows in a range.

ROWS(range)

range the address of a worksheet range

This function counts the number of rows in the rangerange and returns the number.

=ROWS(A1:H20) -> 20

If RANGE1 is the name assigned to the range B1:CC200, =ROWS(RANGE1) 
-> 200

@S

Returns the given expression if it is a string, or a zero length string otherwise.

@S(exp)

exp an expression

If the given expression is a string, this function returns the expression; otherwise it 
returns a zero length string. This function is used to guarantee that an expression 
is a string.
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@S(343) -> “” (blank string)

A1: 2000

A2: Orders

@S(A1)&@S(A2) = Orders

SAME or @SAME

Executes the same function as in the given cell

SAME(adr)

adr the address of the cell containing the desired formula

Takes the formula in celladr and executes it as if it had been copied and then 
pasted into the current cell. This is a powerful and valuable function. You can 
have a master function and a series of functions that are the same. Where you 
change the master function, the method of calculation used by the other functions 
is changed. You can use SAME() in conjunction with INDEX(), HLOOKUP(), 
VLOOKUP(), and to define a formula used in a calculation rather than having a 
complex IF() statement. An application for this is an employee pay calculation that 
depends on an employee type.

A1: 1

A2: 2

If B1: =A1 * 5 and B2: =SAME(B1), then B2 = 10 (A2*5).

If B1: =A1/5, then B2 changes to 0.4 (A2/5)

If B1: =SIN(A1), B2 changes to 0.9093 (SIN(A2))
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SETALTCOLOR or @SETALTCOLOR

Returns the given value and sets the alternate color to the specified color.

SETALTCOLOR(exp, colorconstant [, pattern]), or SETALTCOLOR(exp, r, g, b 
[, pattern])

exp any expression

colorconstant any color constant

r a number from 0 to 1, indicating the amount of red

g a number from 0 to 1, indicating the amount of green

b a number from 0 to 1, indicating the amount of blue

Sets the alternate color of the current cell and returns the given 
expression.Colorconstant is one of the colors listed in the “Constants” section 
(see “Color Constants”), orr, g, andb are numbers between 0 and 1 that set the 
percentage of red, green, and blue that will be mixed together to create the color. 
White is all ones and black is all zeros. If any of the color components are out of 
bounds or result in errors, the color is not changed.

=SETALTCOLOR(A1,IF(A1 < -100,1,0),0,0) : This sets the alternate color to red 
if the number is less than -100, otherwise it sets the alternate color to black.

=SETALTCOLOR(A1,MAGENTACOLOR) : This sets the alternate color of cell 
A1 to Magenta.

SETBKGCOLOR or @SETBKGCOLOR
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Returns the given value and sets the background color to the specified color.

SETBKGCOLOR(exp, colorconstant [,pattern]), or 

SETBKGCOLOR(exp, r, g, b [,pattern])

exp any expression

colorconstant any color constant

r a number from 0 to 1, indicating the amount of red

g a number from 0 to 1, indicating the amount of green

b a number from 0 to 1, indicating the amount of blue

Sets the background color of the current cell and returns the given 
expression.Colorconstant is one of the colors listed in the “Constants” section (see 
“Color Constants”), orr, g

=SETBKGCOLOR(A1,IF(A1 > 50 && A1 < 100,1,0),0,0) : This sets the back-
ground color to red if the number is greater than 50 and less than 100, otherwise it 
sets the background color to black.

=SETBKGCOLOR(A1,CYANCOLOR,56) : This sets the background color of 
cell A1 to Cyan and the pattern to pattern number 56.

SETCOLOR or @SETCOLOR

Returns the given value and sets the text color to the specified color.

SETCOLOR(exp, colorconstant [,pattern]), or 
SETCOLOR(exp, r, g, b [,pattern])
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exp any value

colorconstant any color constant

r a number from 0 to 1, indicating the amount of red

g a number from 0 to 1, indicating the amount of green

b a number from 0 to 1, indicating the amount of blue

Sets the color of the current cell and returns expression. Colorconstant is one of 
the colors listed in the “Constants” section (see “Color Constants”), orr, g, andb 
are numbers between 0 and 1 that set the percentage of red, green, and blue that 
will be mixed together to create the color. White is all ones and black is all zeros. 
If any of the color components are out of bounds or result in errors, the color 
is not changed.

=SETCOLOR(A1,IF(A1 > 100,1,0),IF(A1 > 100,0,1),0) : This sets the color to 
red if the number is greater than 100, otherwise it sets the color to green.

=SETCOLOR(A1,BLUECOLOR) : This sets the color of cell A1 to Blue.

SIGNAL or @SIGNAL

If the condition is true, sends range of cells to the named Mach port.

SIGNAL(cond,port,range)

cond this function only sends data if this parameter is TRUE.

port a string containing the name of the port to send the data to.

range the range of cells to send to the named port.
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This function works in conjunction with the MesaListen class of objects to allow 
a spreadsheet to send a range of cells to a custom application in when a certain 
event takes place. The MesaListen object in the custom application can then 
take the appropriate action. An example is that a signal could be sent if an 
arbitrage opportunity presented itself. The parameters of the opportunity could be 
programmed into the worksheet. When the parameters became true, perhaps based 
of real time data being fed into the worksheet, the worksheet could send a signal to 
a custom application that would perform a securities trade.

=SIGNAL(GOLD_PRICE > 50 * SILVER_PRICE,”BUY_GOLD”,A1) - send a 
message to the “BUY_GOLD” object when the price of gold is 50 times higher 
than the price of silver.

VLOOKUP or @VLOOKUP

Looks up code in the vertical table.

VLOOKUP(code,table,offset)

code a string or number identifying the desired values

table the range of the lookup table

offset the offset of the relevant column 

Returns the celloffset cells from the left side of the first match. If the first column 
contains only strings and code is a number, it returns the value from the last 
row. Ifcode is also a string, but doesn’t match any of the table entries, !ERR is 
returned.

A B

1 A 5.0
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2 B 4.0

3 C 3.0

4 D 2.0

5 F 0

=VLOOKUP(“A”,A1:B5,1) -> 5.0

=VLOOKUP(“D”,A1:B5,1) -> 2.0

=VLOOKUP(“Incomplete”,A1:B5,1) -> !ERR

=VLOOKUP(3.0,A1:B5,1) -> 0

String Functions

CHAR or @CHAR

Returns the ASCII character for the given number.

CHAR(num)

num any integer representing an ASCII character

The CHAR function will convert the integer num to its corresponding ASCII 
character. The ASCII code for a given character can be found with the CODE 
function. See “CODE or @CODE” .

=CHAR(68) -> D
@CHAR(162) -> ¢
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CLEANor @CLEAN

Removes all control characters from a string.

CLEAN(string)

string any string

The CLEAN function will remove all control characters from the string string. 
This can be useful for data that has been imported to Mesa from another source.

CODEor @CODE

Returns the ASCII code for the first character in a string.

CODE(string)

string any string (only the first character will be used)

The CODE function returns the ASCII code for the first character in the string 
string. The character for a given code can be found with the CHAR function. See 
“CHAR or @CHAR”.

=CODE(“A”) -> 65

@CODE(“{“) -> 123

=CODE(“Hello”) -> 72 : This formula is returning the ASCII code for “H”

EXACTor @EXACT

Compares two strings to determine if they are exact matches.
EXACT(str1, str2)
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str1 the first string to be compared

str2 the second string to be compared

The EXACT function compares str1 and str2, and returns 1 if the strings match 
exactly. It returns 0 otherwise. The EXACT function is case sensitive. When you 
use = to match strings, the comparison ignores case. For example, “Upper” = 
“upper” is true, but EXACT(“Upper”, “upper”) is false.

=EXACT(“Daytime”,”Daytyme”) -> 0 (false)

A1=”hello” and B1=”hello”: =EXACT(A1,B1) -> 1 (true)

FIND or @FIND

Finds the location of a substring within a string.

FIND(substr, string, offset)

substr the substring to be found

string the string to be searched

offset the location in the string to begin the search

The FIND function returns the location of the sub-string substr in the string string. 
It starts searching for substroffset characters from the left of string. It returns ERR 
if the string is not found.

=FIND(“hampton”,”Northampton”,1) -> 4

=FIND(“hampton”,”Northampton”,6) -> !ERR (because it starts searching at the 
6th character)
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A1: “The third word in this sentence.”

=FIND(“word”,A1,1) -> 10

FIXED or @STRING

Rounds a number to a specified number of decimal places and converts it to a 
string.

FIXED(num, prec)

num any number

prec the number of places of precision

The FIXED function rounds the number num to a precision of prec decimal 
places, then converts it to a string. If prec is negative, num will be rounded off 
to the left of the decimal point.

B3: 5251.769585987

=FIXED(B3,6) = 5251.769586

=FIXED(3/43,2)&” is now a string” -> 0.07 is now a string : This formula 
evaluates 3/43, then converts it to a string with 2 decimal places of precision and 
concatenates it with the text “ is now a string”.

LEFT or @LEFT

Returns a substring from the left of a string.

LEFT(string, len)
string any string
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len the length of the substring

The LEFT function returns a string containing the first len characters from the 
left of the string string.

=LEFT(“The first twelve characters”,12) -> The first tw

=LEFT(“ABCDEFG”,4) -> ABCD

LEN, LENGTH, @LENGTH or @LEN

Returns the length of a string.

LENGTH(string)

string any string

The LENGTH function returns the number of characters in the string string.

LENGTH(“10% discount on COD”) = 19

A1: “A short string “

B1: “sentence”

=LEN(A1) -> 15

=LENGTH(A1&B1) -> 23

LOWER or @LOWER

Converts a string to lower case.
LOWER(string)
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string any string

The LOWER function converts all the characters in the string string to lower case, 
regardless of their original case.

=LOWER(“Bill Johnson”) -> bill johnson

MID or @MID

Returns a substring from the middle of a string.

MID(string, start, len)

string any string

start the starting character of the substring

len the length of the substring

The MID function returns a string of len characters from the string string, starting 
start characters from the first character of string.

= MID(“Have a great day!”,7,5) = great

A1: “Robert Quimby Douglas”,

=MID(A1,7,6) -> Quimby

NEXTor @NEXT

Returns the next logical value for a given value

NEXT(value[,inc])



168           Release 3.0        Mesa User’s Guide

CHAPTER 3         Working With Workbooks 

value a number, string, or cell reference

inc the [optional] number by which to increment the value

The NEXT function returns the next logical value after value. The value is 
incremented by 1 unless an optional increment inc is specified. For example, if 
value is “Mon”, then NEXT(value) returns “Tue”. Values for months, days, and 
quarters are built in. If value is a number, NEXT adds 1 or inc to the number. 
For quarterly information, it will increment the quarter. When the quarter reaches 
4, the next quarter is Q1 of the following year. For example, NEXT(“Q4 ‘92”) 
is “Q1 ‘93”.

=NEXT(“Q4 ‘92”) -> Q1 ‘93

=NEXT(“January”) -> February

=NEXT(“Region 1”) -> Region 2

PROPER or @PROPER

Converts a string to Proper Case.

PROPER(string)

string any string

The PROPER function capitalizes the first letter of every word in the string string 
and converts all remaining characters to lower case.

=PROPER(“MS. JANET KRAFT”) -> Ms. Janet Kraft

=PROPER(“all entries posted before 7/2”) -> All Entries Posted Before 7/2
REPEAT, REPT, or @REPEAT
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Repeats a string the specified number of times.

REPEAT(string, num)

string any string

num the number of times to repeat the string

This function returns the string string repeated num times. The string is placed 
back-to-back with itself, with no white space.

=REPEAT(“X”,10) -> XXXXXXXXXX

=REPT(“over and “,4) -> over and over and over and over and

REPLACE or @REPLACE

Replaces a specified number of characters in a string with another string.

REPLACE(string, offset, num, newstr)

string any string

offset the position to begin the insertion

num the number of characters to replace

newstr the string with which to replace the specified characters

The REPLACE() function replaces num characters in the string string with the 
string newstr, starting offset characters from the first character of the original 
string. The string newstr does not need to be the same length as the number of 
characters being replaced.
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=REPLACE(“The cost is $450, COD”,13,3,”2,500”) -> The cost is $2,500, COD

=REPLACE(“Robert J. Stevenson”,7,1,”L”) -> Robert L. Stevenson

RIGHT or @RIGHT

Returns a substring from the right of a string.

RIGHT(string, len)

string any string

len the length of the substring

The RIGHT function returns a string containing the first len characters from the 
right of the string string.

=RIGHT(“The last ten characters”,10) -> characters

=RIGHT(“Ida M. Brown”,5) -> Brown

TRIM or @TRIM

Removes extra white space from a string

TRIM(string)

string any string

This function removes all leading and trailing spaces from the string string and 
converts multiple consecutive spaces within the string to single spaces.

A3: Account # 3040302 40303
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=TRIM(A3) -> Account # 3040302 40303

=TRIM(“ Anything at all.”) -> Anything at all.

UPPER or @UPPER

Converts a string to UPPER case.

UPPER(string)

string any string

The UPPER function converts all the characters in the string string to upper case, 
regardless of their original case.

=UPPER(“Uppers only”) -> UPPERS ONLY

=UPPER(MID(“robert c. smith”,8,2)) -> C. : This formula uses MID() to return 
the 8th and 9th characters from the string “Robert C. Smith”. The UPPER() 
function then capitalizes this result.

VALUE

Returns the number value of a string. 

VALUE(string)

string any string

This function converts the string string into a number. If the string begins with a 
number but contains non-numbers, VALUE() returns as much as it can. If string 
begins with a letter, it returns 0.
=VALUE(“3.14159”) = 3.14159
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=VALUE(“1200”) + 2000 = 3200

=VALUE(“320/104”) = 320

@VALUE

Returns the number value of a string.

@VALUE(string)

string any string

This function converts the string string into a number. If the string contains 
characters that are non-numbers, it returns an error.

@VALUE(“3.14159”) -> 3.14159

@VALUE(“1200”) + 2000 -> 3200

@VALUE(“320/104”) -> !ERR

VALUE() and @VALUE() are different in that if the argument to VALUE() cannot 
be completely converted to a number, it returns as much of the number as possible. 
@VALUE() returns an error.

Smart Functions

Mesa provides menu options in Range->Smart Formulas to allow you to quickly 
and easily perform the most common Function operations:

SUM

MIN
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MAX

STDDEV

VAR

To use any of these functions, just highlight the range you want to operate on, 
as well as one cell to the right or below that range (this is where the answer 
will be put).

Then choose the appropriate Smart Function from the 

Range-> Smart Formulas menu.

Mesa will immediately create a formula of the form:

=SUM(a1.h5)

in the appropriate cell.

You can edit this formula manually if you want to do so.

Using The Formula Builder

Use Tools->Formula Builder or click the Formula Builder icon on the Workbook 
Toolbar to get an inspector panel containing a scrollable list of all of the formula 
functions available in Mesa.
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A pop-up menu lets you choose among the following categories: math, financial, string, 
constants, special, date, database, and operators. (You can select functions either with or 
without the @ symbol.) 
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Formulas beginning with the @ character (1-2-3 derived) can be pasted directly into the 
worksheet, but to use formulas without the @ (Excel-derived) , type “=” in the data input 
window of your worksheet, and then define the formula by selecting and pasting non-@ 
functions from the Formula Builder lists. You must type in any variables required by a 
function before you can go on.

You can paste operators from the Formula Builder Operators list into either @ formulas 
or non-@ formulas.

Use the ‘Sizing dimple’ to display more, less or none of the explanatory text associated 
with Functions.

Manual And Automatic Recalculation

Mesa always uses “natural order” recalculation so that the one answer for a given cell is 
returned correctly even if cell data in other parts of the worksheet are accessed. 

By default, Mesa recalculates the entire worksheet each time data in the worksheet is 
changed. For large worksheets, this could take a second or two.

To disable automatic recalculation, uncheck the “Auto Recalc” check-box in the Sheet 
Inspector.

If Auto Recalc is disabled, remember to use the Range ® Recalculate Sheet (Command-=) 
command to update the worksheet after data has changed.



176           Release 3.0        Mesa User’s Guide

CHAPTER 3         Working With Workbooks 

Circular References

Mesa cannot resolve circular references in cell formulas. Circular Reference debugging is 
provided to track and allow you to fix circular references.

To enable calculation debugging, select “Stop on Error” or “Stop on Circ.” from the 
pop-up in the Sheet Inspector.

Large Workbooks

If you have a large worksheet with data in lots of rows and columns, you may find it 
difficult to find your way around the sheet.

Mesa has several techniques which can help you here.

You can:

create more than one window into a worksheet

use several distinct files and link them with formulas

set up Range Names
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Freeze title rows and columns onto the screen

Resizing Rows

Rows can be made higher or lower - usually in order to accommodate large or smaller 
font-sized data.

You can do this in three different ways:

Manually: by moving the mouse to the separator in the Row Frame and dragging the 
row to the required height

Via the menu: use Arrange->Row/Column Smart Resize to set the row to the maxi-
mum height needed to accommodate the largest font `size in any cell along the row

Automatic by Mouse: double-click on the Row Frame separator to do a Smart 
Resize.

Adjacent rows can be resized at the same time. Click and drag in the Row Frame to select 
the rows you want: then use any of the above methods to resize.
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Use menu to Smart Resize all the rows in your selection 

Resizing Coloumns

Columns can be made wider and narrower - usually in order to accommodate large or 
smaller font-sized data.

You can do this in three different ways:

Manually: by moving the mouse to the separator in the Column Frame and dragging 
the column to the required height
Via the menu: use Arrange->Row/Column Smart Resize to set the row to the maxi-
mum height needed to accommodate the largest font size in any cell along the row

Automatic by Mouse: double-click on the Column Frame separator to do a Smart 
Resize.

Adjacent columns can be resized at the same time. Click and drag in the Column Frame to 
select the rows you want: then use any of the above methods to resize.

Use menu to Smart Resize all the columns in your selection 
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Inserting And Deleting Rows

To insert a new row, select the row in the Row Frame to the left of which you want to 
add a row, and use Edit->Insert

To delete a row, select the row in the Row Frame, and use Edit->Delete

Adjacent rows can be inserted or deleted at the same time. Click and drag in the Row 
Frame to select the number of rows you want: then use the appropriate command to 
insert or delete the rows.

To add rows at the Bottom edge of the worksheet, use the Sheet Inspector’s Size option.

Inserting And Deleting Coloumns

To insert a new column, select the column in the Column Frame to the left of which you 
want to add a column, and use Edit->Insert

To delete a column, select the column in the Column Frame, and use Edit->Delete

Adjacent columns can be inserted or deleted at the same time. Click and drag in the 
Column Frame to select the number of columns you want: then use the appropriate 
command to insert or delete the columns.

To add columns at the Right edge of the worksheet, use the Sheet Inspector’s Size option.

Hiding and  Unhiding Rows and  Coloumns

To hide rows, select the row(s), and use Arrange -> Row/Column Size -> Hide Rows.
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To hide columns, select the column(s), and use Arrange -> Row/Column Size -> Hide 
Columns.

To unhide rows and columns choose the appropriate unhide command from the Arrange 
-> Row/Column Size menu.

To choose the rows or columns to unhide once they are hidden, select the rows or columns 
that surround them. All hidden parts in this range will be set to visible status on selection 
of the unhide command.

Workbook Windows

Use Windows->New Window to create a new view of your current workbook.

This is very useful when a Worksheet has more columns or rows than you can display 
simultaneously within the Worksheet window. For example, you could show the Totals 
area in one window, the Input area in a different window, and a graph in a third window or 
sheet1 in one window and sheet2 in a separate one

All windows can be moved, resized etc. just like the main worksheet window. The title 
bar of the second and subsequent windows show the workbook name followed by “View 
n”.

To close the view window either click on the close box in the top right-hand corner of the 
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window, or choose Windows -> Close Window from the menus.

There is no realistic limit to the number of windows you can create for a single worksheet.

A window can contain any of the worksheets contained within the Workbook.

When you save the Workbook, the windows and their relative positions are saved as well. 
When you reopen the Workbook, all the windows will open up too.

Linking Workbooks with Formulas

You can link Mesa worksheets so that information from one worksheet can be used in 
another. The file link is entered into a cell, just like a formula.

Mesa’s file link syntax is: 

filename::range 

or

filename!range

where filename is the path to the file to be linked. If filename is a path, it must be an 
absolute path. If it is not a path, Mesa searches for the file in the directory where current 
worksheet is saved. Filename can either be a string or a cell reference. This allows you to 
link to different worksheets based on the contents of a cell Range can be a cell address, 
range, or label.

If both files are in the same directory, you can use just the filename. Otherwise, you must 
specify the path of the linked file. 
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Linked Workbook Examples

Formula Result

=Sales::A1 Returns contents of cell A1 in worksheet Sales located in the same directory 
as the current worksheet.

=/sam/Sales.Mesa::c5 Prices Returns the contents of cell C5 in the /sam/Sales worksheet.

=sum(Sales!a1:b7) Returns the sum of cells A1 through B7 in the Sales worksheet located 
in the same directory as the current worksheet.

=sum(Sales::Western) Returns the sum of the cells in the range Western in the Sales 
worksheet located in the same directory as the current worksheet.

=X1::A1 Returns the contents of cell A1 in the worksheet whose name is contained in 
cell X1.

=sum(X1::widgets) Returns the sum of the widgets range in the worksheet whose name 
is contained in cell X1.

Note that the MAC OS X environment is sensitive to capital letters in file names, so be 
sure to spell file names exactly as you see them. File names may contain spaces, which 
must be included in link references as well. When you work with linked files, be aware 
of the following points:

When you open a worksheet that has links, recalculate using Command-= unless Auto 
Recalc is on.

Links can be used in formulas, just like any other valid expression. For example: 
@PV(2500,4%, “US_SALES”::b5).

Referencing files via cells (i.e., Q5::Prices) is a powerful tool that allows changing where 
the data for a calculation is coming from without changing the formula. If you have sales 
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data from four regions saved in worksheets named, North, South, East, and West, you 
could build a summary worksheet to generate totals for each region. 

The formula =sum(b5::total_sales) would sum the total_sales region for the sheet named 
in cell B5. To see the summary for North, enter “North” into cell B5 and select Sheet 
® Recalculate (Apple-=). To see the summary for West, enter “West” into cell B5 and 
select Sheet ® Recalculate.
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4. Formatting Data

The Sheet Inspector

The Sheet Inspector changes items that affect the whole worksheet or all cells in the 
worksheet. The Tools Inspector... command opens the Inspector box, the sheet inspector 
is the top item in the list. 

The Sheet Inspector displays and changes parameters of the currently active worksheet. 
When all worksheets close, the Sheet Inspector will automatically close because it has 
nothing to inspect.
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Dimensions

Mesa worksheets can have up to 16,384 rows and columns. However, when a worksheet 
has this many cells, using the scrolls to move around the worksheet becomes very clumsy. 
The number of rows and columns displayed in the worksheet can be viewed and changed 
in the Dimensions section of the Sheet Inspector. 

To change the dimensions, enter the desired number of rows or columns in the height 
or width boxes. Mesa worksheets also grow automatically when you move beyond the 
edge with the arrow keys.

NB. Demo versions of Mesa do not allow the dimensions to be changed.

The dimensions of the worksheet affect only how the information on the worksheet is 
displayed. A worksheet may display only 32 rows and columns, but may contain data in 
any cell in the worksheet. The data in cells that is not displayed is not lost and can be 
used in formulas and viewed by setting the worksheet dimensions to the appropriate size.  
There is no speed or storage size penalty associated with larger dimensions.

Recalc

Mesa always uses “natural order” recalculation so that the one answer for a given cell is 
returned correctly even if cell data in other parts of the worksheet are accessed. However, 
Mesa cannot resolve circular references in cell formulas. Circular Reference debugging 
is provided to track and allow you to fix circular references. To enable calculation 
debugging, select “Stop on Error” or “Stop on Circ.” from the pop-up. To step or trace 
through macros, select the appropriate item from the pop-up. 

By default, Mesa recalculates the entire worksheet each time data in the worksheet is 
changed. For large worksheets, this could take a second or two. To disable automatic 
recalculation, uncheck the “Automatic Recalculation” check-box. If Automatic Recalcu-
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lation is disabled, remember to use the Range Recalculate command to update the 

worksheet after data has changed.

Grid

The “Show Grid” check box turns the worksheet’s grid on and off. The color of the grid 
can be changed by dropping a color chip in the color well in the “Color” section of 
the inspector when the drop-down list is set to “Grid”. You can change the background 
color of the entire worksheet by dropping a color chip inside the same color well when 
“Background” is selected from the list. Similarly, the color of protected cells can be set 
by the same method.

All cells that do not have background shading will display this color as their background. 

If the “Clear” check box is checked, the background will appear white on the screen, 
but if the cells are copied and pasted to another application, the background from that 
application will show through.

Protection

Cell Protection is used to block data entry into cells that are not specifically typed 
Unprotected. . To enable cell protection, check the “Enable Protection” check box. 

If protection is enabled, protected cells will be skipped when tabbing through a range 
if “Skip Protected Cells” is selected. Protected cells will be displayed in a special color 
if “Show in Special Color” is selected and the worksheet is protected. The color of the 
protected cells can be changed by dropping a new color into the color well.
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Size

This allows the default cell height and width to be changed. The current default width and 
height is displayed in the current measurement units. To change the width or height,type 
the desired size directly into the height and width boxes. 

Changing the default will not change the size of rows or columns that have been resized. 
For more information, see “Resizing Rows and Columns” .

The Cell Format Imspector

The Cell Style and Cell Format Inspectors, used to inspect and change the contents of a 
cell, reflects the style and formatting information of the current cell. Changes made via 
the Cell Style Inspector will affect the style of all cells in the current range. 
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The Inspectors

Each view contains a button designated “ Default.” If this is selected, the default format 
from the current style template is used. If a change is made to the format, the template 
will be overridden and the new selection will be used for the cell. 

To go back to using the default item for the cell, click on the Default button. 

Changes made in the cell style inspector are applied to all cells in the currently selected 
range.

Format

The format view allows selection of the format used to display the value of the cell. 
Most items apply only to cells with a number value. Exceptions are the Text and Hidden 

formats. The Text format displays the input of the cell. If a cell has a formula, the formula 
- not the calculated value - is displayed. The Hidden format displays nothing in the cell, 
as if the cell is blank. This format can be used to hide intermediate results that would 
otherwise clutter the worksheet.

Date Int’l 1 displays date serial numbers in the format MM/DD/YY.

Date Int’l 2 displays date serial number in the format MM/DD.

Time Int’l 1 displays the time portion of date serial number in the format HH:MM:SS.

Time Int’l 2 displays the time portion of date serial numbers in the format HH:MM.

The decimal selector changes the number of decimal places displayed when Fixed 

Decimal, Scientific, Currency, Comma, and Percent formats are selected.
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Color

The information in cells is displayed in color. Normally, the contents will be displayed 
in the “Text Color.” However, if the value is a negative number, it will be displayed in 
the “Negative color.” 

The colors may be changed by dragging and dropping a color chip into the appropriate 
color well. The patterns may be changed by dragging and dropping a pattern chip from 
the pattern picker into the color well. The text color of a cell or a range of cells can 
be changed by dragging and dropping a color chip on the cell or range directly on the 
worksheet. The color picker can be opened by clicking on the border around the color 
well or with the Tools -> Colors... command. It may be useful to place this command on 
the Toolbar so that the color picker can be quickly opened.

The background or shading of a cell can be changed by Alt-Dragging a color chip. 
To Alt-Drag a color chip, press the Alternate key before you click on the color well to 
pick up the color chip. When you drop the color chip on a cell or range, you will not 
see the color change until you un-highlight it. The background pattern of a cell can be 
changed similarly.

By default, the cell is shaded with the background color of the sheet. To set a background 
fill, click on the Fill switch. If the background and the shading color are the same, then 
you will not see a change; however, if you change the background color of the sheet, 
the cell will retain its color. To change the cell shading, you can Alt-Drag color over 
the selected cell or range or drop the color in the Shading color well in the Cell Style 
Inspector.

Alignment

Use the Alignment tool to decide on the position of the data within the cell.
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The Wrap option wraps string information in the cell down so that it does not spill out the 
sides of the cell, but is displayed on multiple lines within the cell.

Smart sets text back to left aligned, and Numbers to right-aligned.

Font

This view of the Cell Style Inspector allows you to change the font by dropping a font 
chip in the font well. Open the Font Panel by double-clicking in the font well, by clicking 
the button marked Font, or by using the Format -> Font... (Apple-t) command. 

You can underline the contents of a cell by selecting a single, double, or wide line 
options.

Input Type

Mesa allows basic checking of data input. Cells can be designated as Numeric, String, 
Date, or Formula and that cell will accept only input of the designated type. If a cell is 
typed Any, then any type of data is allowed for input. Unprotected cells are like cells 
typed any, yet data can be entered into an unprotected cell even when sheet protection 
is enabled.

Justication

Use the Cell Format Inspector to align the contents of a cell.
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Any kind of data - text, numbers or dates - can be aligned, to the Left, Right or Center..

If you make a row higher, you can also use the Top, Canter.. and Bottom alignment 
options.

The Wrap option will ‘word-wrap’ text within the row height.

* Mesa does not let you align data over a width greater than one column.
* The Smart option aligns Text to the left, and Numbers and Dates to the right.
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Changing Color

Use the Sheet Inspector to change the color of data and background for the entire sheet.

Use the Cell Format Inspector to change the color of data and background for the selected 
range.

The colors may be changed by dragging and dropping a color chip into the appropriate 
color well. The text color of a cell or a range of cells can be changed by dragging and 
dropping a color chip on the cell or range directly on the worksheet. 

Open the color picker by clicking on the border around the color well or using the menu 
Tools ->Colors.

By default, the cell is shaded with the background color of the sheet. To set a background 
fill, click on the Fill switch. If the background and the shading color are the same, then 
you will not see a change; however, if you change the background color of the sheet, 
the cell will retain its color. To change the cell shading, you can Alt-Drag color over 
the selected cell or range or drop the color in the Shading color well in the Cell Style 
Inspector.

* The Negative color is the one that Negative numbers will use.
* Use Drag from the Color Wheel to change the color of the data in a cell

Use Alt-Drag to change the background color of a cell.

When you drop the color chip on a cell or range, you will not see the color change until 
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you un-highlight it. 

* You can drag a color chip into the Tool

Changing Fonts

Use the Sheet Inspector to change the default font for the entire sheet.

Use the Cell Format Inspector to change the font for the selected range.

The fonts may be changed by dragging and dropping a font chip into the appropriate 
font well, or by dragging and dropping a color chip onto the cell or range directly on 
the worksheet. 

Open the font panel by double-clicking on the Font well, or with the Format->Font 
command.

* The MAC OS X Font Panel shows you a scrollable list of all the type families 
and typefaces available. The panel also has a table of type sizes in points, and a font 
viewer window (a “font well”).
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Click the Preview button to see the result in the font viewer. If you like what you see, 
click the Set button and your font will be applied to the cell range you specified. 

You can also drag the font from the font well by clicking in the well and dragging the tiny 
font chip icon to the cell or range you specified on your worksheet or drop a font chip on 
an element in a chart to change its font.

If you change your mind, click Revert to restore the original font.

Changing Borders

Use the Sheet Inspector to change the default border type for the entire sheet.

Use the Border Inspector to change the border for the selected range.
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Use the QuickBorder Pop-up to fill in 
the commonly-user border types. Or 
click on each individual part of the 
‘Cell’ in the Inspector
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Number Formats

Use the Sheet Inspector to change the number or date display format for the entire sheet.

Use the Cell Format Inspector to change the number or date display format for the 
selected range.
Most items apply only to cells with a number value. Exceptions are the Text and Hidden 
formats.

Options

The decimal selector changes the number of decimal places displayed when Fixed 
Decimal, Scientific, Currency, Comma, and Percent formats are selected.
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Text Format. The 
Text format displays the 
input of the cell. If a cell 
has a formula, the for-
mula - not the calculated 
value - is displayed. 

Hidden Format. The 
Hidden format displays 
nothing in the cell, as 
if the cell is blank. This 
format can be used to 
hide intermediate results 
that would otherwise 
clutter the worksheet.

Date Formats

Date Int’l 1 displays 
date serial numbers in 
the format MM/DD/YY.
Date Int’l 2 displays 
date serial number in the 
format MM/DD.

Time Int’l 1 displays the time portion of date serial number in the format HH:MM:SS.
Time Int’l 2 displays the time portion of date serial numbers in the format HH:MM.

Copying Formats

Use Edit -> Paste Special->Format to copy all the formatting characteristics of a cell.
This lets you paste the format of the cell range that was cut or copied into the pasteboard, 
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to a specified location on a 
worksheet without pasting any 
included values.

Negative Color

Use the Sheet Inspector to set the Negative color for the entire sheet.

All numbers less than zero will be displayed in this color.

Use the Cell Format Inspector to set the Negative Color for selected cells in the worksheet
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5. Printing

Introduction

Printing is likely to be an important part of your Mesa usage.

Mesa has a flexible approach to printing which lets you do anything from quick-and-
simple prints of the entire worksheet, through to complex report layouts designed with 
the Report Designer.

* If you just want a quick print for draft purposes, look at the Simple Printing topic
* If you want to use headers and footers, shrink-to-fit, multiple print ranges etc., 
look at the Report Designer topic

Simple Printing

Select the range you want to print, and choose Print from the main menu (or click the 
Print button on the Workbook) 

Select a printer if necessary from the Print panel, and preview, print or fax your work-
sheet.

Use the Page Layout panel for simple control of page size etc.

Remember that the Report Designer gives much more control over print layout.

* If you don’t select a range, Mesa will print from A1 to the bottom leftmost data 
 cell.
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* If your range extends beyond the edges of the worksheet, then you can use the  
 Range -> Goto... Cell panel to define the range to print.
* For example, type the range A1:Z200 in the Goto... Cell box, click OK, and Mesa  
 will select the range from A1 to Z200 to print.

Printouts will always show the cell grid. If you don’t want the cell grid to print, use 
Report Designer to set grid lines off.

Setting Pagebreaks

Use Format-> PageBreaks to force a printout to start a new page at a particular column 
or row. 

Set Vertical Breaks sets a vertical page break at the right of the selected range.

Set Horizontal Breaks sets a horizontal page break below the currently selected range.

Clear Vertical Breaks clears vertical page breaks in the selected range.
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Clear Horizontal Breaks clears horizontal page breaks in the selected range.

* When page breaks are set, the row or column separation corresponding to the page 
 break changes from white to black.

The Report Designer

Use the Report Designer to create sets of printing commands which can be used repeat-
edly to print your data and make it look good.

Start the Report Designer with Tools->Report Designer, or by clicking the Reports 
button on the worksheet Toolbar.
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For each report you can: 

* define data ranges
* define graphs to print
* set page orientation
* create Header and Footer contents, including graphics
* Smart-Size the print to fit the paper page
* choose whether or not to display grid lines
* set Print Titles
* name the Report
* and more...

To print a Report, either click the Print Report button on the Report Designer, or select the 
report you want from the Print panel.

More detail on setting up a report is given in More on Report Designer.

* A worksheet can have lots of reports associated with it.
* Reports can only print data from the worksheet they are in.
* Reports are saved automatically when you save a worksheet.

More on the Report Designer

The following table summarizes the elements of the Report Designer panel.

To bring the panel select Tools->Report Designer

 This will bring up the Report Selection window. Next select New or Edit (edit existing 
reports), this will open the Report creator window.
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Item   Description
    
Report Name   Each Report has a name. That is how you tell Mesa which report  
                         you want to print or change. Report names should describe   
              the report, e.g., Q1_Sales, Checking, Summary_Report.

Print Button   After a report has been added, you can click on the print button to  
              print the currently selected report. The Print Button is a tool that 
   you can Command-drag to the Toolbar or a Tool Holder in a  
   window.

Ranges   A range is a group of cells or a graph that you want to print. Mesa  
   starts printing each range on a new page. A report can contain up  
   to 32 ranges.
   To print a graph, use the format:
   g=graphname
Range Scaling 
Options            The range scaling options Smart Width and Smart Scale change the  
                        size of the font used in printing the ranges. Smart Width will adjust      
             the printed range so that it is only one page wide. Smart Scale will  
             adjust the scale so that the entire range prints out on a single page.

 Page View            A report starts as a blank page. Ranges are printed within the  
             page margins. In addition, you can place tags on the page. You  
                       should place tags outside the margins so that they are not printed        
             over. Tags contain information that you want to appear on every  
             page such as print date or time, file name, or some text that you
              enter.

View Scale   A full-sized page is too big to be displayed in the Report Format  
   panel. You can change the scale of the page (miniaturize it) so that  
   you can see more of the page, or ªzoom inº and work on a specific
   part of the page.
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Item   Description

Margins   The margins are the borders on the page within which ranges are  
         printed. You can adjust the margins by moving the mouse over  
   a margin, clicking and dragging until the margin is    
   sized to your satisfaction. If you hold the Command key   
   while you are dragging the margin, Mesa will adjust   
              the corresponding margin to the same size.

Page Layout   The Page Layout allows you to change page attributes. For exam 
    ple, you could print in landscape mode on legal paper by entering 
              14 for the paper width and 8.5 for the height and clicking ªSet.º

Tags    Tags can be dragged and dropped onto your page and moved  
   around. Tags contain information such as print time and date,
   file name, page number, etc. Tags are printed on every page. Be  
   sure to place tags outside the margins so that they are not covered  
   by the ranges.

Show Grid   This option will print the worksheet grid for all ranges

 

Print Across   This option will cause multiple-page ranges to print across before  
   printing down.
Show Row/
Col Headings  This option will show the worksheet row and column headings for  
   each range.
Ignore Page 
Breaks    This option will cause any page breaks set within the worksheet to  
   be ignored. Page breaks will still occur between ranges. 
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Using Formatting Tags

Adding Tags to Reports

In the Report Creator you can drag ‘tags’ onto the layout. The tags allow you to do 
things like: 

* Automatically print page numbers on your reports 
* Print the correct date and time 
* Add freeform Text to the report (like a heading, or your name) 
* Print the contents of a particular cell and more 

Tags should be dragged into the margin areas of the page. If you place a tag in the main 
page area, the tag will overprint the data from the Data Ranges, which probably is not 
the effect you’re looking for. 

The contents of a Tag will print out on every page of your report.

NB. Don’t forget that you can add graphic images - e.g. your Company Logo - to a 
report just by dragging the image in from the Mac OS X Finder. 

There is no special ‘graphics’ tag. Tags can be moved, resized and inspected (by double-
clicking) to change their appearance to the way you want them. 

There are tags for: 

Page Number - prints the page number, incrementing by 1 

Cell - Prints the contents of the specified cell address e.g., whatever is in A23 

Date - the date at the moment of printing 

Time - the time at the moment of printing 
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Text - whatever text you want - e.g. ‘Compiled by A. N Other’ 

NB. When you drag a Text tag onto the report, it contains the word ‘Text’. To edit 
this, HOLD DOWN THE ALT KEY AND CLICK THE Text TAG. 

Sheet Name - the name of your workbook and the worksheet you’re printing 

Pathname - the filesystem path to the workbook you’re printing. 

Tag Inspectors 

Double-clicking a tag will bring up the Inspector. Use the inspector to change the borders, 
the colors, the text alignment in the tag width, and where appropriate the Format (e.g. 
different Date formats) 

Headers and Footers

You might want to use a different font in a report tag for stylistic reasons. 

To change the font:

Select Format->Font to display the Font Panel and move it to a convenient place on 
the screen.

Select a new typeface and size 

Repeat this process until you find the font that you want.

Drag the font chip to the tag box and drop it in. The font of the text will change.
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You may need to resize the tag box (with its handles) to be sure that all of the text 
is visible.

You can change the color of a tag just like changing the font. Simply open the color panel 
with Tools->Colors,choose the color, and drag & drop the color chip onto the tag.

NB The background color of the tag can be changed by Alt-dragging a color chip onto 
the tag.

Page Orientation

You can easily swap from Portrait to Landscape layout by clicking on the appropriate icon 
in the Report Layout or the Page Layout panels.

Note that in the Report Layout, Tags are not automatically moved to reflect the new 
orientation. You’ll have to drag them to the correct positions.
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The Print Panel

Mesa uses the standard MAC OS X print panel accessed from the Print option on the 
main menu.

You choose which printer you want to print to, or whether you prefer to simply preview 
the output on your screen.
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6. Working with Databases

The Extract Inspector
This Inspector allows you to extract spe-
cific information from a database and put 
it elsewhere in the worksheet.

 Extract Queries can be given names and 
reused whenever necessary.

Some preparation needs to be done on 
the worksheet before you use the Extract 
Inspector. You must allocate an area for 
each of the following Extract ranges:
Data the data you want to inquire about
Criteria where you specify the Condi-
tions you want your data to meet
Destination the area to which rows which 
meet your Criteria will be copied

In the Extract Inspector, give the Extract 
Query a name, and fill in the Range 
details. Click the Extract Button to run the 

Extract and populate the Destination Range with the rows which satisfy your criteria.

* The button marked Extract can be Command-dragged as an Icon on a Tool 
Holder on the Workbook or to one of the spots in the Toolbar.
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Data Ranges

The rows and columns which hold the data you want to inquire about are the Data 
Range.

* Rows are sometimes called Records
* Columns are sometimes called Fields

The first row of the Data Range must contain Labels as the column identifiers (Field 
Names)

Criteria Ranges

The Criteria Range holds the conditions which control which rows are extracted to the 
Destination Range.

The Criteria Range must contain the same column headings as the Data Range, and must 
be defined as at least the column names and one row below.

Criteria ranges must contain at least two rows. The top row contains the names of the 
fields in which to search, and the other rows list the conditions that must be met. Criteria 
may be numbers, strings, or formulas.

Criteria in the same column are treated as “or” statements, and criteria in different 
columns are treated as “and” statements. If the criteria range were f1:f2, all records whose 
Region field was “West” would be extracted from the database. If the criteria range 
were f1:f3, all records whose Region field matched either “West” or “South” would be 
extracted. If the criteria range were f1:g2, all records that matched the criteria of Region 
being “West” and the Sales field being “high” would be extracted.

For criteria containing formulas, the field must be explicitly referred to in the formula. 
For example, to extract the records for all employees whose ID numbers are greater 
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than 103, the criteria would read =A2>103. The same rules apply for “or” and “and” 
in rows and columns.

* You can have as many rows as you like in a Criteria Range, If you add rows to the 
 range, don’t forget to redefine the range in the Extract Inspector!

Destination Range

The rows which satisfy the Criteria in a query are copied to the Destination Range.

* Column headings (Field Names) are not copied to the Destination range.

You should specify a Destination range which is wide enough and long enough to hold the 
maximum amount of rows you will ever retrieve.

If your destination range is too small, you run the risk of working with insufficient data.

Sort

Range->Sort... displays a Sort dialog panel that allows you to sort the data on your 
worksheet. 

First, select a cell range on your worksheet, then click on the Sort... command. You will 
see a dialog panel where you can choose to sort by rows or columns, and where you can 
specify up to three sort keys to be used to sort in either ascending or descending order.

If the first row or column of your range contains titles, click the Has Titles box to prevent 

the titles from being sorted.
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7. Working With Ranges

Labeling Ranges

Labels are names that are assigned to a rectangular range of cells. Ranges can be 
designated as AutoGrow. 

Use the Label Inspector to set up or 
delete Label names.

To add a range, type in an appropriate 
name, press Tab, enter the cell range 
for the label, and press enter. The 
range will be added to the list. 

To change a range, click on the range 
in the list. The name and cell range 
will be placed in the text fields. Make 
the appropriate changes and click on 

Update. 

To remove a range from the list, 
select the range and click Delete. 

To select a range on the worksheet, 
select the range name, then click Goto....

* The Run button may be Command-dragged to either the Toolbar or to a tool  
 holder in a window
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Range QuickLabels

You can use the Range -> Labels menu options to set up named ranges quickly.

Insert Label Index displays a list of all labels and their range addresses in a column on 
the worksheet, starting in the current cell. This is useful if you frequently refer to the 
ranges that you have labeled.

Label Range To: Right, Left, Top, Bottom. These four commands let you specify the 
direction of your label range, depending on the label you specify before invoking one 
of the commands.

If you enter a name in a cell, you can assign it as a range label to any adjacent cell by 
using the Range Labels menu. For example, if you enter Sales into a cell and select 
Range/Labels/Label Range to Right the label Sales will now refer to the adjacent cell 
on the right. You can also choose Left, Top, or Bottom.

Delete All Labels removes all the labels from the worksheet.
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Autogrow ranges

This feature, applied to a named range, allows the range to grow beyond its defined size 
when new information is added. 

Use the Label Inspector to define a 
range as Autogrow.

Use the enter key to move the cell 
cursor past the bottom row of the range 
and see that a new row is added to the 
range each time you press the key. The 
formula and formatting information is 
copied from the line above.

AutoGrow ranges are useful for data 
entry templates, because you don’t 
need to pre-allocate and format a range 
for data entry. Set the range to Auto-
Grow and as more data entry space 
is needed, the range will expand auto-
matically.

The Label Inspector

The Label Inspector lets you set up, rename, and delete range names on your worksheet.

To add a range, type in an appropriate name, press Tab, enter the cell range for the label, 
and press enter. The range will be added to the list. 
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To change a range, click on 
the range in the list. The 
name and cell range will be 
placed in the text fields. Make 
the appropriate changes and 
click on Update. 

To remove a range from the 
list, select the range and click 
Delete. 

To select a range on the 
worksheet, select the range 
name, then click Goto....
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8. Working With Statistics

Scenarios

The Scenario Inspector creates tables which take values for one or two variables, and the 
result of each value or set of values in a given formula. 

Mesa scenarios allow you 
to use your spreadsheet to 
make calculations based on 
more than a single formula 
and set of variables. For 
example, you might want to 
calculate the monthly pay-
ments and total payments on 
a loan for payment plans 
with different interest rates. 
You could also use scenarios 
to find the orbital angular 
momentum of a body given 
different theoretical values 
of its semi major axis and 
orbital period. Scenarios are 
especially useful when you 
are concerned with a set 
of predicted or theoretical 
values and varying condi-

tions.

Mesa has two types of scenarios. 
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Single Input scenarios show the result of changing the value of a single variable in 
different formulas.

Double Input scenarios compute the result of a single two-variable formula for different 
values of each variable. 

Both types of scenarios are created using the Scenario Inspector.

The Scenario Inspector creates a scenario table. A single input scenario will create a table 
which shows the result of using each different value of the variable in each formula. 
Double input scenario tables show the result of each different set of variables in the 

equation.

Using the Scenario Inspector

Mesa scenarios are calculated using the Scenario Inspector. To open the Scenario Inspec-
tor select Tools ® Inspector ® Scenario Inspector... in the menu. Give the Scenario a 
name by typing it into the space at the bottom. Enter the cell name for the input cell or 
cells, and the range of the scenario table. Once the information is entered, click on the 
Add button. The name of the Scenario will appear in the list in the middle of the Scenario 
Inspector. You can remove, change, or run a Scenario by clicking on its name in the list, 
which will highlight it, and then clicking the appropriate button.

Mesa runs all “Run before each recalc” Sybase queries before running each data point 
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in a scenario. Scenarios recalculate the worksheet after they execute, even if auto-recalc 
is off.

Creating Single Input Scenarios

To create a single input scenario, choose a column to enter the different values of the 
variable into. Leave the first cell of the column blank and enter the values starting with 
the second cell of the column. For example, if you wished to make a scenario using ten 
different values of a variable starting in the upper left corner of the spreadsheet you would 
leave cell A1 blank and enter the values in cells A2 through A11. 

Next, enter the your formulas in the row corresponding to the blank cell at the top of 
the data column, and starting in the next column over. In our example, if you had five 
formulas you would enter them in cells B1, C1, D1, E1, and F1. When entering the 
formulas, refer to the variable using a cell name. This cell is the input cell, and can be 
any cell on the spreadsheet that is not part of the scenario table and does not contain a 

formula. You can also use the blank cell at the top of the input column. For example, you 
might enter the formula =A1^2 in cell B1 to find the square of the values in column A. 

Note that as a result of Mesa’s normal formula computation, the cell you enter the formula 
in will display the value of the formula with the variable equal to the contents of the 
input cell. 

Once you have entered the variable values and the formulas, use the Scenario Inspector 
to run the scenario. The Scenario Inspector will create a table with the values of the 
formulas computed for each of the variable’s values in the appropriate cell. For example, 
cell D9 would contain the value of the formula in column D computed with the variable 
value in row 9. 

The table is a range on the worksheet that includes the row and column with the input 
values and formulas. In our example above the range of the scenario would be A1:F11.
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Creating Double Input Scenarios

To create a double input scenario, choose a column to enter one set of variables into, and 
a row to enter the other set of variable. The formula is entered in the cell where the two 
intersect. For example, if you wanted to place your scenario in the upper left corner of 
the spreadsheet, you would enter one set of variables in column A starting with cell A2, 
and one set of variables in row 1 starting with cell B1. The formula would be entered 
into cell A1. If there were ten values of each variable, the range of this scenario table 
would be A1:K11. When the scenario is run, a table will be created in the range with 
the value of the formula using each pair or input values in the appropriate cell. For 
example, cell C6 would contain the value of the formula using the input values in column 
C and row 6.

When you enter the formula into the formula cell, refer to the variables using two input 
cells. The two input cells may be any two cells on the worksheet that are not part of the 
scenario range and do not contain formulas. As long as these two conditions are met, 
the input cells can be anywhere on the sheet, and do not have to be blank cells. Once 
you have entered both the input values and the formula use the Scenario Inspector to 
run the scenario.

Matrix manipulation

The Matrix sub-menu contains Mesa’s matrix manipulation commands. These commands 
can be used to perform various operations on matrices. 

Regress performs linear regression on the input range. Place your matrix numbers in a 
range on the worksheet with the x values in the leftmost columns, and the y value in the 
second to last column, with empty column next to the y values for the output. Highlight 
the range, and select the command. The results of the linear regression will be calculated 
and placed in the right-hand column. 
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Invert will calculate the inverse of a matrix. Highlight the matrix that you wish to find the 
inverse of, and a range of equal size immediately to the right of it. When you execute the 
invert command, the inverse of the matrix will be placed in the empty cells to the right of 
the original matrix. Only square matrices may be inverted. 
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9. Working With Charts

Creating a Chart

First, select the range on the worksheet that you want to chart. If the range includes 
labels at the left and the top, then these labels will be used as the X and Y axis labels 
on the chart.

Then click the Chart Icon on the Workbook Toolbar (or use select Tools->Charts from 
the menu).

The Chart Selection Panel will appear. There are three main 
Chart Types (Bar, Line and Area). Within each Type there are 
several variations: for example a Bar Chart can be Stacked, 
Horizontal, 3D and more.

Click on the Type you want. The Chart will draw itself on the 
worksheet at the current cursor position. The Chart Inspector 
will also appear.
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Use the Chart Inspector to change and customize the chart.

You can have as many charts as you like on the worksheet

You can move and resize charts.

Chart Types

Once you have created a chart using the Chart Selection Tool, you can change it from one 
graph type to another by using the ‘Chart’ aspect of the Chart Inspector. Double clicking 
on a graph will open the Chart Inspector.

Each type of chart in Mesa can be modified in a number of ways using the Inspector. You 
can add titles labels, and legends, and change the orientation and color of the graphs.

In addition, some graphs have a Current view on the graph inspector that allows you to 
change the graph in a way specific to that graph type. For more information about graph 
titles, orientation, color, etc. see “Chart Inspector Commands” .

The graph data is set to “Left Column has Titles” off, and Horizontal data orientation. 
To set these parameters, use the Chart Inspector. To open the Chart Inspector, you can 
double-click on a graph . 

You must have the chart that you want to inspect selected in order to see the Chart 
Inspector. 

To remove a chart or graphic from the worksheet, select it and press the ¬ key or select 
Edit Cut.

Bar and Column Charts

This view allows you to determine the width of the bar or column by moving the slider 
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to select the desired width. The line option will plot a line (the first series of data) on 
the same graph. If the orientation of the graph is horizontal, the line is plotted from the 
data in the left column. If the orientation of the graph is vertical, the line is plotted from 
the data in the top row.

Scatter Charts

Scatter charts can be drawn with data points, lines, or both. Select the drawing method 
using the radio buttons. Use the slider to adjust the line width.

XY Charts

In addition to the chart options for lines and data points that Scatter Charts allow, XY 
charts allow you to select whether the Y values of the plot will be matched with a single 
set of X values or if they will be matched with the X values of the adjoining row or 
column. The default is a single X axis.

High/Low/Close Charts

High/Low/Close charts have an option for displaying candlestick graphs. This option is 
chosen by default.

3D Charts

3D charts have sliders for adjusting the X and Y rotation of the graph and a wire frame 
option.

Sample Data: The following examples of chart use this data, unless otherwise noted: 

Chart Inspector

Once you have created a chart using the Chart Selection Tool, you can use the Chart 
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Inspector to tailor the chart to your precise requirements.
Switch between the various aspects of the Chart by using the Pop-up List on the Inspector. 
You can change Chart Type, add Titles, change the ranges in the Chart, change Colors, 
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add and move the Legend,and more.

In addition, some charts have a Current view on the inspector that allows you to change 
the chart in a way specific to that chart type.

The Inspector allows you to invoke special features in Mesa’s graphs, including graphing 
discontiguous ranges, adding labels, and creating mixed bar and line charts. The different 
views of the Inspector allow you to adapt different parts of your chart to suit your needs.

* Double clicking on a chart is another way to open the Chart Inspector.
* The Chart Inspector panel changes to say ‘No Chart Selected’ when a chart is no 
 longer selected and reappears when the graph is selected again.

Customizing a Chart

By default, Mesa automatically chooses the largest and smallest X and Y values for data 
plots. You can change these values manually to enhance the appearance of a chart. To turn 
off automatic scaling, click the Auto Scale check box. Enter the desired scale values in the 
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text fields and press enter. The minimum and maximum values must be different.

Graphs are displayed in linear scale by default, but can be displayed in log scale by 
clicking the “Log Scale” check box.

Changing Charts

From the three Pop-up menus on the Chart Inspector, you can inspect and change the 
following aspects of the currently selected chart.

Name

Each chart has a unique name. You select a chart by name using Range ® Goto.... You can 
also print a chart by name in a report. To change the name of a chart, select the name, be 
sure that the Graph Inspector is selected (i.e., the title bar is black not light gray), type the 
new name, and press enter. You cannot give a chart the same name as another chart in the 
worksheet. If you try to, Mesa will beep and the name will not change.

Color

The Color view allows the background color, border color, legend background color, and 
3D background color to be changed. If the “Clear” check box is checked, the background 
below the graph will show through. This is especially useful for developing presentations 
using Concurrence(tm) or Create(tm). The width of the border can be changed using the 
slider below the border color well.
To change the color or pattern of the plotted part of the graph you do not need to use the 
Graph Inspector. Simply drag and drop color chips onto the graph itself. Mesa will keep 
color shading consistent for data that is grouped together. 
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Labels

The different areas of the on the Label view if the inspector allow you to change the 
appearance of the graph’s labels. Labels are placed near the horizontal and vertical axis 
of a graph. 

You can adjust the rotation of the labels using the Label Rotation area. Rotating labels 
enhances the visual appearance of the chart and can be used to display labels that would 
otherwise overlap. Labels may be rotated using the sliders or by typing the desired 
rotation in the text fields and pressing enter. 
The check boxes in the Label Location area allow you to designate whether the top 
row and/or the left column contains additional labels. You can also designate ranges 
containing additional labels using the Range view of the Graph Inspector. Flat graphs 
can display one set of additional labels, and 3D graphs can display two sets of additional 
labels.
The font wells in the Fonts area of the view display the current font used to draw the 
labels on the X and Y axis. To change the font, open the Font Panel by selection Format 
® Fonts... (Apple-t) or by double-clicking in the font well. Build the desired font and drop 
the font in the appropriate font well. The fonts of the X and Y axis can also be changed by 
dropping a font chip on the X or Y axis or any label of the chart.

The Display Format area of the view allows you to change the format and precision of the 
axis labels. You can select any of the Mesa’s standard format, including date formats. This 
will not affect the format of additional labels. 
The Label Position area allows you to select the vertical centering of labels drawn on the 
Y axis. Select the setting that you prefer.

Titles

Charts can display titles on the top, bottom and left side. The First and Second titles are 
drawn at the top of the chart. The X Axis title is drawn under the X axis. The Y Axis title 
is drawn to the left of the Y axis and is rotated 90 degrees. Enter the text to appear in the 
titles. The font of each title can be changed by dropping a font chip in the font well or 
by dropping a font chip on the title of the chart. If Cell Reference is checked, the text is 
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interpreted as an address and the contents of the cell at that address is displayed.

Orientation

The Orientation defines the order that the data will be accessed when drawing the chart. 
Horizontal orientation reads data “across” and additional data ranges are added under the 
base range. Data in a column will show up with the same color and pattern. Vertical 
orientation reads data “down” and additional ranges are added on the right side. Data 
in the same row is given the same color and pattern. Mesa tries to choose the correct 
orientation for your data when you create a graph.

Ticks

This view allows you to set how the format in which ticks on the X and Y axis will 
be drawn.

Scale

By default, Mesa automatically chooses the largest and smallest X and Y values for data 
plots. You can change these values manually to enhance the appearance of a chart. To turn 
off automatic scaling, click the Auto Scale check box. Enter the desired scale values in the 
text fields and press enter. The minimum and maximum values must be different.
Graphs are displayed in linear scale by default, but can be displayed in log scale by 
clicking the “Log Scale” check box.

Grid

This view allows you to control the display of a light gray grid in the background of the 
chart. You can also select an optional black border around the graph area on the chart.

Range

You can add up to six discontiguous ranges to the base range of a data plot. Additional 
ranges will be added at the bottom or right side of the prior data range depending on the 
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orientation of the chart. (See “Orientation” .) To add ranges, type the range into each of 
the six provided text fields.
In addition you can also add ranges containing titles to your graph using the Top Titles 
and Side Titles fields. The contents of these ranges will be added as additional labels to 
the graph the same way that selecting Top Row or Left Column in the Label Location area 
of the Label view would, except that the ranges entered as titles in this range do not need 
to be in a specific location in relation to the rest of the data.

Legend

This view allows you to place a data legend on the chart. The legend can be located on 
top, below, or on either side of the chart. The legend’s font can be changed by dropping a 
font chip in the font well or by dropping a font chip directly on the legend on the chart. 
The color of the chart can be changed by dropping color chips on the legend or by 
dropping the color chips on the item that you want to change directly on the graph.

Current

Some chart types have special inspector views to change unique parameters. These views 
appear in the Current view depending on the chart type.

* You can have as many charts as you like on the worksheet
* You can move and resize charts.
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10. Working With Graphic Objects

Shapes

You can pull Shapes onto the worksheet with the Graphics Shapes tool.

Use Tools->Graphics to bring up the Graphics panel, and select Shapes from the Pop-up 
list.

Drag any shape onto the area you want to affect.

If you double-click a Shape on the worksheet, you can change it’s color and border with 
the Shape Inspector.

* Rich Text is the only Shape that you can type text into. It’s the most useful shape 
 for this reason. Use it to add comments to your Charts or worksheets.
* You can drag any Shape into the Toolbar..

Graphical Images

You can put Graphic objects onto the Mesa sheet and into Report Layouts.

Drag any TIFF or EPS file icon from the Workspace onto your Mesa sheet: it will 
immediately ‘stick’ on to the sheet.

Graphic objects can be selected and moved just like the native Mesa Charts and Shapes.

* To put a Graphic image on a Report, first drag a Graphic Tag from the edge of        
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the Report Layout onto the correct position on the page. Then drag a TIFF or EPS icon 
from the workspace onto that Graphic Tag. You’ll see the cursor turn green when you’ve 
reached the correct ‘dropping’ position.

Graphics on Reports can also be moved and resized.

Adding graphics/images to the worksheet 

Adding images to the workbook 

You can easily add graphic images (.gif, .jpeg, .tiff etc.) to your workbook. 

For example, you might want to put your company logo at the top of the worksheet. Or 
if you’re grading students you could put their photograph above their subjects and grades 
so that you can identify them! 

Just use the Finder to locate the image you want to add, and Drag it from the finder 
into the worksheet. 

Once the image is there you can move it and resize it as you want. 

You can add as many images as you want. 

To delete an image from the worksheet, just select it and press Backspace or Edit-
>Delete. 

Tip: if you want an image such as your Company Logo to ‘freeze’ at the top of the 
worksheet window and you want to see it regardless of the No of rows you scroll down 
the worksheet , take the following steps: 

 1. Drag the image to the position you want, probably near cell A1. 
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 2. Put your mouse on the top border of the worksheet 
 3. Drag the ‘Freeze border’ down below your image.

Freeze border 
arrow

Top image stays 
always visible

Scrolling section of 
the worksheet

The picture above shows a worksheet where we have performed the above 3 steps

You can also use the Layer Inspector to move your images to appear either underneath 
or above the grid lines. 

The Layer Inspector

The Layer Inspector allows you to look at Graphic objects (Charts, Icons and other 
graphics you have introduced on to the worksheet), and adjust their relative positions

All Graphic objects can be moved ‘up’ and ‘down’ relative to other objects, selected areas 
on the sheet (shading) and the cell grid lines (sheet). You cannot change the name of a 
Graphic object in this Inspector.  
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Graphics in Report Layouts

To put a Graphic image on a Report, first drag a Graphic Tag from the edge of the Report 
Layout onto the correct position on the page. 

Then drag a TIFF or EPS icon from the workspace onto that Graphic Tag. You’ll see the 
cursor turn green when you’ve reached the correct ‘dropping’ position.

Graphics on Reports can also be moved and resized
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11. Working With Co Workers

Why Share Sheets?

If you share worksheets with other users, or if you create worksheets which you intend 
to give to other people to use, then you can do quite a lot to make your and other users 
lives easier. Mesa allows you to:

* Protect cells on your sheet so that no-one can type into them (useful for stopping  
 yourself or others from typing over formulas by mistake).
* Give meaningful names to parts of the worksheet and use those names in Reports, 
 Formulas and Goto...s
* Designate cells on your worksheet to accept only particular types of input.
* Delete data only from cells containing designated data types.
* Design report layouts which ensure that all users will produce the same well-
 presented printouts.

Protecting Your Worksheet

Within your worksheet, you can designate protected and unprotected cells. Typically 
you’ll do this if you have a sheet where you don’t want users to overwrite formulas and 
headings by mistake.

When you create a new worksheet, protection is off by default. After you have built a 
structure that requires some ranges to be protected and others open for data entry, you 
should do the following:
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* In the Sheet Inspector select the  
 “Enable Protection” aspect and tick       
 the Check-Box . The entire 
 worksheet is now protected.

* Anyone using the sheet can turn off  
 the Sheet Protection. Setting 
 protection is not a guarantee that  
 no-one will ever delete your 
 formulas or overwrite constant data. 

Protecting Cells

Within your worksheet, you can designate protected and unprotected cells. Typically 
you’ll do this if you have a sheet where you don’t want users to overwrite formulas and 
headings by mistake.

When you create a new worksheet, protection is off by default. After you have built a 
structure that requires some ranges to be protected and others open for data entry, you 
should do the following:

In the Sheet Inspector select the “Protection” aspect and click the Protection button to 
display the check mark. The entire worksheet is now protected.

Next, highlight a range you want to unprotect. In the CellStyle Inspector select the “Input 
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Type” aspect. Select the Unprot’d radio button.

The range you selected is now unprotected. This is now the only area in which you are 
allowed to type.

You can mark lots of different areas as Unprotected.

Anyone using the sheet can turn off the Sheet Protection. Setting protection is not a 
guarantee that no-one will ever delete your formulas or overwrite constant data. 

Controlling Data Input

Mesa allows basic checking of data input.

Use the Cell Format Inspector to designate cells as 
Numeric, String, Date, or Formula. That cell will then 
accept only input of the designated type. 

This is very useful if you want to be sure that, for 
example, users only ever put valid dates into a date 
column.

* If a cell is typed Any, then any type of data is  
 allowed for input.

Range Names

You can give English-like names to cells or ranges of cells.
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You can then Goto... or Select the area by referring to it’s name rather than having to 
remember the cell references. This makes it easier for both you and other users of your 
worksheet to navigate around the sheet.

Create, change and Use Range Labels in the Label Inspector (see below for more 
information)

 * Use Range Labels in any 
  situation where you would  
  otherwise use cell-addresses. 
 * in the Report Designer
 * in Formulas
 * for Copying

Clear Special

Use Edit->Clear Special to clear various aspects of a cell or range of cells.

 Format clears all formatting options from the cell or cell range that you selected, 
returning it to Base Style 1.
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Data clears all data from the cell or cell range that you selected, leaving only the 
formatting options.

Numeric Input clears all cells containing numeric data in the selected cell range. 

* This is useful for worksheets that are used repeatedly, and must be cleared of all 
 prior numeric content before each use. Formatting options, formulas, and string  
 are not affected by this command.

String Input clears only cells containing string data in the selected cell range. 

* This is useful for reusing a worksheet that needs to have only its captions updated. 
 Formatting options, formulas, and number are not affected by this command.

Reset clears the values of cells containing formulas. This is useful when working with 
cells containing CURRENTVALUE and CURRENTNUMBER constants.

Navigating Cells

If you have set Protection ON the worksheet (with the Sheet Inspector) and designated 
certain cells as Unprotected (with the Cell Format Inspector) then you can use the Tab key 
to jump from one unprotected cell to the next.

Select the range through which you want to jump (this can be the entire worksheet if 
you like).

When you use the TAB key you will ‘jump’ to the next unprotected call in the range.

* If you don’t select a range then TAB will have it’s normal effect of moving one 
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12. Functions by Category

File Operations

NAMESHEET

Names the current worksheet.

NAMESHEET(name)

name the new name of the worksheet

This function changes the name of the current worksheet to name. The name name must 
be a string.

Returns: the name of the sheet if success, -1 if failure

namesheet(“MySheet”)

SAVE

Saves the current worksheet.

SAVE([name])

name the [optional] new name of the worksheet

This function saves the current worksheet. If name is specified, the worksheet’s name is 
changed before the save. The name name must be a string.
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Returns: the full pathname of the sheet if success, -1 if failure

save()
save(“NewName”)

SETSHEETPROTECTION

Turns sheet protection on or off.

SETSHEETPROTECTION(TRUE|FALSE)

Editing Operations

CLR or CLEAR

Clears the specified cell or range.

CLR(cell) or CLR(range)

cell any cell reference

range any worksheet range

This function clears all the information from the cell or range specified, including both 
data and formatting information.

Returns: cell or range

clear(a1)

clear(a1:b7)
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clear(myrange)

CLRDATA or CLEARDATA

Clears any data from the specified cell or range.

CLRDATA(cell) or CLRDATA(range)

cell any cell reference

range any worksheet range

This function clears the data (but not the formatting information) from cell or range.

Returns: cell or range

clrdata(a1)

clrdata(a1:b7)

clrdata(myrange)

CLRFMT, CLEARFMT or CLEARFORMAT

Clears any formatting information from the specified cell or range.

CLRFMT(cell) or CLRFMT(range)

cell any cell reference

range any worksheet range

This function clears formatting information (but not the data) from cell or range.
Returns: cell or range
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clrfmt(a1)

clrfmt(a1:b7)

clrfmt(myrange)

CLRNUM or CLEARNUM

Clears numerical data from the specified cell or range.

CLRNUM(cell) or CLRNUM(range)

cell any cell reference

range any worksheet range

This function clears the numerical input from cell or range, but not strings, formulas, or 
formatting information.

Returns: cell or range

clrnum(a1)

clrnum(a1:b7)

clrnum(myrange)

CLRSTR or CLEARSTR

Clears string data from the specified cell or range.

CLRSTR(cell) or CLRSTR(range)
cell any cell reference
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range any worksheet range

This function clears any string data from cell or range, but not numerical input, formulas, 
or formatting information. It returns cell or range.

Returns: cell or range

clrstr(a1)

clrstr(a1:b7)

clrstr(myrange)

COPY

Copies a cell or range from one location to another.

COPY(source,dest)

source any cell reference or worksheet range

dest any cell reference or worksheet range

The COPY function copies the information from source into dest. If a cell reference is 
given for dest, it will be used as the upper left hand corner of the destination range. Any 
information in the destination range will be overwritten.

Returns: dest

copy(a1:b7,d12)

copy(myrange,d12:e14)
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COPYFMT or COPYFORMAT

Copies formatting information of a cell or range from one location to another.

COPYFMT(source,dest)

source any cell reference or worksheet range

dest any cell reference or worksheet range

This function copies formatting information only (but not the values) from source into 
dest. If a cell reference is given for dest, it will be used as the upper left hand corner of the 
destination range. Any information in the destination range will be overwritten.

Returns: dest

copyfmt(a1:b7,d12)

copyfmt(myrange,d12:e14)

COPYVAL

Copies the values of a cell or range from one location to another.

COPYVAL(source,dest)

source any cell reference or worksheet range

dest any cell reference or worksheet range

This function copies the values only (but not the formatting) from source into dest. If 
a cell reference is given for dest, it will be used as the upper left hand corner of the 
destination range. Any information in the destination range will be overwritten.
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Returns: dest

copyval(a1:b7,d12)

copyval(myrange,d12:e14)

FORMTOVAL or FORMULASTOVAL

Converts formulas to their current values.

FORMTOVAL(cell) or FORMTOVAL(range)

cell any cell reference

range any worksheet range

This function converts any formulas in the cell or range to their current values. Any cell 
references within the formulas will be converted to the values of the cells referenced, and 
the values of the formulas will be calculated.

Returns: cell or range

formtoval(a1)

formtoval(a1:b7)

formtoval(myrange)

LOWER

Converts strings in a cell or range to lower case.

LOWER(cell) or LOWER(range)
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cell any cell reference

range any worksheet range

Converts the strings in the cell or range to lower case, regardless of their original case.

Returns: cell or range

lower(a1)

lower(a1:b7)

lower(myrange)

MOVE

Moves the information in a cell or range.

MOVE(source,dest)

source any cell reference or worksheet range

dest any cell reference or worksheet range

Moves the information from source into dest. If a cell reference is given for dest, it will 
be used as the upper left hand corner of the destination range. Any information in the 
destination range will be overwritten.

Returns: dest

move(a1:b7,d12)

move(myrange,d12:e14)
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NUMTOSTR

Converts numbers in the specified cell or range to strings.

NUMTOSTR(cell) or NUMTOSTR(range)

cell any cell reference

range any worksheet range

This function any converts numerical values in cell or range to strings. 

Returns: cell or range

lower(a1)

lower(a1:b7)

lower(myrange)

PROPER

Converts the strings in the specified cell or range to Proper Case.

PROPER(cell) or PROPER(range)

cell any cell reference

range any worksheet range

This function converts the strings in the cell or range to Proper Case, regardless of their 
original case. The first letter of each word is capitalized, and all remaining letters are 
converted to lower case.
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Returns: cell or range

proper(a1)

proper(a1:b7)

proper(myrange)

SELECT

Selects a cell or range in the worksheet.

SELECT(cell) or SELECT(range[, selectedcell])

cell any cell reference

range any worksheet range

selectedcell an [optional] cell reference within 

This function highlights cell or range. If selectedcell is specified and is within range, that 
cell is selected; otherwise, the upper left cell is selected.

Returns: cell or range

select(b17)

select(a10:g19,b13)

SELECTALL

Selects all cells in the sheet.

SELECTALL([selectedcell])
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selectedcell an [optional] cell reference

This function highlights the entire sheet. If selectedcell is specified, that cell is selected; 
otherwise, the upper left cell (A1) is selected.

Returns: the range reference of the selected area

selectall()

selectall(g29)

STRTONUM

Converts strings in the specified cell or range to numbers.

STRTONUM(cell) or STRTONUM(range)

cell any cell reference

range any worksheet range

This function converts any strings in cell or range to their numerical equivalent.

Returns: cell or range

strtonum(a1)

strtonum(a1:b7)

strtonum(myrange)

TRANSPOSE

Transposes the data from a range, switching rows and columns.



251           Release 3.0        Mesa User’s Guide

CHAPTER 12        Functions by Category

TRANSPOSE(source,dest)

source any cell reference or worksheet range

dest any cell reference or worksheet range

This function transposes the information from source into dest, such that rows and 
columns are transposed. If a cell reference is given for dest, it will be used as the upper 
left hand corner of the destination range. Any information in the destination range will 
be overwritten.

Returns: dest

transpose(a1:b7,d12)

transpose(myrange,d12:e14)

UPPER

Converts strings in the specified cell or range to UPPER CASE.

UPPER(cell) or UPPER(range)

cell any cell reference

range any worksheet range

This function converts any strings in the cell or range to UPPER CASE, regardless of 
their original case.

Returns: cell or range

upper(a1)
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upper(a1:b7)

upper(myrange)

Formatting Operations

BOLD

Toggles the data in the specified range between bold and regular weight.

BOLD(cell) or BOLD(range)

cell any cell reference

range any worksheet range

This function changes the format of the selected cells to bold if they are regular weight, 
and to regular weight if they are bold.

Returns: cell or range

CLRHBREAK or CLEARHBREAK

Clears horizontal page breaks from the specified cell or range.

CLRHBREAK(cell) or CLRHBREAK(range)

cell any cell reference

range any worksheet range

This function clears any horizontal page breaks within the cell or range, including breaks 
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following the last cell in the range, but not breaks preceding the first cell.

Returns: cell or range

clrhbreak(a1)

clrhbreak(a1:b7)

clrhbreak(myrange)

CLRVBREAK or CLEARVBREAK

Clears horizontal page breaks from the specified cell or range.

CLRVBREAK(cell) or CLRVBREAK(range)

cell any cell reference

range any worksheet range

This function clears any vertical page breaks within the cell or range, including breaks 
following the last cell in the range, but not breaks preceding the first cell.

Returns: cell or range

clrvbreak(a1)

clrvbreak(a1:b7)

clrvbreak(myrange)

DEFAULTS

Sets the formatting of the specified cell or range to its defaults.
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DEFAULTS(cell) or DEFAULTS(range)

cell any cell reference

range any worksheet range

Returns: cell or range

defaults(a1)

defaults(a1:b7)

defaults(myrange)

HBREAK

Sets a horizontal page break.

HBREAK(cell) or HBREAK(range)

cell any cell reference

range any worksheet range

Sets a horizontal page break immediately after cell or range. 

Returns: cell or range

hbreak(a1)

hbreak(a1:b7)

hbreak(myrange)
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HIDDENCOL

Tests for hidden columns.

HIDDENCOL(cell)

cell any cell reference

This functions tests if cell is in a hidden column.

Returns: 1 if cell is hidden, 0 if not

hiddencol(h19)

HIDDENROW

Tests for hidden rows.

HIDDENROW(cell)

cell any cell reference

This function tests if cell is in a hidden row.

Returns: 1 if cell is hidden, 0 if not

hiddenrow(h19)

HIDECOL

Hides the specified columns.

HIDECOL(cell) or HIDECOL(range)
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cell any cell reference

range any worksheet range

This function hides the columns that contain cell or range. Column A cannot be hidden.

Returns: cell or range

hidecol(b5)

hidecol(b5:c7)

hidecol(myrange)

HIDEROW

Hides the specified rows.

HIDEROW(cell) or HIDEROW(range)

cell any cell reference

range any worksheet range

This function hides the rows that contain cell or range. Row 1 cannot be hidden.

Returns: cell or range

hiderow(b5)

hiderow(b5:c7)

hiderow(myrange)
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ITALIC

Toggles the data in the specified range between italic and standard text.

cell any cell reference

range any worksheet range

This function changes the format of the cells specified by cell or range to italic if they are 
standard, and to standard if they are italic.

Returns: cell or range

italic(a1)

italic(a1:b7)

italic(myrange)

OUTLINE

Outlines the specified cells with the specified border.

OUTLINE(cell, border) or OUTLINE(range, border)

cell any cell reference

range any worksheet range

border the specified border type: 0, 1 or 2

This function outlines each of the specified cells with a border of type border. Possible 
borders are 0 (no border), 1 (single border) or 2 (double border).
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Returns: cell or range

outline(a1,1)

outline(a1:b7,0)

outline(myrange,2)

PLAIN

Changes the format of the specified cell or range to plain text.

PLAIN(cell) or PLAIN(range)

cell any cell reference

range any worksheet range

This function changes the text formatting of cell or range to plain (i.e. non-bold, non-
italic).

Returns: cell or range

plain(a1)

plain(a1:b7)

plain(myrange)

RESETROWSIZE

Resets the size of the specified rows.

RESETROWSIZE(cell) or RESETROWSIZE(range)
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cell any cell reference

range any worksheet range

This function sets the row(s) that contain cell or range to the default for the worksheet.

Returns: cell or range

resetrowsize(a1)

resetrowsize(a1:b7)

resetrowsize(myrange)

RESETCOLSIZE

Resets the size of the specified columns.

RESETCOLSIZE(cell) or RESETCOLSIZE(range)

cell any cell reference

range any worksheet range

This function sets the column(s) that contain cell or range to the default for the worksheet.

Returns: cell or range

resetcolsize(a1)

resetcolsize(a1:b7)

resetcolsize(myrange)
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SETALIGN

Sets the text alignment of the specified cell or range.

SETALIGN(cell, h-align[, v-align])

SETALIGN(range, h-align[, v-align])

cell any cell reference

range any worksheet range

h-align a horizontal alignment constant

v-align an [optional] vertical alignment constant

This function aligns the text in cell or range according to h-align and an optional v-align. 
For a list of alignment constants, see “Alignment Constants” .

Returns: cell or range

setalign(a1,LEFTALIGN)

setalign(a1:b7,RIGHTALIGN,TOPALIGN)

setalign(myrange,RIGHTALIGN,BOTTOMALIGN)

SETALTCOLOR

Sets the alternate text color of the specified cell or range.

SETALTCOLOR(cell, color[, pattern]), SETALTCOLOR(range, color[, pattern]), 
SETALTCOLOR(cell, r, g, b [, pattern]), or SETALTCOLOR(range, r, g, b[, pattern])
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cell any cell reference

range any worksheet range

color a color constant

r the amount of red

g the amount of green

b the amount of blue

pattern a pattern number

This function sets the alternate text color of cell or range to the specified color and 
optional pattern. The color can be specified by a color constant color or with red, green, 
and blue values (r, g, b) between 0 and 1. For a list of color constants, see “Color 
constants” . The pattern can be specified with a number between 0 and 87.

Returns: cell or range

setaltcolor(a1,BLACKCOLOR)

setaltcolor(a1:b7,0,0.5,0.5)

setaltcolor(myrange,MAGENTACOLOR,53)

SETALTPATTERN

Sets the alternate text pattern of the specified cell or range.

SETALTPATTERN(cell, pattern) or SETALTPATTERN(range, pattern)

cell any cell reference
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range any worksheet range

pattern a pattern number

This function sets the alternate text pattern of cell or range to pattern, using the current 
alternate color. The pattern can be specified with a number between 0 and 87.

Returns: cell or range

setaltpattern(a1,23)

setaltpattern(a1:b7,17)

setaltpattern(myrange,59)

SETBKGCOLOR

Sets the background color of the specified cell or range.

SETBKGCOLOR(cell, color [, pattern]), SETBKGCOLOR(range, color[, pattern]), 
SETBKGCOLOR(cell, r, g, b [, pattern]), or SETBKGCOLOR(range, r, g, b [, pattern])

cell any cell reference

range any worksheet range

color a color constant

r the amount of red

g the amount of green

b the amount of blue
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pattern a pattern number

This function sets the background color of cell or range to the specified color and optional 
pattern. The color can be specified by a color constant color or with red, green, and blue 
values (r, g, b) between 0 and 1. For a list of color constants, see “Color constants”. The 
pattern can be specified with a number between 0 and 87.

Returns: cell or range

setbkgcolor(a1,BLACKCOLOR)

setbkgcolor(a1:b7,0,0.5,0.5)

setbkgcolor(myrange,MAGENTACOLOR,53)

SETBKGPATTERN

Sets the background pattern of the specified cell or range.

SETBKGPATTERN(cell, pattern) or SETBKGPATTERN(range, pattern)

cell any cell reference

range any worksheet range

pattern a pattern number

This function sets the background pattern of cell or range to pattern, using the current 
background color. The pattern can be specified with a number between 0 and 87.

Returns: cell or range

setbkgpattern(a1,23)
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setbkgpattern(a1:b7,17)

setbkgpattern(myrange,59)

SETBORDER

Sets the border for a specified cell or range.

SETBORDER(range, borders, bool)

range any worksheet range

borders a border constant

bool whether the border should be visible

This function places a border in range around the sides of the cells specified by borders, 
which can be one of: LEFTBORDER, RIGHTBORDER, TOPBORDER, BOTTOM-
BORDER. These constants can be OR’d together. The bool argument should be TRUE or 
FALSE, depending on whether the border should be visible.

Returns: range

setborder(a1,TOPBORDER,TRUE)

setborder(a1:b7,LEFTBORDER | RIGHTBORDER,TRUE)

setborder(myrange,TOPBORDER | BOTTOMBORDER,FALSE)

SETBORDERCOLOR

Sets the border color for a specified cell or range.

SETBORDERCOLOR(cell, color [, pattern]), SETBORDERCOLOR(range, color[, pat-
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tern]), SETBORDERCOLOR(cell, r, g, b [, pattern]), or SETBORDERCOLOR(range, r, 
g, b [, pattern])

cell any cell reference

range any worksheet range

color a color constant

r the amount of red

g the amount of green

b the amount of blue

pattern a pattern number

This function sets the border color of cell or range to the specified color and optional 
pattern. The color can be specified by a color constant color or with red, green, and blue 
values (r, g, b) between 0 and 1. For a list of color constants, see “Color constants”. The 
pattern can be specified with a number between 0 and 87.

Returns: cell or range

setbordercolor(a1,BLACKCOLOR)

setbordercolor(a1:b7,0,0.5,0.5)

setbordercolor(myrange,MAGENTACOLOR,53)

SETBORDERPATTERN

Sets the border pattern for the specified cell or range.
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SETBORDERPATTERN(cell, pattern) or SETBORDERPATTERN(range, pattern)

cell any cell reference

range any worksheet range

pattern a pattern number

This function sets the border pattern of cell or range to pattern, using the current border 
color. The pattern can be specified with a number between 0 and 87.

Returns: cell or range

setborderpattern(a1,23)

setborderpattern(a1:b7,17)

setborderpattern(myrange,59)

SETBORDERTYPE

Sets the border type for a specified cell or range.

SETBORDERTYPE(cell, border) or SETBORDERTYPE(range, border)

cell any cell reference

range any worksheet range

border a border type: 0, 1, or 2

This function changes the border for cell or range to border type border. Possible borders 
are 0 (no border), 1 (single border) or 2 (double border). This does not place a border 
around the cell.
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Returns: cell or range

setbordertype(a1,1)

setbordertype(a1:b7,0)

setbordertype(myrange,2)

SETCOLOR

Sets the text color for a specified cell or range.

SETCOLOR(cell, color [, pattern]), 

SETCOLOR(range, color[, pattern]),

SETCOLOR(cell, r, g, b [, pattern]), or 

SETCOLOR(cell, r, g, b [, pattern])

cell any cell reference

range any worksheet range

color a color constant

r the amount of red

g the amount of green

b the amount of blue

pattern a pattern number
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This function sets the text color of cell or range to the specified color and optional pattern. 
The color can be specified by a color constant color or with red, green, and blue values (r, 
g, b) between 0 and 1. For a list of color constants, see “Color constants”. The pattern can 
be specified with a number between 0 and 87.

Returns: cell or range

setcolor(a1,BLACKCOLOR)

setcolor(a1:b7,0,0.5,0.5)

setcolor(myrange,MAGENTACOLOR,53)

SETCOLSIZE

Sets the size of the specified columns.

SETCOLSIZE(cell, num) or SETCOLSIZE(range, num)

cell any cell reference

range any worksheet range

num the size of the column(s) in points

This function sets the column(s) that contain cell or range to a size of num points.

Returns: cell or range

setcolsize(a1,72)

setcolsize(a1:b7,100)

setcolsize(myrange,53)
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SETFMT or SETDISPLAYFMT

Sets the display format of the specified cell or range.

SETFMT(cell, format[, precision]) or 

SETFMT(range, format[, precision])

cell any cell reference

range any worksheet range

format the size of the column(s) in points

precision the [optional] number of decimal places.

This function sets the display format of cell or range to the format specified by format 
and, optionally, to precision decimal places. For a list of formatting constants, see 
“Formatting Constants” . 

Returns: cell or range

setfmt(a1:b10,CURRENCYFMT,2)

SETFONT

Sets the font of the specified cell or range.

SETFONT(cell, fontname, size) or 

SETFONT(range, fontname, size)

cell any cell reference



Mesa User’s Guide         Release 3.0         270

CHAPTER 12        Functions by Category

range any worksheet range

fontname the name of a font

size the point size

This function changes the font in cell or range to the font fontname and point size size. 

Returns: cell or range, or -1 on error

setfont(a1:b7,”ZapfChancery-MediumItalic”,12)

SETPATTERN

Sets the text pattern for the specified cell or range.

SETPATTERN(cell, pattern) or 

SETPATTERN(range, pattern)

cell any cell reference

range any worksheet range

pattern a pattern number

This function sets the text pattern of cell or range to pattern, using the current text color. 
The pattern can be specified with a number between 0 and 87.

Returns: cell or range

setpattern(a1,23)

setpattern(a1:b7,17)
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setpattern(myrange,59)

SETPRECISION

Sets the precision of the specified cell or range.

SETPRECISION(cell, precision) or

SETPRECISION(range, precision)

cell any cell reference

range any worksheet range

precision the number of decimal places.

Sets the number of decimal places for cell or range to precision.

Returns: cell or range

setprecision(a1,2)

setprecision(a1:b7,3)

setprecision(myrange,0)

SETROWSIZE

Sets the size of the specified rows.

SETROWSIZE(cell, num) or SETROWSIZE(range, num)

cell any cell reference



Mesa User’s Guide         Release 3.0         272

CHAPTER 12        Functions by Category

range any worksheet range

num the size of the row(s) in points

This function sets the row(s) that contain cell or range to a size of num points.

Returns: cell or range

setrowsize(a1,72)

setrowsize(a1:b7,100)

setrowsize(myrange,53)

SETTEMPLATE

Sets the style template of the specified cell or range.

SETTEMPLATE(cell, template) or 

SETTEMPLATE(range, template)

cell any cell reference

range any worksheet range

template a style template number

Sets the style template for cell or range to template. template can be an integer between 
1 and 8, inclusive. For more information about style templates, see “Style Template 
sub-menu” .

Returns: cell or range
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setrowsize(a1,1)

setrowsize(a1:b7,6)

setrowsize(myrange,3)

SETVERTALIGN

Sets the vertical text alignment of the specified cell or range.

SETVERTALIGN(cell, alignment) or SETVERTALIGN(range, alignment)

cell any cell reference

range any worksheet range

alignment a vertical alignment constant

This function vertically aligns the text in cell or range according to alignment. For a list of 
alignment constants, see “Alignment Constants”.

Returns: cell or range

setalign(a1,TOPALIGN)

setalign(a1:b7,TOPALIGN)

setalign(myrange,BOTTOMALIGN)

SMARTCOLSIZE

Smartsizes the columns of the specified cell or range.

SMARTCOLSIZE(cell) or SMARTCOLSIZE(range)
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cell any cell reference

range any worksheet range

This function sets the column(s) that contain cell or range to the best column size for 
the data they contain.

Returns: cell or range

smartcolsize(a1)

smartcolsize(a1:b7)

smartcolsize(myrange)

SMARTROWSIZE

Smartsizes the rows of the specified cell or range.

SMARTROWSIZE(cell) or SMARTROWSIZE(range)

cell any cell reference
range any worksheet range

This function sets the row(s) that contain cell or range to the best row size for the data 
they contain.

Returns: cell or range

smartrowsize(a1)

smartrowsize(a1:b7)

smartrowsize(myrange)
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UNHIDECOL

Unhides the specified columns.

UNHIDECOL(cell) or UNHIDECOL(range)

cell any cell reference

range any worksheet range

This function unhides any hidden columns in cell or range.

Returns: cell or range

unhidecol(a1)

unhidecol(a1:b7)

unhidecol(myrange)

UNHIDEROW

Unhides the specified rows.

UNHIDEROW(cell) or UNHIDEROW(range)

This function unhides any hidden rows in cell or range.

Returns: cell or range

unhiderow(a1)

unhiderow(a1:b7)
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unhiderow(myrange)

VBREAK

Sets a vertical page break.

VBREAK(cell) or VBREAK(range)

cell any cell reference

range any worksheet range

Sets a vertical page break immediately after cell or range. 

Returns: cell or range

vbreak(a1)

vbreak(a1:b7)

vbreak(myrange)

Graphics Operations

ABOVESHADING

Places a graphic above the shading on the sheet.

ABOVESHADING(name)

name the name of a graphic
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This function places the graphic named by name above the shading but below the text on 
the sheet. name must be a string.

Returns: name, or -1 if name isn’t found

aboveshading(“Graph 1”)

c1 := “MyGraphic”

aboveshading(c1)

ABOVESHEET

Places a graphic about the sheet.

ABOVESHEET(name)

name the name of a graphic

This function places the graphic named by name above the sheet. Name must be a string.

Returns: name, or -1 if name isn’t found

abovesheet(“Graph 1”)

c1 := “MyGraphic”

abovesheet(c1)

BRINGTOFRONT

Brings a graphic to the front of its sheet layer.

BRINGTOFRONT(name)
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name the name of a graphic

This function brings the graphic named by name to the front of other graphics in the same 
layer on the sheet. Name must be a string.

Returns: name, or -1 if name isn’t found

bringtofront(“Graph 1”)

c1 := “MyGraphic”

bringtofront(c1)

CLEARGRAPH

Clears a graph.

CLEARGRAPH(name)

name the name of a graph

This function clears the graph named by name from the sheet. Name must be a string.

Returns: name, or -1 if name isn’t found

cleargraph(“Graph 1”)

c1 := “MyGraphic”

cleargraph(c1)

GRAPH

Creates a graph.
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GRAPH(range, type[, name])

range any worksheet range

type a graph type constant

name the [optional] graph name

This function graphs range in a graph of type type. For a list of graph type constants, see 
“Graph Constants”. Optionally, the graph can be given a name of name. Name must be a 
string. If a name is not chosen, the name assigned is “Graph n”, where n starts at 1 and is 
incremented with each successive graph.

Returns: name, or -1 if there’s an error

graph(a1:c10,BARGRAPH)

graph(d10:f17,COLUMNGRAPH,”MyGraph”)

SENDTOBACK

Sends a graphic to the back of its sheet layer.

SENDTOBACK(name)

name the name of a graphic

This function sends the graphic named by name to the back of other graphics in the same 
layer on the sheet. Name must be a string.

Returns: name, or -1 if name isn’t found

sendtoback(“Graph 1”)
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c1 := “MyGraphic”

sendtoback(c1)

SETGRAPHELEMENTCOLOR

Sets the color of an element (row, column, line, etc) in a graph. 

SETGRAPHELEMENTCOLOR(graph,element,color)

graph the name of the graph. 

element the element to be affected (starting at 0).

color a color constant.

SETGRAPHITEMCOLOR

Sets the color of a graphic item.

SETGRAPHITEMCOLOR(graph,item,color)

graph the name of the graph. 

item the item to be affected (see below).

color a color constant.

Item:

bkgColorGraphItem - the background color of the graph

borderColorGraphItem - the border color of the graph
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legendColorGraphItem - the color of the legend

threeDColorGraphItem - the color of the 3D background

baseColorGraphItem - the color of the text and the axises

SETGRAPHITEMVALUE

Sets the numeric value of an item in a graph.

SETGRAPHITEMVALUE(graph,item,value)

graph the name of the graph. 

item the item to be affected (see below).

value the new value of the item.

Item:

hasClearBkgGraphItem - 1 if the graph has a clear background, 0 if it is colored

borderWidthGraphItem - width of the border around the graph. 0 if no border

hasClearLegendGraphItem - 1 if the legend is clear. 0 if colored

hasClear3DGraphItem - 1 if the 3D backgeound is clear. 0 if colored.

labelPositionGraphItem - the position of the Y labels. 0 if centered. 1 if grouped.

topRowLabelsGraphItem - 1 if the top row has labels. 0 if the top row has graphed data.

leftColumnLabelsGraphItem - 1 if the left column has labels. 0 if it has graphed data.
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displayFormatGraphItem - the display format of the labels on the graph axis.

precisionGraphItem - sets the precision of the graph labels

xTitleIsCellRefGraphItem - 1 if the X Title is a cell reference, 0 if it is text

yTitleIsCellRefGraphItem - 1 if the Y Title is a cell reference, 0 if it is text

firstTitleIsCellRefGraphItem - 1 if the first Title is a cell reference, 0 if it is text

secondTitleIsCellRefGraphItem - 1 if the second Title is a cell reference, 0 if it is text

orientationGraphItem - 0 Horizantal data orientation. 1 Vertical data orientation

yMajTickGraphItem

yMajTickSizeGraphItem

xMajTickGraphItem

xMajTickSizeGraphItem

yMinTickGraphItem

yMinTickSizeGraphItem

xMinTickGraphItem

xMinTickSizeGraphItem

autoScaleGraphItem

logScaleGraphItem
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xMajHairGraphItem

xMinHairGraphItem

yMajHairGraphItem

yMinHairGraphItem

hasXBorderGraphItem

hasYBorderGraphItem

barColumnSizeGraphItem

hasBarColumnLineGraphItem

barColumnLineWidthGraphItem

scatterGraphTypeGraphItem

singleXRangeGraphItem

candleStickGraphItem

wireFrameGraphItem

legendLocationGraphItem

xyDisplayFormatGraphItem

xyPrecisionGraphItem

xLabelRotGraphItem
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yLabelRotGraphItem

xMaxGraphItem

xMinGraphItem

yMaxGraphItem

yMinGraphItem

xRotGraphItem

yRotGraphItem

strikeThroughGraphTickMark

innerGraphTickMark

outerGraphTickMark

scatterGraphPointsOnly

scatterGraphPointsAndLine

scatterGraphLineOnly

noMesaLegend

leftMesaLegend

rightMesaLegend

topMesaLegend
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bottomMesaLegend

SETGRAPHITEMSTRING

Sets the string value of an item in a graph.

SETGRAPHITEMSTRING(graph,item,string) 

graph the name of the graph. 

item the item to be affected (see below).

string the new value of the item.

Item:

xTitleGraphItem - the X Title

yTitleGraphItem - the Y Title

firstTitleGraphItem - the First Title

secondTitleGraphItem - the Second Title

topTitleGraphItem - the top title

sideTitleGraphItem - the side title

SETGRAPHITEMRANGE

Sets an item in a graph to refer to a range.

SETGRAPHITEMRANGE(graph,item, range) 
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graph the name of the graph. 

item the item to be affected (see below).

Item:

xLabelGraphItem - the X Label range (accessed only if Top Row has Labels is not 
checked)

yLabelGraphItem - the Y Label range (accessed only if Left Column has Labels is not 
checked)

baseRangeGraphItem - The base range of the graph information.

baseRangeGraphItem1 - An additional range of graph information.

baseRangeGraphItem2 - An additional range of graph information.

baseRangeGraphItem3 - An additional range of graph information.

baseRangeGraphItem4 - An additional range of graph information.

baseRangeGraphItem5 - An additional range of graph information.

baseRangeGraphItem6 - An additional range of graph information.

SETGRAPHSIZE

Changes the size of the specified graph.

SETGRAPHSIZE(name, width, height)

name the name of a graphic
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width the width of the graph in points

height the height of the graph in points

This function sets the width and height of the graph name, in points.

Returns: name, or -1 if name isn’t found

setgraphsize(“Graph 1”,520,350)

SETGRAPHTYPE

Sets graph to type.

GETGRAPHITEMRANGE(graph,item) 

graph the name of the graph. 

type a graph type constant (see GRAPH()).

SETGRAPHXY

Sets the X and Y coordinates of a graph.

SETGRAPHXY(name, x, y)

name the name of a graphic

x the width of the graph in points

y the height of the graph in points

This function sets the X and Y coordinates, in points, of the graph name to x and y, 
respectively. The X coordinate is measured from the left of the worksheet, and the Y 
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coordinate is measured from the top of the worksheet. The name name must be a string.

Returns: name, or -1 if name isn’t found

setgraphxy(“Graph 1”,100,200)

UNDERALL

Places a graphic under everything on a sheet.

UNDERALL(name)

name the name of a graphic

This function places the graphic named by name under everything in the sheet, including 
text and shading. name must be a string.

Returns: name, or -1 if name isn’t found

underall(“Graph 1”)

c1 := “MyGraphic”

underall(c1)

 

Other Operations

ADDIN

Calls an EventAddIn with optional data.
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ADDIN(name[, data...])

name the name of an EventAddIn

data the [optional] data to be passed to the AddIn

This function calls the EventAddIn name, optionally passing it the specified data. The 
name name must be expressed as a string.

Returns: the return value from the AddIn

addin(“MyAddIn”)

ALERT

Opens an alert panel.

ALERT(title, message[, button1[, button2[, button3]]])

title the title of the alert panel

message the message of the alert panel

button n the titles of the buttons

This function opens an alert panel with the title, message, and button s specified. The 
title, message, and button n names must be strings. If no buttons are specified, one button 
will appear, labeled OK.

Returns: the number of the button pressed, with the first button numbered 0

alert(“Warning”,”The number entered exceeds the maximum.”, “Redo”,”Accept”)
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DISPLAY

Re-displays the worksheet.

DISPLAY()

This function redisplays the worksheet. By default, the sheet is only re-displayed at the 
end of a script. This is useful for re-displaying the worksheet during the execution of 
a long script.

Returns: 0

display()

FREEZE

Freezes the value of a cell reference.

FREEZE(value)

value any cell reference

This function returns the current value of cell. This is useful for assignment of the value 
in a cell to a local variable.

Returns: the current value of value

b1 := freeze(a1)

?x := freeze(g7)

INVERT

Inverts a matrix.
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INVERT(range, dest)

range any worksheet range representing a matrix

dest the destination of the inverted matrix

This function inverts the matrix in range and places the inverse in dest. Both ranges must 
be square and of the same size.

Returns: 0 if successful and -1 if unsuccessful

invert(a1:c3,d1:f3)

invert(mymatrix,g7:j10)

LET

Assigns a value to a variable.

LET(variable, value)

variable a variable name

value a number, string, label, or cell reference

This function sets a variable to a value. The variable must be expressed as a string. 
Variables can also be assigned with the := operator.

Returns: value

LET(“?x”,10). 

% is the same as
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?x := 10

MENU

Displays a menu of choices.

MENU(range[, MENUBYROW|MENUBYCOL])

This function gives the user a menu of choices. 

If MENUBYCOL is used (this is default), for each column in range, the first row is the 
short name, the second row is the long description, and the third row is the string to return 
(this can be used for a subsequent “Goto...” or “gosub”). 

If MENUBYROW is used, the orientation of the table is horizontal rather than vertical.

Returns: the return string, or -1 if the Cancel button is clicked

?foo := menu(a1:c3,MENUBYROW)

MULTIPLY

Multiplies two matrices.

MULTIPLY(Xrange, YRange, dest)

XRange a worksheet range representing a matrix

YRange a worksheet range representing a matrix

dest the destination range

This function multiplies the two matrices specified by XRange and YRange and places 
the result in dest.
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Returns: 0 if successful and -1 if unsuccessful

multiply(A1:C3,E1:F3,H1:I3)

PRINT

Prints a report or a part of the worksheet.

PRINT([range]) or PRINT([report])

This function prints the range or the report specified. Report names must be expressed as 
strings. If nothing is specified, PRINT() will print all the information on the sheet.

Returns: 1 if success, -1 if failure

print()

print(“MyReport”)

print(a1:g27)

PROMPT

Prompts the user for input.

PROMPT(text)

text the user prompt string

This function prompts the user for input with the string text. The message text must be 
expressed as a string.

Returns: the user’s input, as a string
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a1 := prompt(“Type in any word.”)

a2 := value(prompt(“Type in any number”))

RECALC

Recalculates the worksheet.

RECALC(), RECALC(cell) or RECALC(range)

This function recalculates the range or, if no range is specified, the whole worksheet.

Returns: cell or range

recalc()

recalc(b7:z99)

REGRESSION

Performs a linear regression on the specified ranges.

REGRESSION(Xrange, YRange, dest)

XRange a worksheet range representing a matrix

YRange a worksheet range representing a matrix

dest the destination range

Performs linear regression on the input ranges specified by XRange and YRange and 
places the result in the range dest.

Returns: 0 if successful and -1 if unsuccessful
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regression(A1:C3,D1:D3,F1:F3)

REPORT

Prints a specified report.

REPORT(name)

name the name of a report

This function prints the pre-defined report name. name must be expressed as a string. The 
report must first be defined in the Report Layout Inspector. For more information about 
reports, see “Report Layout Inspector” .

Returns: 0

report(“myreport”)

report(c18)

SCENARIO

Runs a scenario.

SCENARIO(name)

name the scenario name

This function runs the predefined scenario name. Name must be expressed as a string. 
The scenario must first be defined in the Scenario Inspector. For more information about 
scenarios, see “Scenario Inspector” .

Returns: 0
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scenario(“myscenario”)

scenaro(c9)

SETADDRESS

Sets the cell address for the macro execution.

SETADDRESS(cell)

This function sets the address of the cell that the macro is executing in. This is useful for 
the SAME() command. The default is A1.

setaddress(g17)

SETINPUT

Sets the input of a specified cell.

SETINPUT(cell, string)

cell any cell reference

string a string

This function sets the input of the cell cell to string. The string will be interpreted by 
the cell as if typed by the user.

the evaluated string

setinput(c1,”=a1+b1”)

SETLABEL
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Assigns a label name to a range of cells.

SETLABEL(label, range)

label any string

range any worksheet range

This function assigns range to the name label. label must be expressed as a string.

Returns: 0

setlabel(“myrange”,a1:g13)

SETPROTECTION

Sets the protection for a given range.

SETPROTECTION(range,TRUE|FALSE)

SOLVE

Finds an input value such that a specified formula will give a desired result.

SOLVE(var, comp, value[, prec])

var any cell reference

comp any cell reference containing a formula

value the desired result

prec the [optional] digits of precision
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This function tries to find the correct value of the cell var such that the formula in comp 
yields value (a number). It places the result in var. Optionally, the number of digits of 
precision can be specified with prec. The default is 6.

Returns: 0 if successful, -1 if not

solve(A1,B1,2.5)

solve(A1,B1,2.5,8)

SORT

Sorts a range.

SORT(range, titles, SORTBYROW | SORTBYCOL, key1, sorttype[, key2, sorttype[, 
key3, sorttype]])

range any worksheet range

titles a boolean stating if the range has titles

key n the offset of the column to sort by

sorttype a sort-type constant (see below)

This functions sorts the given range. If titles is true, the top row of the range is ignored. To 
sort by rows, use the SORTBYROW constant; to sort by columns, use the SORTBYCOL 
constant. The key is the number of rows or columns that the key row or column is offset 
from the top or left side of the range. Use ASCENDINGSORT or DESCENDINGSORT 
to specify the order of the sort. key2 and key3 are optional.

Returns: 0

sort(a1:b10,false,SORTBYROW,0,ASCENDINGSORT)
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SYSTEM

Sends a string to the shell.

SYSTEM(string)

string any string that can be interpreted by the shell

This function sends the string string to the shell for execution.

Returns: the return value of the shell command

a1 := system(“whoami”)

Constants

Color Constants

Constant Red Green Blue

BLACKCOLOR 0 0 0

BLUECOLOR 0 0 1

CYANCOLOR 01 1

DKGRAYCOLOR 0.3330.333 0.333

GREENCOLOR 0 1 0

LTGRAYCOLOR 0.6660.666 0.666
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MAGENTACOLOR 1 0 1

WHITECOLOR 11 1

YELLOWCOLOR 1 1 0

REDCOLOR 10 0
  

Alignment Constants

Constant Effect

RIGHTALIGN Aligns text to right side of cell

LEFTALIGN Aligns text to left side of cell

CENTERALIGN Centers text in cell

SMARTALIGN Aligns strings left, numbers and dates right

FILLALIGN Makes copies of cell contents to fill the cell

TOPALIGN Aligns text to top of cell

BOTTOMALIGN Aligns text to bottom of cell

WRAPALIGN Wraps text to fit inside width of cell

Formatting Constants

Constant Effect

GENERALFMT Displays numbers as typed
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FIXEDFMT Displays numbers in fixed decimal format with the default number of 
decimal places

SCIENTIFICFMT Displays numbers in scientific notation

CURRENCYFMT Displays numbers in the default currency format

COMMAFMT Displays numbers using commas to separate groups of three digits

CHARTFMT Displays numbers as a series of plus signs of length equal to the number

PERCENTFMT Displays numbers in percentage format with the default number of 
decimal places

TEXTFMT Displays formulas directly, not as values

HIDDENFMT Hides numbers

DMYFMT Treats number as a serial number of a date and displays the date in day-month-
year format

DMFMT Displays the date in day-month format

MYFMT Displays the date in month-year format

HMSFMT Number must be fractional; treats number as a time and displays it in twelve-
hour hours:minutes-second format

HMFMT Displays the time in twelve-hour hours:minutes format

DATE1FMT Displays date in month/day/year format

DATE2FMT Displays date in month/day format
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TIME1FMT Displays time in 24-hour hour:minutes:seconds format

TIME2FMT Displays time in 24-hour hour:minutes format

Graph Type Constants

Constant Meaning

BARGRAPH Bar chart

STACKEDBARGRAPH Stacked bar chart

COLGRAPH Column chart

STACKEDCOLGRAPH Stacked column chart

SCATTERGRAPH Scatter chart

XYGRAPH X-Y chart

AREAGRAPH Area chart

PIEGRAPH Pie chart

HILOGRAPH High/Low chart

HILOCLOSEGRAPH Hi/Low/Close chart

BAR3DGRAPH 3D bar chart

RIBBONGRAPH Ribbon chart

PYRAMIDGRAPH Pyramid chart
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SURFACEGRAPH Surface chart

Error Constants

Constant Meaning

ERR General error

ERRORCONST General error

NA Special NA error

NACONST Special NA error
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13. Changing the Defaults

Preferences

The Preferences options allow you to customize Mesa behavior.

Use Info->Preferences to bring up the Preferences panel. Select the Area you want to 
change. 

You can change the overall behavior. of: 

  Workbooks 

 
* Sheet dimensions 
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* Currency symbol and position 
* Measurement units 

 
  Key functions 

* Behavior. of Return 
* Behavior. of Enter 
* Behavior. of Escape 

  File and Copying preferences 
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14. Importing and Exporting Files 

Excel and 1-2-3 Import/Export

Mesa currently allows import from 1-2-3 files and from Excel files.

It’s easy to open an Excel file. Just use the Workbook->Open menu command, and the 
browser will show you .xls and .xlw files (as well as .mesa files). 

Mesa and Excel are not 100% compatible. Most Excel files will open in Mesa satisfacto-
rily, in terms of bringing in all text, data, formulas, range labels and formatting. 

Charts, macros, text boxes etc are not imported in this version of Mesa. In some cases 
Excel has features which Mesa doesn’t yet have (for example pivot tables, ODBC 
database access, and some advanced functions (eg @RANK) and these can’t be imported 
either. In future releases we intend to enhance the Excel compatibility. 

Delimited Text les

Use the Workbook-> Import/Export Delimited Text options to allow ASCII text delim-
ited in many different ways to be brought into the Mesa sheet.



Mesa User’s Guide         Release 3.0         308

CHAPTER 14        Importing and Exporting les



Mesa User’s Guide         Release 3.0              309   

15. Shortcuts

The Toolbar

Setting up the Toolbar Adding an icon Use drag to drag an icon off a menu. Drag 
it to the position on the toolbar you want, release the Command key, and then release 
the mouse button. 

Deleting a icon Drag it outside the Toolbar onto the workspace and let go with the 
mouse.  

Moving an icon Drag it to the new location. Note that you can’t drag icons between 
Tabs. 

Adding a Tab Click on a Tab name twice (so that the tab area turns dark gray), and press 
Return. A new tab with a name like ‘New2’ will be created. Renaming a Tab Double-click 
on the Tab Name, and type in the name you want Deleting a Tab  click on a Tab name 
twice (so that the tab area turns dark gray), and press Backspace. The Tab and all the icons 
it contains will be removed from your toolbar.  

Tools On The Workbook

Just as you can drag an item onto the Toolbar, you can place an item onto the worksheet. 
This is useful if you have a command or a script that you use at a certain place in the 
worksheet. For example, if you have a script that validates data in a data entry in a certain 
range on the worksheet, you can place an MScript button near that range so that you can 
run the script by clicking on the button.
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To place a command or a script on the worksheet, drag the item and drop it onto the 
worksheet just like you would drop the item onto the Toolbar Now the tool works just like 
it does on the menu or in the Toolbar

Click on the New button that you placed on the Toolbar. Mesa will create a new, blank 
worksheet. Select the File menu. drag the Save item and drop it on the worksheet. Click 
on the button and Mesa will prompt you for the file name to use to save this worksheet. 
Enter MySheet and press enter. Mesa will save the worksheet in your home directory 
with the name MySheet.Mesa.

To remove a tool from the worksheet, Control-Drag a blank tool and drop it onto the 
tool on the worksheet. 

To move a tool on the worksheet, drag the tool to a new location.

Drag-and-Drop ranges

Mesa allows you to perform many tasks by direct manipulation: grabbing the thing that 
you want to change and changing it. Drag & Drop ranges are an example of this. You can 
copy of move a range of cells by dragging them to a new location.

The range A1 through A12 should still be selected from the previous SmartFill operation. 
Let’s move this range to B2 through B13. To do this, move the mouse cursor above cell 
A1; press and hold the Control key; press and hold the mouse button. Mesa will display a 
shadow of the range. Move the mouse and watch as the shadow range follows the mouse 
movements. Move the mouse above cell B2; release the mouse button and then release the 
Control key. Mesa will move the range from A1 through A12 to B2 through B13.

If you want to abort the Drag & Drop operation, release the Control key and Mesa will 
stop the operation.

You can copy a range to another location by Alt-Dragging it rather than Control-Dragging 
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it. Mesa will make a second copy of the range in the new location.

Select with Goto...

Use Range->Goto... to jump directly to any part of the worksheet or to a chart.

You can enter:
a cell reference (e.g. J56)
a Range Label (e.g. SalesTotal)
a Chart name (eg FinalFigures)

Formula Inheritance

Mesa has a unique and useful feature called Formula Inheritance. Formula Inheritance 
applies object oriented concepts to spreadsheets by allowing a set of cells to inherit their 
formula from a master cell and automatically change the way they calculate when that 
master cell changes its formula.

Select cells C2 through H13 by clicking in cell C2 and dragging to cell H13 and releasing 
the mouse button. The range C2 through H13 should be selected and the current cell 
should be cell C2. Type =INT(RAND * 100) and press Shift-enter. This will SmartFill the 
range with this formula that generates a random number between 0 and 99.

When a range is SmartFilled with a formula, Mesa sets the other cells in the range to 
inherit their formula for the formula in the base cell which is cell C2 in this case.

Select cell C2 and change the formula to =B2 & “ Hello” and press enter. Note that all the 
cells in the range changed the way that they calculated. Change cell C2 to =INT(RAND * 
1000). All the cells in the range C2 through H13 should be displaying a random number 
between 0 and 999.
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You have just performed a SmartFill operation with formulas and taken advantage 
of Mesa’s formula inheritance feature. Formula inheritance makes it easier to build 
spreadsheets because you only need to change a single formula and the other cells that 
inherit their formula from the base formula will automatically change the way that they 
calculate. Formula Inheritance also makes spreadsheet maintenance easier because you do 
not have to remember all the places that the formula was copied to.
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16. Technical Support 

Commercial versions of Mesa include free unlimited technical support. P&L System’s 
technical support lines are open from 9:15 am to 5:30 PM Greenwich Mean Time, 
Monday through Friday, except holidays. 

The technical support phone number is +44-1494-432422. Please have your license 
number handy when calling for technical support. 

You can also request technical support via e-mail. The e-mail address for technical 

support is mesa@plsys.com.
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17. Tutorial 

Starting up the Tutorial

Introduction

Work through the steps in this tutorial to get a feel for the way Mesa works.

Example - We have the following scenario: 

The Head Office of a multinational corporation needs a spreadsheet for their Worldwide 
Sales of Widgets and Gadgets. They might want to use a separate worksheet to hold the 
sales figures for each country they deal with, and have a ‘front’ worksheet to total up all 
the figures. Our desired result will be the spreadsheet below.

          Example Worldwide Sales of Widgets and Gadgets 
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In this tutorial we will go through all the steps needed to create the above spreadsheet. To 
start the tutorial click on one of the links below.

Create new Workbook

The first step is to create a new Workbook. A Workbook consisting of one or several 
worksheets is the place you work on in Mesa. A Worksheet is a collection of cells 
organized in rows and columns. Each cell can be individually addressed with its row and 
column address. Rows are numbered 1,2,3 and so on and columns are labeled A,B,C and 
so on. When you first create a Workbook, it will have 20 columns and 20 rows. It will 
automatically expand as you need more space. You can also make a Workbook larger or 
smaller by changing the sheet size in the Sheet Inspector.

To create a new Workbook, select the Workbook->New or key in Apple +  command. To 
do this, move the mouse cursor above the Workbook selection on the main menu. Click 
and release the mouse button. The Workbook sub-menu will appear. Move the mouse 
cursor above the New selection, click and release the mouse button. Mesa will create a 
new, blank Workbook.

Many Mesa commands have Apple-Key equivalents. These commands can be issued by 
clicking on the desired menu item or by pressing the Apple key along with another key 
on the keyboard. Apple-Key equivalents are useful shortcuts once you become familiar 
with an application. The Apple-Key equivalent will be listed after each command so that 
they will become familiar.

Once you have created a new, blank Workbook, you can save it on your computer’s 
disk. Saving a Workbook transfers the information contained in the Workbook from the 
computer’s internal memory to a hard disk or file server. Once the information is on 
permanent storage, it will remain until it is changed or erased.

It is a good idea to save your work from time to time in case there is an unexpected 
problem with your computer. If you have saved the file, even if the information in the 
computer’s memory is lost, you will still have the information on disk.
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To save a Workbook, select the Workbook -> Save As or key in Apple S  command. The 
first time you save a Workbook, Mesa asks you for the name of the Workbook. Select an 
appropriate name, for example, SampleCompany, enter it into the name field in the Save 
panel and press enter. The name ‘SampleCompany.mesa’ will be visible on the top of the 
workbook see pointing arrow below.

You can also use the Save icon on the Workbook Toolbar to save your Workbook.

Multiple Sheets and Renaming

New Workbook by default opens a single worksheet, to open more worksheets simply go 
to Workbook->New Sheet. A Mesa workbook can contain up to 256 separate worksheets 
within it. Each worksheet has a name, shown on the TAB at the top of the workbook. The 



Mesa User’s Guide         Release 3.0         317

CHAPTER 17        Tutorial

first worksheet is called “Sheet 1”, the next “Sheet 2” and so on. 

You never have to use more than one worksheet, if you don’t want to, however your 
life will be easier, if you organize your work into separate sheets. Also having names 
like a “Sheet 1” and “Sheet 2” is not the most convenient, particularly when dealing 
with large number of worksheets, better way is to rename the sheets to something more 
meaningful. To do that just double-click on the TAB name and type in the new name 
you want. In our example, create two more sheets and name them: Japan, Germany and 
Consolidation.

New Workbook by default opens a single worksheet, to open more worksheets simply go 
to Workbook->New Sheet. A Mesa workbook can contain up to 256 separate worksheets 
within it. Each worksheet has a name, shown on the TAB at the top of the workbook. The 
first worksheet is called “Sheet 1”, the next “Sheet 2” and so on. 

You never have to use more than one worksheet, if you don’t want to, however your 
life will be easier, if you organize your work into separate sheets. Also having names 
like a “Sheet 1” and “Sheet 2” is not the most convenient, particularly when dealing 
with large number of worksheets, better way is to rename the sheets to something more 
meaningful. To do that just double-click on the TAB name and type in the new name 
you want. In our example, create two more sheets and name them: Japan, Germany and 
Consolidation.

Entering Text and Data

It is easy to enter text and data - just move to the cell you want using the mouse and 
cursor keys. In our example we move to A8 cell and type in the text “Widgets” and 
then to A9 cell and type “Gadgets”. To do the month headings, move to B6 and type in 
“Jan”. You could do the same manually for other months, however Mesa will do this for 
you. Highlight cells from B6 through H6, then use Range->Fill->SmartFill, Mesa will 
intelligently fill in the remaining months. Next type in some number values for the Widget 
and Gadget sales,see image below.
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Entering Formulas

In this subsection we will enter some formulas. Formulas are algebraic statements that 
can be evaluated by Mesa to return a value in a cell. The formula in one cell can refer to 
the value in another cell. When the value in a cell changes, the spreadsheet automatically 
recalculates and updates each cell that relies on a value that was changed.

To enter the formulas that calculate the balance in the SampleCompany account. Move 
to cell B11 and enter the formula =B8+B9 and press enter. This formula adds two values 
and places the result in cell B11. Next go to menu Range->Fill->SmartFill to fill ranges 
with sequences of data. Select the cell containing the data you want to start the sequence 
with, and Drag to all the cells you want to copy the data into. Then use the appropriate 
Range->Fill->SmartFill command to paste the data in. In our example we want to copy 
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the data into cells for the next six months.

You can use formulas to refer to cells in other worksheets. You can either use the mouse 
to ‘click and select’ the sheet and cells you want, or simply type the full cell reference 
yourself. 

To refer to a cell on a different worksheet, put the sheet name and a ‘!’ 
(bang) before the cell reference. For example: =”Japan”!A23*25% 
=”Japan”!A23+”Germany”!A23+”USA”!A23 If you change the name of a worksheet, all 
formulas referring to that sheet will automatically update and use the new name. To show 
this, first copy and paste everything in ‘Japan’ to ‘Germany’ and again to ‘Consolidation’. 
Next in ‘Consolidation’ go to B5 and type in ‘=’ and then click to ‘Japan B5, press ‘t’ 
and click to ‘Germany’ B5.

Apply some Style and Colors 

Spreadsheets are easier to read when we introduce some background colors and styles. 
To do that open The Cell Style and Cell Format Inspectors (Select Tools->Inspector from 
the menu or click on the icon on the Toolbar). These two are used to inspect and change 
the contents of a cell, this will reflect the style and formatting information of the current 
cell. Changes made via the Cell Style Inspector will affect the style of all cells in the 
current range.

In our SampleCompany we have used orange as a background color for the row contain-
ing month names, blue for the rows containing number entries for the widget and gadget 
sales and purple for the Total sum. To create this look first open inspectors, select The Cell 
Style or Cell Format Inspectors. Next place your mouse above the rectangular box inside 
Cell Format Inspector, see arrow pointing to the box above. Once you click on the border 
of the box, the color well will appear.( You can also open the color well using the menu 
Tools ->Colors.) The colors may be changed by dragging and dropping a color chip into 
the appropriate color well. The text color of a cell or a range of cells 
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can be changed by dragging and dropping a color chip on the cell or range directly on 
to the worksheet. 

To apply some style to our text we use font well. Use the Sheet Inspector to change the 
default font for the entire sheet. Use the Cell Format Inspector to change the font for the 
selected range. The fonts may be changed by dragging and dropping a font chip into the 
appropriate font well, or by dragging and dropping a color chip onto the cell or range 
directly on the worksheet. Open the font panel by double-clicking on the Font well, or 
with the menu Format->Font. 

Click the Preview button to see the result in the font viewer. If you like what you see, 
click the Set button and your font will be applied to the cell range you specified. 
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Create Chart

Pictures often tell more than words. To enhance our accounting spreadsheet we will 
introduce some charts. To do that we, select the range on the worksheet that we want to 
chart (highlight all the data you want chart to cover, using mouse) If the range includes 
labels at the left and the top, then these labels will be used as the X and Y axis labels 
on the chart. Then click the Chart Icon on the Workbook Toolbar (or use select Tools-
>Charts from the menu). The Chart Selection Panel will appear, see picture below. In 
our example we have opened Japan worksheet and have selected (by highlighting) cells 
A8:B9 cells.

There are three main Chart Types (Bar, Line and Area). Within each Type there are several 
variations: for example a Bar Chart can be Stacked, Horizontal, 3D and more. Click on 
the Type you want. The Chart will draw itself on the worksheet at the current cursor 
position see our Japan - Budget pie chart below.
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The Chart Inspector will also appear. Use the Chart Inspector to change and customize 
the chart. You can have as many charts as you like on the worksheet You can move 
and resize charts. 
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Reports

This lesson will show you how to build a simple report and how to print it. Use the Report 
Designer to create sets of printing commands which can be used repeatedly to print your 
data and make it look good. Start the Report Designer with Tools->Report Designer or by 
clicking the Reports icon on the worksheet Toolbar. 

First, we will name the report. Click in the Name field in the lower right part of the Report 
Inspector and type SampleCompany and click on the Add button. This will add a report 
named SampleCompany to the worksheet.

Next, change the orientation of the report by clicking on the Landscape radio button in the 
Page Layout section of the inspector. Select the first line in the Range section and type 
A2:G999, and click on the Smart Width button on that line. This will set the print range to 
cells A2 through G999 and use the first row as titles on each page. You may question the 
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designation of almost 1,000 lines in the report if you have only filled in a few lines. Mesa 
automatically ignores rows that do not contain any information when printing, so only the 
lines that contain information will be printed.

Now, we will add Tags to the report. The Report Inspector contains a virtual piece of 
paper onto which you can place tags which contain information such as print time and 
more. You can reduce the scale of the piece of paper using the Scaler at the bottom 
right of the Page Area.. Drag the tag marked Page# from the tags and drop in on the top 
part of the piece of paper. Mesa will now print the file name on the top of this report 
every time you print it.

Now click Save to add this report to the Report List.

Click on print button to print out your report. Next drag the report icon onto the 
worksheet.
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Summary

This has been a short tutorial that has stepped you through building a spreadsheet. You 
created a new workbook, entered information and formulas, formatted the information, 
and created a report. 

Mesa has many other features that will help you enter data and present it in a pleasant 
and informative fashion. 

If you have any questions about this tutorial or about using Mesa in general, 
please contact P&L Software Technical Support at +44 1494 432422 or by e-mail at 
mesa@plsys.com 
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